Identificativo articolo: 235009 - Ultima modifica: venerdì 23 marzo 2007 - Revisione: 3.0

Visualizzazione del messaggio di errore "<Percorso> non è un componente aggiuntivo valido di Office" all'avvio di Outlook 2000 o Outlook 2002

Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne una copia di backup e di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

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Sintomi

Quando si avvia Microsoft Outlook 2000 o Microsoft Outlook 2002, viene visualizzato un messaggio di errore analogo al seguente:
Percorso non è un componente aggiuntivo valido di Office.
Questo problema si verifica solitamente quando si installa Microsoft Office 2000 in una cartella diversa da quella predefinita e interessa tutte le versioni di Office 2000.

Quando si avvia Microsoft Outlook 2000, viene visualizzato un messaggio di errore analogo al seguente:
Impossibile installare o caricare il componente aggiuntivo <Unità>:\Programmi\Microsoft Office\Office\Sbcmsync.dll. È possibile risolvere il problema utilizzando Rileva problemi e ripristina. Memoria o risorse di sistema insufficienti o file dll mancante.

Cause

Le voci del Registro di sistema per Small Business Customer Manager vengono impostate durante l'installazione di Small Business Tools, ma i file di programma non sono ancora installati.

Risoluzione

NOTA: esistono vari metodi per risolvere questo problema, a seconda della particolare configurazione in uso. Leggere attentamente tutte le informazioni riportate in questo articolo prima di tentare di eseguire qualsiasi procedura descritta. Le procedure elencate presentano un grado di difficoltà via via crescente.

Inizialmente il messaggio di errore potrebbe essere evitato semplicemente disattivando il componente aggiuntivo Sincronizzazione di Outlook attenendosi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti, quindi fare clic sulla scheda Altro.
  2. Scegliere Opzioni avanzate, quindi Gestione componenti aggiuntivi.
  3. Deselezionare l'opzione Sincronizzazione di Outlook, scegliere OK tre volte e riavviare Outlook.
Se l'errore persiste, chiudere Outlook, rinominare il file Extend.dat e riavviare Outlook. Per rinominare questo file:
  1. Chiudere Outlook, se aperto.
  2. Fare clic sul pulsante Start, scegliere Trova oppure Cerca, quindi File o cartelle oppure Tutti i file e le cartelle.
  3. Nella casella Nome o Nome del file o parte del nome digitare Extend.dat e nella casella Cerca in selezionare Unità disco rigido locali (C:). Se si utilizza Microsoft Windows 95, Microsoft Windows 98 o Microsoft Windows NT 4.0, selezionare l'opzione Includi sottocartelle.
  4. Fare clic su Trova o su Cerca.
  5. In Risultati ricerca selezionare il nome del file e scegliere Rinomina dal menu File.
  6. Cambiare l'estensione di file dat in old, quindi premere INVIO. Se si dispone di più istanze del file, rinominarle tutte.
  7. Chiudere la finestra di dialogo Risultati ricerca.
Se l'errore persiste, provare a eseguire le procedure descritte nelle sezioni seguenti, scegliendo quella più adatta per l'installazione di Office in uso e la configurazione di sistema.

Esistono altre due possibili soluzioni a questo problema. Utilizzare la prima soluzione se non si desidera installare Small Business Customer Manager nel computer e utilizzare la seconda se si desidera installarlo.

Small Business Customer Manager non installato nel computer

Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema è a rischio e pericolo dell'utente.
Per modificare il Registro di sistema, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit, quindi scegliere OK.
  2. Spostarsi sulla seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\SBCM.ADDIN.1
  3. Dopo avere selezionato la chiave Sbcm.addin.1 premere CANC.
  4. Chiudere l'editor del Registro di sistema.

Small Business Customer Manager installato nel computer

Se si desidera installare Small Business Customer Manager nel computer:
  1. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
  2. Fare doppio clic su Installazione applicazioni.
  3. Selezionare l'opzione relativa al secondo disco di Microsoft Office 2000, quindi scegliere Aggiungi/Rimuovi. Verrà avviato il programma di installazione in modalità manutenzione.
  4. Fare clic sul pulsante accanto a Aggiungi/Rimuovi funzionalità.
  5. Fare clic per espandere Small Business Tools e individuare Small Business Customer Manager.
  6. Fare clic sulla X di colore rosso e selezionare Esecuzione dal computer locale.
  7. Scegliere Aggiorna. Se richiesto, inserire il CD 2 e completare l'installazione.

Informazioni

Se l'installazione di Office fosse presente nella cartella predefinita, potrebbe essere necessario completare un'altra procedura per la risoluzione del problema, se si desidera installare Small Business Customer Manager. Quando si tenta di installare il programma utilizzando il programma di installazione in modalità di manutenzione, potrebbe infatti venire visualizzato un messaggio di errore analogo al seguente:
Impossibile installare Small Business Customer Manager nella stessa cartella che contiene una versione precedente di Access o una versione runtime di Access. Disinstallare qualsiasi versione precedente di Access prima di installare Small Business Customer Manager.
Per completare l'installazione, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Trova oppure Cerca, quindi File o cartelle oppure Tutti i file e le cartelle.
  2. Nella casella Nome o Nome del file o parte del nome digitare Msaccess.exe.
  3. Nella casella Cerca in selezionare Risorse del computer e fare clic su Trova o su Cerca.
  4. In Risultati ricerca selezionare il nome del file e scegliere Rinomina dal menu File.
  5. Rinominare il file Msaccess.old in Msaccess.exe.

    Se viene trovato più di un file, rinominare quello contenuto nella stessa cartella degli altri programmi di Office.
  6. Eseguire l'installazione in modalità manutenzione per il secondo disco di Office 2000 utilizzando lo strumento Installazione applicazioni del Pannello di controllo e installare Small Business Contact Manager in corrispondenza di Microsoft Small Business Tools.
Verrà installata una copia runtime di Microsoft Access.

Se l'installazione di Small Business Customer Manager fosse stata effettuata in precedenza nel computer e quindi spostata in un'altra cartella, potrebbe essere necessario mettere a punto il programma affinché faccia riferimento alla nuova ubicazione. Per effettuare questa operazione:
  1. Chiudere qualsiasi programma aperto.
  2. Fare clic sul pulsante Start, scegliere Prompt di MS-DOS o Prompt dei comandi, in base alla versione di Microsoft Windows in uso.

    Per Microsoft Windows 2000 e Microsoft Windows Millennium Edition (ME) fare clic sul pulsante Start, scegliere Accessori, quindi Prompt di MS-DOS.
  3. Al prompt di MS-DOS digitare quanto riportato di seguito e premere INVIO:
    cd "\programmi\microsoft office\office"
    NOTA: includere le virgolette.

  4. Al prompt di MS-DOS digitare quanto riportato di seguito, quindi premere INVIO:

    Per Microsoft Windows 95, Microsoft Windows 98 e Windows ME c:\windows\system\regsvr32.exe sbcmsync.dll
    Oppure
    Per Windows NT c:\winnt\system32\regsvr32.exe sbcmsync.dll
  5. Viene visualizzato il seguente messaggio:
    DllRegisterServer in sbcmsync.dll eseguita con successo.
  6. Scegliere OK e chiudere il prompt di MS-DOS.
NOTA: Small Business Customer Manager (SBCM) non è incluso in Office XP, ma è possibile utilizzare con Office XP la versione di SBCM fornita con Microsoft Office 2000, purché venga applicata la patch di Microsoft Small Business Tools 2000.

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
297876  (http://support.microsoft.com/kb/297876/ ) Small Business Customer Manager rimosso dopo l'aggiornamento a Office XP Small Business Edition

Le informazioni in questo articolo si applicano a
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
Chiavi: 
kbsetup kbstartprogram kberrmsg kbpending kbprb KB235009
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