Article ID: 235279 - Last Review: March 22, 2007 - Revision: 3.3 ACC2000: "Can't Find the Database You Specified" Error When Starting Access 97 on Computer with Office 2000 Small Business ToolsThis article was previously published under Q235279 Moderate: Requires basic macro, coding, and interoperability skills.
This article applies only to a Microsoft Access database (.mdb). IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base: 256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
SYMPTOMS
When you start Microsoft Access, you may receive the following error message:
Can't find the database you specified, or you didn't specify a database at all.
Specify a valid database in the command line and include a path if necessary.
CAUSE
You have installed Microsoft Access 97, either as a stand-alone program or by using the Custom installation option from the Microsoft Office 97 Professional compact disc, into the default installation folder on a computer that already has the Microsoft Office 2000 Small Business Customer Manager installed. The most common installation procedure that will cause this error is to install the Microsoft Office 2000 Small Business Edition, and then to install the Microsoft Office 2000 Small Business Tools.
RESOLUTION
Remove the installation of Access 97, and then re-install it to a folder other than the default folder. To do so, follow these steps. NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
MORE INFORMATION
The Microsoft Office Small Business Customer Manager, which ships with the Small Business Tools, is based on a special type of Access 2000 run-time components. During the installation of the Small Business Tools, the Access 2000 run-time components are installed to the C:\Program Files\Microsoft Office\Office folder. When you try to install Access 97 on the same computer, it will try to use the same default folder. When Access 97 is installed, the Setup program checks for existing programs. When it finds the Access 2000 version of Msaccess.exe, it does not install the Access 97 version because newer versions of files are not overwritten during installation. By renaming the existing Access 2000 run-time components, and then installing Access 97 to a different folder, you can circumvent this file checking and have Access 97 successfully installed on the computer. REFERENCES
The following article describes an issue that results in an error message:
235280
(http://support.microsoft.com/kb/235280/EN-US/
)
ACC2000: "Can't find the database you specified" Error When Starting Access 97 After Upgrade to Office 2000
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