Part 2 of "Troubleshooting invalid page faults (IPFs) and exception errors" in Word 2000

Article translations Article translations
Article ID: 236383 - View products that this article applies to.
This article was previously published under Q236383
This article has been archived. It is offered "as is" and will no longer be updated.
For a Microsoft Word 97 version of this article, see 168198.
Expand all | Collapse all

On This Page

SUMMARY

This article is part 2 of a series of three Knowledge Base articles titled "Troubleshooting IPFs and Exception Errors" that present a systematic approach to eliminating error messages in Microsoft Word 2000.

For more information, please see the following articles:
236319 WD2000: Part 1: Troubleshooting Invalid Page Faults (IPFs) and Exception Errors
236423 WD2000: Part 3: Troubleshooting Invalid Page Faults (IPFs) and Exception Errors

MORE INFORMATION

Continue troubleshooting invalid page faults and exception errors with the following steps after you have completed part 1 of this series of articles.

Troubleshooting Invalid Page Faults and Exception Errors That Occur While Printing or Formatting the Document

Invalid page faults and exception errors can occur while you are printing or formatting the document. These actions trigger the use of several Windows components, including the following Windows drivers:

Is the Printer Driver Damaged?

Word frequently queries the printer driver for information it needs when formatting and printing a document. A damaged printer driver can cause an invalid page fault or exception error to occur when you are working in a document.

Most non-PostScript (PCL) printer drivers use a common core file called the Unidrv.dll. This includes Microsoft Fax and Generic/Text Only. For this reason, if you are using a PCL printer driver and want to troubleshoot the printer driver, it is necessary to install a non-PCL printer driver.

Almost all PostScript printer drivers use a common core file called Pscript.drv. For this reason, if you are using a PostScript printer driver and want to troubleshoot the printer driver, it is necessary to install a non-PostScript printer driver.

To troubleshoot this problem, install a different printer driver by following these steps:
  1. Quit all Microsoft Office programs.
  2. Click Start, point to Settings, and then click Printers.

    NOTE: In Microsoft Windows XP, click Start and then click Printers and Faxes.
  3. Use the appropriate method for your type of printer.
    • Method 1: PostScript Printer

      If you currently print to a PostScript printer, follow these steps:

      1. Double-click Add Printer to run the Add Printer Wizard.

        NOTE: In Windows XP, click Add a Printer under Printer Tasks.
      2. Follow the instructions in the wizard to install a local PCL printer driver, or some other non-PostScript printer driver.
    • Method 2: Non-PostScript Printer

      If you currently print to a non-PostScript printer (for example; a PCL, dot-matrix, or ink-jet type printer), follow these steps:

      1. Double-click Add Printer to run the Add Printer Wizard.

        NOTE: In Windows XP, click Add Printer under Printer Tasks.
      2. Follow the instructions in the wizard to install a local PostScript printer.
  4. Right-click the printer icon, and then click Set As Default on the shortcut menu.
  5. Start Word normally (without using the /a switch) and try to reproduce the problem.
If the problem is corrected, you have identified the problem as a damaged printer driver. Follow the steps in the next section, "Remove and Reinstall the Printer," to resolve the problem.

If Word fails to function correctly, continue troubleshooting using the steps in the "Is It the Video Driver?" section of this article.

Remove and Reinstall the Printer:

NOTE: The following steps may require your Windows 95 or Windows 98 CD or the printer driver files supplied by the manufacturer of the printer. To remove and reinstall the printer driver, follow these steps:
  1. Quit all Microsoft Office programs.
  2. Click Start, point to Settings, and then click Printers.

    NOTE: In Windows XP, click Start, and then click Printers and Faxes.
  3. Right-click the printer that was giving you the problem (the printer that you were using before you started troubleshooting the printer driver).
  4. On the shortcut menu, click Delete.
  5. Click Yes to confirm the deletion. The following message appears:
    Some files were used only for this printer and are no longer needed. Would you like to delete these files now?
    Click Yes.

  6. Click Double-click Add Printer to run the Add Printer Wizard.

    NOTE: In Windows XP, click Add Printer under Printer Tasks.
  7. Click Follow the instructions in the wizard to install the correct printer driver for the printer you print to, or follow the instructions that came with your printer.
  8. Click After the printer is installed, right-click its icon and click Set As Default on the shortcut menu.


Is It the Video Driver?

Word frequently queries the video driver for information it needs when formatting and printing the document. A damaged video driver can cause an invalid page fault or exception error to occur.

To troubleshoot this problem, install a different video driver by following the steps for your version of Microsoft Windows.

In Windows 95, Windows 98, or Windows Me:
  1. Quit all Microsoft Windows programs.
  2. Right-click the Windows desktop.
  3. On the shortcut menu, click Properties.
  4. Click to select the Settings tab. Note the settings for the desktop area, color palette, and font size. You may need to know these if you want to return the display settings to their original state.

    NOTE: In Microsoft Windows Millennium Edition (Me), click Advanced.
  5. Click Change Display Type. Note the display adapter that is currently in use. You may need this if you want to return the display settings to their original state.
  6. For the Adapter type, click Change.
  7. Click Show All Devices.
  8. At the top of the Manufacturers list, click Standard Display Types.
  9. For the Model, click Standard Display Adapter (VGA).
  10. Click the OK and Close buttons to close the dialog boxes.
  11. Click Yes when Windows asks you to restart your computer. When the computer is restarted, your display appears in 640x480 resolution with 16 colors.
In Windows 2000 or Windows XP:
  1. Restart your computer.
  2. Before the Windows 2000 or Windows XP splash screen appears, press F8.
  3. Select Enable VGA Mode, and then press ENTER.
  4. In the Please select the operating system to start section, select Microsoft Windows 2000 Professional or Microsoft Windows XP, and then press ENTER.
NOTE: The operating system now loads the Standard VGA driver.

Start Word normally (without using the /a switch), and then try to reproduce the problem. If the problem is corrected, you have identified the problem as a damaged or incompatible video driver. You need to contact the manufacturer of the video card for an updated video driver.

For information about how to contact your video card manufacturer, visit the following Microsoft Web site:
http://support.microsoft.com/gp/vendors

If Word fails to function correctly, continue troubleshooting using the steps in the next section of this article, "Troubleshooting Invalid Page Faults and Exception Errors That Occur While Working in the Document."

Back to printing or formatting


Troubleshooting Invalid Page Faults and Exception Errors That Occur While Working in the Document

Invalid page faults and exception errors can occur while you are working in a document because of any of the following:

Back to Topics

Is the Custom Dictionary Damaged?

When you type a space or press ENTER, background spelling attempts to check the word. If it does not find the word you typed in the main dictionary, it checks the custom dictionary. When you run Spelling and Grammar and click Add to add a word to the spelling dictionary, the word is actually added to the custom dictionary. If the custom dictionary gets damaged for some reason, it can cause an error when you start to check spelling.

To correct this problem, follow these steps.

For Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows NT 4.0:

  1. Quit all Office programs.
  2. Click Start, point to Find, and then click Files or Folders.
  3. In the Named box, type *.dic.
  4. Set the Look in box to your local hard disk (or to an alternate user location if you are running Word from a network server).
  5. Click Find Now to search for the file. The default name for the custom dictionary is Custom.dic, and the default location is in the following folder:
    \Application Data\Microsoft\Proof
    NOTE: Your custom dictionary file may have a different file name, and it may be located in a different folder than the default. If you are using profiles, your custom dictionary may be located in your Profiles folder.
  6. For each occurrence of a custom dictionary file that appears in the Find dialog box, right-click the file. Click Rename on the shortcut menu. Type a new name for the old custom dictionary file (for example, type OldCustom.dic), and then press ENTER.
  7. Close the Find dialog box, restart Word as you normally do (without using the /a switch), and try to reproduce the problem.
For Windows Me or Windows 2000:

  1. Quit all Office programs.
  2. Click Start, point to Search, and then click For Files or Folders.
  3. In the Search for files or folders named box, type *.dic.
  4. Set the Look in menu to your local hard disk (or to an alternate user location if you are running Word from a network server).
  5. Click Search Now to search for the file. The default name for the custom dictionary is Custom.dic, and the default location is in the following folder:
    \Application Data\Microsoft\Proof
    NOTE: Your custom dictionary file may have a different file name, and it may be located in a different folder than the default. If you are using profiles, your custom dictionary may be located in your Profiles folder.
  6. For each occurrence of a custom dictionary file that appears in the Search Results dialog box, right-click the file. Click Rename on the shortcut menu. Type a new name for the old custom dictionary file (for example, type OldCustom.dic), and then press ENTER.
  7. Close the Search Results dialog box, restart Word as you normally do (without using the /a switch), and try to reproduce the problem.
For Windows XP:
  1. Quit all Office programs.
  2. Click Start and then click Search.
  3. Click All Files or Folders, and then click More Advanced Options.
  4. Select the Search hidden files and folders check box.
  5. In the All or part of a file name box, type *.dic.
  6. Set the Look in menu to your local hard disk (or to an alternate user location if you are running Word from a network server).
  7. Click Search Now to search for the file. The default name for the custom dictionary is Custom.dic, and the default location is in the following folder:
    \Application Data\Microsoft\Proof
    NOTE: Your custom dictionary file may have a different file name, and it may be located in a different folder than the default. If you are using profiles, your custom dictionary may be located in your Profiles folder.
  8. For each occurrence of a custom dictionary file that appears in the Search Results dialog box, right-click the file. Click Rename on the shortcut menu. Type a new name for the old custom dictionary file (for example, OldCustom.dic), and then press ENTER.
  9. Close the Search Results dialog box, restart Word as you normally do (without using the /a switch), and try to reproduce the problem.
If the problem is corrected, you have identified the problem as a damaged custom dictionary file. At this point you have created a new custom dictionary file, and it does not contain any of the words that you added in the past. If you want to add the words from the old custom dictionary file, follow the steps in the "Adding Words Back to the New Custom Dictionary" section of this article.

If Word fails to work correctly, continue troubleshooting by using the steps in the "Is It the AutoCorrect (ACL) File?" section of this article.

Adding Words Back to the New Custom Dictionary:

To add words from an old custom dictionary (or any text file) to a current (or new) custom dictionary, follow these steps:
  1. Open the old custom dictionary file in Word. If you recently renamed the old custom dictionary file using the steps outlined in this article, the file is most likely called OldCustom.dic.
  2. If background spelling is turned on, you should see red wavy underlines under each word. Right-click each word, and then click Add on the shortcut menu.

    NOTE: If background spelling is not turned on, click Spelling and Grammar on the Tools menu. After all of the words are added, you can close the file and delete it.
Back to working in the document

Is It the AutoCorrect (ACL) File?

When you type a space or press ENTER, the background AutoCorrect attempts to correct the spelling or grammar of a word or add special symbols in place of some characters. The AutoCorrect list (ACL) stores a list of what words or characters to act upon, and what to substitute for them.

If this file is damaged, you can experience an IPF when Word tries to access the ACL file. To correct this problem, follow these steps.

In Windows 95, Windows 98, or Windows NT 4.0:

  1. Quit all Office programs.
  2. Click Start, point to Find, and then click Files or Folders.
  3. In the Named box, type *.acl.
  4. Set the Look in box to your Windows folder.
  5. Click Find Now. When the search is completed, a list of .acl files appears. These files are stored in the Windows folder.

    IMPORTANT: Three of the .acl files are named Mso1033.acl, Mso2057.acl, and Mso3081.acl. Do not rename or delete these files unless you are instructed to do so by Microsoft Technical Support or unless you completely remove Office 2000 from the computer.
  6. Right-click one of the .acl files (for example, User.acl). Then click Rename on the shortcut menu.
  7. Press END on the keyboard. Type .old and then press ENTER. The file appears with ".old" appended to the end (for example, User.acl.old).
  8. Except for Mso1033.acl, Mso2057.acl, and Mso3081.acl, repeat steps 3 through 5 for all .acl files in the Windows folder.
  9. Quit the Find dialog box, restart Word normally (without using the /a switch), and then try to reproduce the problem.
In Windows Me or Windows 2000:

  1. Quit all Office programs.
  2. Click Start, point to Search, and then click For Files or Folders.
  3. In the Search for files or folders named box, type *.acl.
  4. Set the Look in box to your Windows folder.
  5. Click Search Now. When the search is completed, a list of .acl files appears. These files are stored in the Windows folder.

    IMPORTANT: Three of the .acl files are named Mso1033.acl, Mso2057.acl, and Mso3081.acl. Do not rename or delete these files unless you are instructed to do so by Microsoft Technical Support or unless you completely remove Office 2000 from the computer.
  6. Right-click one of the .acl files (for example, User.acl). Then click Rename on the shortcut menu.
  7. Press END on the keyboard. Type .old and then press ENTER. The file appears with ".old" appended to the end (for example, User.acl.old).
  8. Except for Mso1033.acl, Mso2057.acl, and Mso3081.acl, repeat steps 3 through 5 for all the .acl files in the Windows folder.
  9. Quit the Search Results dialog box, restart Word normally (without using the /a switch), and try to reproduce the problem.
In Windows XP:
  1. Quit all Office programs.
  2. Click Start and then click Search.
  3. Click All Files or Folders, and then click More Advanced Options.
  4. Select the Search hidden files and folders check box.
  5. In the All or part of a file name box, type *.acl.
  6. Click Search Now. When the search is completed, a list of .acl files appears. These files are stored in the Windows folder.

    IMPORTANT: Three of the .acl files are named Mso1033.acl, Mso2057.acl, and Mso3081.acl. Do not rename or delete these files, unless you are instructed to do so by Microsoft Technical Support, or unless you completely remove Office 2000 from the computer.
  7. Right-click one of the .acl files (for example, User.acl), and then click Rename on the shortcut menu.
  8. Press END. Type .old and then press ENTER. The file name appears with ".old" appended to the end (for example, User.acl.old).
  9. Except for Mso1033.acl, Mso2057.acl, and Mso3081.acl, repeat steps 3 through 5 for all .acl files in the Windows folder.
  10. Close the Search Results dialog box, restart Word normally (without using the /a switch), and then try to reproduce the problem.
If the problem is corrected, you have identified the problem as a damaged ACL file.

If Word fails to work correctly, continue troubleshooting using the steps in the section of this article titled "Is It Spelling and Grammar?"

Back to working in the document

Is It Spelling and Grammar?

When you type a space or press ENTER, background Spelling and Grammar checks what you typed and flags it as a misspelled word (with a red wavy underline) or as a grammar error (with a green wavy underline) if needed. If either the spelling or grammar files are damaged, it may cause an error when you type. To test whether this is the problem, try to reproduce the problem with background Spelling and Grammar turned off.

To turn off (or turn on) background Spelling and Grammar, follow these steps:
  1. Open the document if possible.
  2. Immediately, before doing anything else, click Options on the Tools menu.
  3. Click to select the Spelling and Grammar tab.
  4. Click to clear the Check spelling as you type and the Check grammar as you type check boxes.
  5. Click OK and try to reproduce the problem.
If the problem is corrected, or if you could not run the above test, you may have identified the problem as damaged proofing tools. To correct the problem, run Detect and Repair on the Help menu. After completing Detect and Repair, turn background Spelling and Grammar back on.

If Word fails to work correctly, continue troubleshooting using the steps in the "Are the Fonts Damaged?" section of this article.

Back to working in the document

Are the Fonts Damaged?

A damaged font can cause an IPF when working with Word (or any other Windows program).

If a document crashes while you are working in it, try to determine what fonts are in the document, and apply these fonts to a new document based on Normal.dot. If the problem occurs in the new document, systematically reduce the number of fonts in the new document until you are left with the font causing the problem.

NOTE: Tahoma is the font that is used in the dialog boxes and menus in Word and Office. If Word is crashing when you start it, one possible cause might be a damaged Tahoma font. Follow the instructions below for removing and reinstalling the Tahoma font.

After you determine (or suspect) a damaged font, follow these steps to remove and reinstall the font.

NOTE: This procedure removes the font from your system and requires you to be able to reinstall the font from its original source.
  1. Quit all Office programs.
  2. Click Start, point to Settings, and click Control Panel.

    NOTE: In Windows XP, click Start and then click Control Panel.
  3. Double-click Fonts.
  4. Drag the font (or fonts) that you think may be damaged to your desktop (or to some other location outside of the font folder). The font is now "removed" from your computer. Any document formatted with that font actually has another font substituted.
  5. Quit the font folder, restart Word normally (without using the /a switch), and try to reproduce the problem.
If the problem is corrected, you may have identified the problem as a damaged font. To resolve the problem, run Detect and Repair on the Help menu. After completing Detect and Repair, try to reproduce the problem.

NOTE: If the font you removed came from a different software program, you may need to reinstall that program to replace the font on your system.

If Word fails to work correctly, continue troubleshooting using the steps in the section of part 3 of this article titled "Starting Word as Cleanly As Possible."



For additional information about troubleshooting invalid page faults and exception errors in Word 2000, click the article number below to view the article in the Microsoft Knowledge Base:
236423 WD2000: Part 3: Troubleshooting Invalid Page Faults (IPFs) and Exception Errors

Properties

Article ID: 236383 - Last Review: February 28, 2014 - Revision: 2.0
APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbnosurvey kbarchive kberrmsg kbtshoot kbdta kbinfo wd2000 KB236383

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com