OFF2000: Errore 1402 durante l'esecuzione del programma di installazione di Office 2000

Traduzione articoli Traduzione articoli
Identificativo articolo: 236427 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I236427
*********************************************************************
**                           - ATTENZIONE -                        **
**     LE INFORMAZIONI SOTTO RIPORTATE SONO PRELIMINARI E NON SONO **
**     STATE CONFERMATE O VERIFICATE DA MICROSOFT. UTILIZZARLE     **
**     CON PRUDENZA.                                               **
*********************************************************************
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di installare Microsoft Office 2000 viene visualizzato un messaggio di errore simile al seguente:
Errore 1402. Impossibile aprire la chiave: <NomeChiave>. Errore di sistema 1009.

Assicurarsi di disporre di diritti di accesso sufficienti per tale chiave oppure contattare il personale di supporto.
dove <NomeChiave> è il nome della chiave del Registro di configurazione di Windows su cui l'installazione di Office sta tentando di scrivere.

Cause

Questo problema si verifica in presenza delle seguenti condizioni:
  • Si utilizza Microsoft Windows 95, Microsoft Windows 98 o Microsoft Windows Millennium Edition (Me).

    e

  • È attiva l'opzione Profili utente.

    e

  • Si è verificato un problema relativamente al profilo attivo.

Workaround

Per aggirare questo problema, attenersi alla seguente procedura.

Metodo 1: controllare che il Registro di configurazione non sia danneggiato

Microsoft Windows Millennium Edition (Me) e Microsoft Windows 98 sono dotati di uno strumento chiamato Controllo del Registro in grado di eseguirne la scansione per verificare che non sia danneggiato e, se necessario, ripristinarne una copia di backup. Seguire le procedure relative a come utilizzare lo strumento Controllo del Registro per eseguirne la scansione in base al sistema operativo in uso:

Per Windows Me:

  1. Fare clic sul pulsante Start, scegliere Programmi, Accessori, Utilità di sistema e infine Microsoft System Information.
  2. Scegliere Controllo del registro dal menu Strumenti. Può essere visualizzato il seguente messaggio di errore:
    Errore durante l'accesso al registro di sistema. Il computer verrà ora riavviato e gli errori saranno corretti automaticamente.
    Se viene visualizzato questo messaggio di errore procedere al passaggio 3.

    Se non viene visualizzato il messaggio di errore, è possibile scegliere di compattare e riparare il danno alla struttura di dati interna del Registro di configurazione di sistema, attenendosi alla seguente procedura:

    1. Chiudere tutti i programmi in esecuzione.
    2. Fare clic sul pulsante Start e scegliere Esegui. Nella casella Apri digitare quando segue e fare clic su OK:
      scanreg /fix
    3. Scegliere per riavviare il computer.
  3. Per riavviare il computer scegliere OK.
  4. Seguire i passaggi rimanenti per ripristinare una copia integra del Registro di configurazione.
  5. Eseguire il programma di installazione di Office.
Se il problema persiste provare con il metodo 2 o 3.

Per Windows 98:

  1. Riavviare il computer, premere e tenere premuto il tasto CTRL finché viene visualizzato il menu Esecuzione automatica di Windows 98, quindi scegliere Prompt dei comandi con supporto di rete.
  2. Al prompt dei comandi digitare scanreg /fix e premere INVIO.
  3. Una volta che lo strumento Controllo del Registro ha terminato di riparare il Registro di configurazione, premere INVIO.
  4. Al prompt dei comandi digitare scanreg /opt e premere INVIO.

    NOTA: l'opzione della riga di comando /opt fa sì che lo strumento Controllo del Registro ottimizzi il Registro di configurazione rimuovendo lo spazio inutilizzato.
  5. Riavviare il computer.
  6. Eseguire il programma di installazione di Office.
Se il problema persiste provare con il metodo 2 o 3.

Metodo 2: eseguire l'installazione con un profilo diverso

Se il profilo mediante il quale si è collegati è danneggiato potrebbe essere possibile eseguire l'installazione con un profilo utente diverso. Se accedendo al sistema con un profilo diverso si riesce a installare Office, potrebbe essere necessario eliminare e ricreare il profilo con cui si verificavano problemi. In caso contrario lo stesso problema si potrà ripresentare quando si tenterà di installare Office dopo essersi ricollegati con quel profilo.

Per ulteriori informazioni sulla rimozione di un profilo utente esistente, vedere l'articolo seguente della Knowledge Base (gli articoli con prefisso 'Q' contengono informazioni in inglese):
156826 How to Disable and Delete User Profiles


NOTA: se sono attivati i profili e il menu Avvio è personalizzato in base all'utente, l'installazione di Office deve essere eseguita da ogni utente per cui esiste un profilo in Windows 95 o Windows 98. Gli unici utenti che non devono eseguire l'installazione sono quelli per cui non esiste un profilo sul computer; quando accederanno al sistema per la prima volta, come profilo verrà copiato il profilo utente predefinito. Il profilo utente predefinito comprende tutte le informazioni del Registro di configurazione e i collegamenti necessari per avviare i programmi di Office.

Per ulteriori informazioni sulla installazione di Office 2000 con i profili utente attivati, vedere l'articolo seguente della Knowledge Base (gli articoli con prefisso 'Q' contengono informazioni in inglese):
233529 OFF2000: All Users Must Run Setup on Windows 95/98 with Profiles
Se con questo metodo il problema non viene risolto, provare con le procedure indicate nel metodo 3.

Metodo 3: disattivare i profili utente prima di eseguire l'installazione

  1. Fare clic sul pulsante Start/Avvio, scegliere Impostazioni, quindi fare clic su Pannello di controllo. Fare doppio clic su Password.
  2. Scegliere la scheda Profili utente. Selezionare Tutti gli utenti utilizzano le stesse impostazioni per il desktop.
  3. Scegliere OK. Riavviare il computer se richiesto.
  4. Installare Office 2000. Se l'installazione di Office viene completata correttamente è possibile riattivare i profili utente.
NOTA: riattivando i profili utente possono verificarsi problemi di esecuzione dei programmi di Office. Per ulteriori informazioni sulle procedure aggiuntive da seguire prima di eseguire i programmi di Office 2000 dopo avere riattivato i profili utente, vedere i seguenti articoli della Microsoft Knowledge Base (gli articoli con prefisso 'Q' contengono informazioni in inglese):
234017 OFF2000: Error Starting Programs After Disabling Profiles
233529 OFF2000: All Users Must Run Setup on Windows 95/98 with Profiles

Riferimenti

Per ulteriori articoli contenenti informazioni generali sulla risoluzione degli errori di Office, fare clic sul collegamento riportato di seguito:
Troubleshooting Office 2000 (informazioni in lingua inglese)

Proprietà

Identificativo articolo: 236427 - Ultima modifica: mercoledì 18 ottobre 2006 - Revisione: 4.1
Le informazioni in questo articolo si applicano a
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
Chiavi: 
kbdta kberrmsg kbprb xlwinsetup KB236427
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com