OFF2000: Office 2000 설치 프로그램 실행 중 오류 1402

기술 자료 번역 기술 자료 번역
기술 자료: 236427 - 이 문서가 적용되는 제품 보기.
이 문서는 이전에 다음 ID로 출판되었음: KR236427
********************************************************************* 
**                             - 경고 -                            ** 
**          아래의 정보는 사전 정보이며 마이크로소프트에           ** 
**          의해서 확인 또는 테스트되지 아니하였습니다.            **
**          신중하게 사용하십시오.                                 **
*********************************************************************
모두 확대 | 모두 축소

이 페이지에서

현상

Microsoft Office 2000을 설치하려고 할 때 아래와 유사한 오류 메시지가 나타날 수 있습니다.
오류 1402. 키를 열 수 없습니다: <Keyname>. 시스템 오류 1009.

그 키에 대한 액세스 권한이 충분한지 확인하거나, 해당 관리자에게 문의하십시오.
여기서 <Keyname>은 Office 설치 프로그램이 Windows 레지스트리에 쓰려고 시도하는 키 이름입니다.

원인

이 문제는 다음과 같은 경우 발생합니다.
  • Microsoft Windows 95, Microsoft Windows 98 또는 Microsoft Windows Me를 실행하는 경우
-및-
  • 사용자 프로필을 설정한 경우
-및-
  • 활성 프로필에 문제가 있는 경우

해결 과정

이 문제를 해결하려면 다음 단계를 수행하십시오.

방법 1: 레지스트리 손상 확인

Microsoft Windows Me와 Microsoft Windows 98에는 레지스트리가 손상되었는지 검사하고 필요하면 레지스트리 백업을 복원할 수 있는 레지스트리 검사기라고 하는 도구가 들어 있습니다. 사용하는 운영 체제에 해당하는 단계에 따라 레지스트리 검사기를 사용하여 레지스트리를 스캔합니다.

Windows Me의 경우:

  1. 시작을 누르고 프로그램, 보조프로그램, 시스템 도구를 차례로 가리킨 다음 시스템 정보를 누릅니다.
  2. 도구 메뉴에서 레지스트리 검사기를 누릅니다. 아래와 같은 오류 메시지가 나타날 수 있습니다.
    시스템 레지스트리를 액세스하는 도중 오류가 발생하였습니다. 시스템을 다시 시작하여 오류를 수정합니다.
    이 오류 메시지가 나타나면 3단계로 진행합니다.

    오류 메시지가 나타나지 않으면 다음 단계를 수행하여 시스템 레지스트리의 내부 데이터 구조를 압축하고 손상을 복구할 수 있습니다.

    1. 실행 중인 모든 프로그램을 닫습니다.
    2. 시작을 누른 다음 실행을 가리킵니다. 열기 상자에 아래 명령을 입력하고 확인을 누릅니다.
      scanreg /fix
    3. 를 눌러 컴퓨터를 다시 시작합니다.
  3. 컴퓨터를 다시 시작하려면 확인을 누릅니다.
  4. 남은 단계를 수행하여 레지스트리를 복구합니다.
  5. Office 설치 프로그램을 실행합니다.
문제가 지속되면 방법 2 또는 방법 3을 시도합니다.

Windows 98의 경우:

  1. 컴퓨터를 다시 시작하고 Windows 98 Startup 메뉴가 나타날 때까지 Ctrl 키를 누른 다음 Command prompt only를 선택합니다.
  2. 명령 프롬프트에서 scanreg /fix를 입력한 다음 Enter를 누릅니다.
  3. 레지스트리 검사기 도구가 레지스트리 복구를 완료한 후에 Enter를 누릅니다.
  4. 명령 프롬프트에서 scanreg /opt를 입력한 다음 Enter를 누릅니다.

    참고: /opt 명령줄 스위치를 사용하면 레지스트리 검사기 도구가 사용하지 않는 공간을 제거하여 레지스트리를 최적화합니다.
  5. 컴퓨터를 다시 시작합니다.
  6. Office 설치 프로그램을 실행합니다.
문제가 지속되면 방법 2 또는 방법 3을 시도합니다.

방법 2: 다른 프로필에서 설치 프로그램 실행

사용자가 로그온한 프로필이 손상된 경우 다른 사용자 프로필에서 설치 프로그램을 실행할 수 있습니다. 다른 프로필로 로그온하여 Office를 설치할 수 있는 경우 문제가 있는 프로필을 삭제하고 다시 만들어야 할 수 있습니다. 그렇지 않으면 해당 프로필로 다시 로그온하여 Office를 설치하려고 하면 같은 문제가 발생할 수 있습니다.

기존의 사용자 프로필 제거에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
156826 How to Disable and Delete User Profiles


참고: 프로필을 설정했고 사용자별 시작 메뉴가 있는 경우 Windows 95 또는 Windows 98에 기존 프로필이 있는 각 사용자는 Office용 설치 프로그램을 실행해야 합니다. 설치 프로그램을 실행하지 않아도 되는 유일한 사용자는 컴퓨터에 기존 프로필이 없어 처음 로그온할 때 기본 사용자 프로필이 해당 프로필로 복사되는 사용자입니다. 기본 사용자 프로필에는 Office 프로그램을 시작하는 데 필요한 레지스트리 정보와 바로 가기가 모두 포함되어 있습니다.

사용자 프로필을 설정한 상태에서 Office 2000 설치에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
233529 OFF2000: All Users Must Run Setup on Windows 95/98 with Profiles
이 방법으로 문제가 해결되지 않을 경우 방법 3에서 설명하는 단계를 시도하십시오.

방법 3: 설치 프로그램을 실행하기 전에 사용자 프로필 해제

  1. 시작 메뉴에서 설정을 가리키고 제어판을 누릅니다. 암호 제어판을 두 번 누릅니다.
  2. 사용자 프로필 탭을 누릅니다. '이 PC의 모든 사용자가 동일한 기본 설정 및 바탕 화면 사용' 을 누릅니다.
  3. 확인을 누릅니다. 컴퓨터를 다시 시작할 것인지 물으면 를 누릅니다.
  4. Office 2000을 설치합니다. Office가 성공적으로 설치되면 사용자 프로필을 다시 설정할 수 있습니다.
참고: 사용자 프로필을 다시 설정한 경우 Office 프로그램 실행 중 문제가 발생할 수 있습니다. 사용자 프로필을 설정한 후 Office 2000 프로그램을 실행하기 전에 수행해야 하는 추가 단계에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
234017 OFF2000: Error Starting Programs After Disabling Profiles
233529 OFF2000: All Users Must Run Setup on Windows 95/98 with Profiles

참조

Office 설치 시의 특정 오류를 해결하는 방법에 대한 자세한 내용은 다음 문서를 참조하십시오.
Windows Installer Errors for Office 2000
Office 오류를 해결하는 방법에 대한 일반적인 정보를 보려면 다음 문서를 참조하십시오.
Troubleshooting Office 2000

속성

기술 자료: 236427 - 마지막 검토: 2006년 10월 18일 수요일 - 수정: 2.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
키워드:?
kberrmsg kbdta kbprb xlwinsetup KB236427

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com