Office 2000 セットアップの実行中にエラー メッセージ "内部エラー 2351" または "内部エラー 2355" が表示される

文書翻訳 文書翻訳
文書番号: 236437 - 対象製品
この記事は、以前は次の ID で公開されていました: JP236437
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
重要 : この資料には、コンピュータのセキュリティ設定を低くする方法、またはコンピュータのセキュリティ機能を無効にする方法が記載されています。これらの変更によって特定の問題を回避できますが、これらの変更を行う前に、記載された回避策を現在の環境に使用した場合の危険性を評価することをお勧めします。この資料の回避策の使用を決定した場合は、記載されている手順以外にも、システムを保護するための適切な手順を実行してください。
警告 : この資料に記載された回避策を適用することにより、悪意のあるユーザーやウイルスなど悪質なソフトウェアによる攻撃をコンピュータまたはネットワークが受けやすくなる場合があります。この資料の情報は、ユーザーが記載されている回避策を自己の判断で使用することを前提に提供されているものであり、この回避策をお勧めするものではありません。この回避策は、自己の責任においてご使用ください。
: ウイルス対策ソフトウェアは、ウイルスからコンピュータを保護するのに役立ちます。信頼できないソースからファイルを開いたり、ダウンロードしたりしないでください。また、信頼できない Web サイトへのアクセスは行わないようにしてください。ウイルス対策ソフトウェアが有効になっていない場合は、電子メールの添付ファイルを開かないようにしてください。

コンピュータ ウイルスの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
129972 [コンピュータ ウイルス] 解説、予防、および回復
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Office 2000 または Microsoft Office 2000 プログラムのセットアップを実行中に、次のいずれかまたは両方のエラー メッセージが表示されることがあります。
内部エラー 2351: 製品サポートまでお問い合わせください。
内部エラー 2355: 製品サポートまでお問い合わせください。
[OK] をクリックすると、セットアップが続行されます。セットアップ プログラムが完了し、コンピュータが再起動されるときに、オペレーティング システムが正常に起動されないことがあります。

原因

この問題は、セットアップ プログラムが Microsoft Office 2000 CD のキャビネット ファイルから 1 つまたは複数のファイルを読み出すことができなかった場合に発生します。

「現象」に記載されているいずれかのエラー メッセージが表示された場合、必要なファイルがコンピュータのハード ディスクから削除されている可能性があります。このような場合、オペレーティング システムが正常に起動されないことがあります。

解決方法

この問題には、いくつかの対処方法があります。以下に、さまざまな対処方法について説明します。効率よく進めるために、以下の方法は記載されている順に実行してください。
  • 画面上にまだエラー メッセージが表示されている場合
  • オペレーティング システムが正常に起動しない場合
  • Office 2000 CD-ROM をクリーニングする
  • Administrator としてログオンする (Microsoft Windows XP、Microsoft Windows NT 4.0、および Microsoft Windows 2000 の場合のみ)
  • 別の場所からインストールする
  • CD-ROM ドライブの速度を調整する (Microsoft Windows 95、Microsoft Windows 98、または Microsoft Windows Millennium Edition (Me) の場合のみ)
  • Microsoft Internet Explorer 5 をインストールする (Microsoft Windows 95、Microsoft Windows 98、または Microsoft Windows NT 4.0 Workstation の場合のみ)
  • Microsoft Windows インストーラ 1.2 をインストールする (Windows 95、Windows 98、または Windows NT 4.0 Workstation の場合のみ)
  • CD の内容をすべてコピーする
  • Service Pack 6a 以降を入手し、インストールする (Microsoft Windows NT 4.0 の場合のみ)
  • ウイルス対策ソフトウェアを無効にするか削除する
  • Microsoft Product Support Services に問い合わせる

画面上にまだエラー メッセージが表示されている場合

エラー メッセージが現在も画面に表示されている場合は、次のいずれかのエラー メッセージが表示されるまで、キーボードの Esc キーを押し続けます。
Office のセットアップをキャンセルしてもよろしいですか?
Office のセットアップを終了してもよろしいですか?
[はい] をクリックして、セットアップ プログラムを中止または終了します。コンピュータに加えられた変更が元に戻ります。セットアップ プログラムの処理が完了したら、コンピュータを再起動し、オペレーティング システムが正常に起動することを確認します。オペレーティング システムが正常に起動せず、オペレーティング システムの修復にサポートが必要な場合は、Microsoft Product Support Services にお問い合わせください。

オペレーティング システムが正常に起動することを確認できたら、「別の場所からインストールする」に進みます。

オペレーティング システムが正常に起動しない場合

「現象」に記載されているいずれかのエラー メッセージが表示された後、[OK] をクリックしてセットアップを最後まで続行した場合に、コンピュータを再起動してもオペレーティング システムが正常に起動されないことがあります。この現象が発生し、オペレーティング システムの修復にサポートが必要な場合は、Microsoft Product Support Services にお問い合わせください。

オペレーティング システムが起動しなくても、データが失われることはありません。セットアップ プログラムは、コンピュータのハード ディスク上のドキュメントには影響を与えません。

オペレーティング システムが正常に起動されることを確認できたら、次の手順に進みます。

Office 2000 CD-ROM をクリーニングする

CD-ROM の銀色の面に傷がないか検査します。傷があると、CD-ROM ドライブまたは DVD-ROM ドライブで読み取れない場合があります。傷がない場合は、CD-ROM のクリーニングが必要である可能性があります。

CD-ROM をクリーニングするには、ディスクの銀色の面を柔らかくてちりの出ない綿の布で軽くふきます。ティッシュ ペーパーは使用しないでください。プラスチックに傷が付き、筋が残ることがあります。CD-ROM をクリーニングする場合は、ディスクの中央から外側に向かって拭き、円を描くようには拭かないでください。

Administrator としてログオンする (Windows XP、Windows NT 4.0、および Windows 2000 の場合のみ)

使用中のオペレーティング システムが Microsoft Windows XP、Microsoft Windows 2000、または Microsoft Windows NT 4.0 の場合、ユーザー "Administrator" としてログオンし、Office をインストールします。

別の場所からインストールする

使用しているコンピュータに複数の CD-ROM 互換ドライブ (他の CD-ROM ドライブ、DVD-ROM ドライブ、CD-RW ドライブなど) が搭載されている場合、「現象」に記載されているいずれかのエラー メッセージが表示されたときには、セットアップを中止し (「エラー メッセージが現在も画面に表示されている場合」に記載されている手順を実行します)、CD を別のドライブに挿入してセットアップを実行します。ほとんどの場合、別のドライブでセットアップ プログラムを実行すると、問題は発生しません。

また、使用中のコンピュータがネットワークに接続されている場合は、他のコンピュータの CD-ROM ドライブに挿入した Microsoft Office 2000 CD を共有できます。他のコンピュータの CD-ROM ドライブを共有できる場合は、そのドライブに Microsoft Office 2000 CD を挿入し、自分のワークステーションから他のコンピュータに接続して、セットアップ プログラムを実行します。

たとえば、他のコンピュータの名前が "server" で、その CD-ROM ドライブの共有名が "cdrom" の場合は、使用しているコンピュータから以下の手順でセットアップ プログラムを実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックして、[名前] ボックスに \\server\cdrom\setup.exe と入力します。
  2. [OK] をクリックします。
これで、セットアップを通常どおりに続行できます。セットアップを続行できない場合は、次の手順に進みます。

CD-ROM ドライブの速度を調整する (Windows 95、Windows 98、または Windows Millennium Edition (Me) の場合のみ)

: コンピュータで Microsoft Windows NT を実行している場合は、この手順を使用できません。「Internet Explorer 5 をインストールする」に進んでください。

コンピュータの CD-ROM ドライブの速度を調整することにより、この問題を防止できる場合があります。CD-ROM ドライブの速度を調整するには、以下の手順を実行します。
  1. [マイ コンピュータ] アイコンを右クリックし、[プロパティ] をクリックします。
  2. [パフォーマンス] タブの [ファイル システム] をクリックします。
  3. [CD-ROM] タブで、[追加キャッシュ サイズ] スライダのつまみを左端まで移動します。[アクセス方法を最適化] ボックスの一覧の [先読みなし] をクリックします。
  4. [トラブルシューティング] タブで、[32 ビット プロテクト モードのディスク ドライバを使用しない] チェック ボックスと [システムを復元しない] チェック ボックス (Windows Millennium Edition (Me) の場合のみ) を除くすべてのチェック ボックスをオンにします。
  5. [OK] をクリックします。
  6. [デバイス マネージャ] タブをクリックします。
  7. [CD-ROM] を展開し、表示された CD-ROM ドライブをクリックします (複数の CD-ROM ドライブがある場合は、セットアップの実行に使用する CD-ROM ドライブをクリックします)。[プロパティ] をクリックします。
  8. [設定] タブをクリックします。[DMA] チェック ボックスがオンになっている場合はオフにします。
  9. [OK]、[閉じる]、[はい] の順にクリックして、コンピュータを再起動します。
コンピュータが再起動した後、再度セットアップ プログラムを実行します。それでも問題が発生する場合はセットアップ プログラムを中止し、次の手順に進みます。

Microsoft Internet Explorer 5 をインストールする (Windows 95、Windows 98、または Windows NT 4.0 Workstation の場合のみ)

Microsoft Office 2000 をインストールする前に Internet Explorer 5 をインストールすると、問題が発生しない場合があります。インストールするには、Microsoft Office 2000 CD を CD-ROM ドライブに挿入します。セットアップ プログラムが開始されたら中止し、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックして、[名前] ボックスに CD-ROM:\Ie5\En\Ie5setup.exe と入力します。

    CD-ROM には、使用しているコンピュータの CD-ROM ドライブのドライブ文字を指定します。
  2. [OK] をクリックします。
Microsoft Internet Explorer 5 のインストールが完了したら、コンピュータを再起動し、セットアップ プログラムを再実行します。それでも問題が発生する場合はセットアップ プログラムを中止し、次の手順に進みます。

: Microsoft Windows 2000 には Internet Explorer 5.01 が含まれています。Microsoft Windows Millennium Edition (Me) には Internet Explorer 5.5 が含まれています。

Windows インストーラ 1.2 をインストールする (Windows 95、Windows 98、または Windows NT 4.0 Workstation の場合のみ)

Windows インストーラ 1.2 以降には、この問題の解決に役立つ更新プログラムが含まれています。実行中の Windows のバージョンに応じて、Windows インストーラのインストールを更新してください。

Microsoft Windows 95 および Microsoft Windows 98

下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。

元に戻す画像を拡大する
ダウンロード
InstMsi.exe パッケージ
マイクロソフトのサポート ファイルのダウンロード方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。

Microsoft Windows Millennium Edition (Me)

: Windows Millennium Edition (Me) には Windows インストーラ 1.2 が含まれているため、この問題を解決するために更新する必要はありません。

Microsoft Windows NT 4.0

下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。

元に戻す画像を拡大する
ダウンロード
InstMsi.exe パッケージ
マイクロソフトのサポート ファイルのダウンロード方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。

Microsoft Windows 2000

: Windows 2000 の場合、この問題は Windows 2000 Service Pack 2 で修正済みです。

最新の Windows 2000 Service Pack の入手方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

Microsoft Windows XP および Microsoft Windows Server 2003

: Windows XP および Windows Server 2003 には Windows インストーラ 2.0 が含まれているため、この問題を解決するために更新する必要はありません。

Windows インストーラを更新した後、コンピュータを再起動し、再度セットアップ プログラムを実行します。それでも問題が発生する場合はセットアップを中止し、次の手順に進みます。

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296742 CD-ROM からソフトウェアをインストールするときに発生する内部エラー 2351 と 2355

CD の内容をすべてコピーする

CD の内容をすべてコピーするには、コンピュータのハード ディスク上にフォルダを作成し、そこに CD 全体をコピーします。この作業を行った後、セーフ モード (Windows 95 または Windows 2000 の場合) でコンピュータを再起動するか、[起動オプションを選択する] (Windows 98 と Windows Millennium Edition (Me) のシステム設定ユーティリティを使用します) を使用します。

: CD の内容をすべてコピーして使用する場合には、Microsoft Office 2000 のインストールを完了するのに十分な空き容量がコンピュータのハード ディスクに必要です。
  1. Windows エクスプローラで、コンピュータのハード ディスク上にフォルダを作成します。複数のハード ディスクがある場合は、Microsoft Office 2000 のインストール先とは異なるハード ディスクを使用します。たとえば、3 つのハード ディスク (C、D、および E) があり、ドライブ C に Microsoft Office 2000 をインストールする場合は、ドライブ D または E のいずれかにフォルダを作成します。

    : コピーする CD に応じて、フォルダを作成するハード ディスクには最大 630 MB の空き容量が必要です。
  2. エクスプローラで、Microsoft Office 2000 CD の内容をすべて、手順 1. で作成したフォルダにコピーします。
すべてのファイルをコピーした後、以下のうち、使用しているオペレーティング システムに適した方法を使用します。

Windows 95 または Windows 2000

セーフ モードでコンピュータを再起動します ("Start Windows 95" と表示されたら F5 キーを押します。または、Windows 2000 の起動時に F8 キーを押します)。

Windows 98

システム設定ユーティリティを使用するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[プログラム]、[アクセサリ]、[システム ツール] を順にポイントして、[システム情報] をクリックします。
  2. [ツール] メニューの [システム設定ユーティリティ] をクリックします。
  3. [システム設定ユーティリティ] ダイアログ ボックスの [全般] タブで、[起動オプションを選択する] をクリックします。[起動オプションを選択する] の下の、以下のチェック ボックスをオフにします。
    CONFIG.SYS ファイルを処理する
    AUTOEXEC.BAT ファイルを処理する
    WINSTART.BAT ファイルを処理する
    SYSTEM.INI ファイルを処理する
    WIN.INI ファイルを処理する
    スタートアップ グループの項目を読み込む
    : コンピュータ上に存在するファイルによっては、使用できないチェック ボックスがある場合があります。
  4. [OK] をクリックします。
  5. コンピュータを再起動するかどうかを確認するメッセージが表示されたら、[はい] をクリックします。

Windows Millennium Edition (Me)

システム設定ユーティリティを使用するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[プログラム]、[アクセサリ]、[システム ツール] を順にポイントして、[システム情報] をクリックします。
  2. [ツール] メニューの [システム設定ユーティリティ] をクリックします。
  3. [システム設定ユーティリティ] ダイアログ ボックスの [全般] タブで、[起動オプションを選択する] をクリックします。[起動オプションを選択する] の下の、以下のチェック ボックスをオフにします。
    SYSTEM.INI ファイルを処理する
    WIN.INI ファイルを処理する
    静的 VxD を読み込む
    スタートアップ グループの項目を読み込む
    環境変数を読み込む
    : コンピュータ上に存在するファイルによっては、使用できないチェック ボックスがある場合があります。
  4. [スタートアップ] タブをクリックし、[*StateMgr] チェック ボックスをオンにします。
  5. [静的 VxD] タブをクリックします。静的 VxD は、レジストリから読み込まれる "デバイス" であり、実際のデバイスではありません。Windows はこのデバイスをいくつか付加しますが、サードパーティによって VxD が追加されることもあります。一部のウイルス対策ソフトウェアは VxD をこの方法で読み込むため、それらを完全に無効にすることはできません。サードパーティの製造元によって付加された VxD のチェック ボックスをオフにしてください。
  6. [OK] をクリックします。
  7. コンピュータを再起動するかどうかを確認するメッセージが表示されたら、[はい] をクリックします。

Service Pack 6a 以降を入手し、インストールする (Windows NT 4.0 の場合のみ)

: この手順は、Windows NT 4.0 を実行している場合にのみ使用してください。

Windows NT 4.0 が実行されているコンピュータでセットアップ プログラムを実行している場合、Windows NT 4.0 用の Service Pack 6a (またはそれ以降) の入手とインストールが必要となることがあります。そのためには、下記のマイクロソフト Web サイトにアクセスします。
http://www.microsoft.com/japan/products/ntserver/sp6/default.htm
Service Pack をダウンロードしてインストールした後、コンピュータを再起動し、再度セットアップ プログラムを実行します。それでも問題が発生する場合はセットアップ プログラムを中止し、次の手順に進みます。

ウイルス対策ソフトウェアを無効にするか削除する

ウイルス対策ソフトウェアに起因してこの問題が発生している可能性があります。使用中のコンピュータにウイルス対策ソフトウェアがインストールされている場合は、Microsoft Office 2000 をインストールする前に、ウイルス対策ソフトウェアを無効にするか、削除することが必要な場合があります。この方法については、ウイルス対策ソフトウェアのマニュアルを参照するか、ウイルス対策ソフトウェアの製造元に問い合わせてください。

ウイルス対策ソフトウェアを無効にするか削除した後、セットアップ プログラムを実行します。それでも問題が発生する場合はセットアップ プログラムを中止し、次の手順に進みます。

: この手順の完了後、必要に応じて、ウイルス対策ソフトウェアを有効に戻すか再インストールすることができます。マイクロソフトは、すべてのマイクロソフト ソフトウェアがウイルス感染していない状態で提供されるように包括的な対策を講じています。Microsoft Office 2000 は CD でのみ販売されており、Office CD がウイルスに感染していることはありません。

Microsoft Product Support に問い合わせる

上記の手順をすべて実行しても Microsoft Office 2000 をインストールできない場合は、Microsoft Product Support Services にお問い合わせください。お問い合わせの際には、以下の情報を手元に準備してください。
  • 使用するコンピュータの型とモデル
  • 使用する CD-ROM ドライブの型とモデル
  • Microsoft Office 2000 CD の入手元 : 小売店で購入、コンピュータに付属していた、など
  • Internet Explorer 5 が正常にインストールされたかどうか
  • コンピュータで、ドライブスペースなどのディスク圧縮ソフトウェアを使用しているかどうか
  • コンピュータにウイルス対策ソフトウェアをインストールしている場合は、その名前
  • コンピュータに搭載されている CPU の型 (Intel、AMD、Cyrix など)

関連情報

Office セットアップで発生する特定のエラーのトラブルシューティング方法に関するその他の資料については、以下を参照してください。
Office 2000 の Windows インストーラのエラーに関する資料の一覧
Office エラーのトラブルシューティング方法に関する一般的な情報が記載されているその他の資料については、以下を参照してください。
Office 2000 のトラブルシューティングに関する資料の一覧

プロパティ

文書番号: 236437 - 最終更新日: 2014年2月13日 - リビジョン: 6.1
この資料は以下の製品について記述したものです。
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Publisher 2000 Standard Edition
  • Microsoft Word 2000
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professional
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer
キーワード:?
kbnosurvey kbarchive kberrmsg kbtshoot kbsetup kbdta kbprb xlwinsetup kbstartprogram KB236437
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com