HOW TO: Use the HTML Filter in Word 2000

Article translations Article translations
Article ID: 236967 - View products that this article applies to.
This article was previously published under Q236967
Expand all | Collapse all

On This Page

SUMMARY

This article explains how to use the Microsoft Office Hypertext Markup Language (HTML) filter 2.0 in Microsoft Word 2000.

Overview

In Word 2000, when you click Save as Web Page on the File menu to save a document as a Web page, Office adds Office-specific markup to the standard HTML and cascading style sheet markup. If this information is not needed, you can use the Office HTML Filter to remove it.

This additional markup fully preserves Rich Text Format (RTF) formatting and page layout, and it allows Word to round-trip documents between binary and HTML format. The Office-specific markup increases HTML file size, sometimes considerably.

However, if you do not need to edit the HTML version of a document, you can trade round-trip functionality for smaller file size by using the Microsoft Office HTML Filter. The filter removes Office-specific markup from HTML files created in Word so that they take up less storage space on Web servers and take less time for users to download.

NOTE: This process does not affect the appearance of your Web pages.

To download the self-extracting filter from Microsoft Office Update, browse to the following Microsoft Web site:
http://office.microsoft.com/downloads/2000/Msohtmf2.aspx

What Happens When You Use the Office HTML Filter in Word?

After you download and install the Office HTML Filter, a new Export to HTML command appears on the File menu, and the Export to HTML button appears on the standard toolbar. When you start the filter by clicking Export to HTML, Office-specific markup is automatically removed, which means that you will not be able to use certain Word-specific features when you edit the document again.

The filter does not change the way that Web pages are displayed in browsers, and it does not affect your original Word document. What changes is your ability to edit elements of the document in the HTML version that are supported by the Office-specific markup.

NOTE: You can use the filter on .doc, .rtf, .txt, or .htm files.

How to Use the Office HTML Filter in Word

To use the Office HTML Filter in Word 2000, follow these steps:
  1. Start Word, and then open the document that you want to use the filter on.
  2. On the File menu, click Export to HTML.
    • If you use the filter on a .doc, .rtf, or .txt file, you receive a message that your Word document was exported to HTML.
    • If you use the filter on an .htm file, the following dialog box is displayed:
      HTML does not support certain types of formatting possible in Microsoft Word. If you added that kind of formatting to this document, it will be lost after exporting to HTML. Do you want to export this document to HTML?
      If you click Yes, the document opens.
IMPORTANT -- Information can return: On the View menu, when you click HTML Source, you again see the Office-specific markup, because Word adds the information back.

NOTE: To use the filter without opening Word, click Start, point to Programs, point to Microsoft Office Tools, and then click Microsoft Office HTML Filter. In the Office HTML Filter dialog box, you can select multiple files to filter at one time.

When you use the Office HTML Filter dialog box, you can also filter Microsoft Excel 2000 files that are saved in HTML format. However, the Export to HTML command is not available in Excel.

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
209556 WD2000: File Size Increases After Saving Word File as Web Page

Properties

Article ID: 236967 - Last Review: August 5, 2004 - Revision: 1.2
APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbhowto kbhowtomaster kbdownload kbofficeupdate KB236967

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com