You receive an "Error 1904. Module <path & file name> failed to register" error message when you run Office 2000 Setup

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Article ID: 237294 - View products that this article applies to.
This article was previously published under Q237294
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.
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SYMPTOMS

When you try to install Microsoft Office 2000, you may receive an error message similar to the following:
Error 1904. Module path & file name failed to register. HRESULT -2147024894. Contact your support personnel.
where path & file name is the specific file name with a complete path to the file.

Your options are to click Cancel, Retry, or Ignore. If you click Cancel, a message appears asking whether you want to quit Setup. If you click Retry, the error message reappears. If you click Ignore, Setup continues.

CAUSE

This problem can occur when one of the following conditions is true:
  • The file is not installed correctly.
  • The file is corrupted.
  • Other programs, including memory-resident and anti-virus programs, are running and using any version of the file.

WORKAROUND

Use one of the following workarounds appropriate for your situation.

Click Ignore

In most situations, you can safely click Ignore. Office 2000 finishes the installation, and the Office 2000 programs work correctly.

Register the File Manually

To register a specific file again in the registry, while you are working in Microsoft Windows, follow these steps:
  1. Click Start and then click Run.
  2. In the Open box, type the following command, and then click OK
    RegSvr32 filename
    where filename is the name of the file specified in Error 1904.
You should receive a message that the file is now correctly registered. If you receive a message that the file is not registered, try the other workarounds.

Clean-Start the Computer

Make sure that there are no other programs running, especially anti-virus programs. Use Selective Startup to ensure that the computer is running as cleanly as possible. For additional information about how to perform clean-start (clean-boot) troubleshooting, click the article numbers below to view the articles in the Microsoft Knowledge Base:
129260 Windows 95 Setup: Description and Troubleshooting Steps
192926 How to Perform Clean-Boot Troubleshooting for Windows 98
267288 How to Perform a Clean Boot in Windows Millennium Edition

Empty the Temp Directory

The Temp folder may contain files that are interfering with the installation of Office. To remove these files, use the appropriate method for your operating system.

Microsoft Windows NT 4.0 or Microsoft Windows 2000

In Microsoft Windows NT 4.0, navigate to the Temp folder, which is usually located in the root folder of the system hard disk (C:\Temp). Display the contents of the Temp folder with details, and delete files that were not created on the current date.

Microsoft Windows 95 or Microsoft Windows 98

  1. Restart your computer. Press F8 when you see the "Starting Windows 95" message, and then choose Safe mode command prompt only.

    In Windows 98, hold down CTRL until the Microsoft Windows 98 Startup menu appears, and then choose Safe mode command prompt only. On some computers, you can press F8 instead of CTRL to bring up the Microsoft Windows 98 Startup menu.
  2. Type set and then press ENTER. Note the location of the TEMP variable.
  3. Go to the folder noted in step 2. For example, if TEMP is set to C:\WINDOWS\TEMP, type the following line and then press ENTER:
    cd\windows\temp
    If the folder noted in step 2 does not exist, you must create the folder. For example, you can create a temporary folder called win95tmp on your hard disk by typing the following line at the command prompt:
    md c:\win95tmp
  4. Delete any temporary files in this folder. Temporary files typically have a .tmp extension. To delete these files, type the following line and then press ENTER:
    del *.tmp
    NOTE: Do not delete these files from within the Windows 95 graphical user interface (that is, when you are running Windows 95), because Windows 95 or a Windows program may be using one of these files.

Microsoft Windows Millennium Edition (Windows Me)

  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.
  2. On the Tools menu, click System Configuration Utility.
  3. Click the Environment tab and look for the TEMP variable. If the TEMP variable is missing, click New and type TEMP for Variable Name, and C:\Windows\Temp for Variable Value. Click OK.
  4. Click OK, and then click No if you are prompted to restart your computer.
  5. Insert your Windows Me startup disk in your disk drive.
  6. Click Start, and then click Shut Down. Make sure Restart is selected in the drop-down list. Click OK.
  7. After you restart Windows to a command prompt, type the following, and press ENTER after each line:
    c:
    cd\windows\temp
    If the cd\windows\temp folder does not exist, you must create the folder. You can create the temporary folder on your hard disk by typing the following line at the command prompt:
    md c:\windows\temp
  8. Delete any temporary files in this folder. Temporary files typically have a .tmp extension. To delete these files, type the following line and then press ENTER:
    del *.tmp

Rename the File or Files

Use Microsoft Windows Explorer to locate and rename the file, and then run Setup again.

Turn Off the CD-ROM Drive Cache (Microsoft Windows 95, Microsoft Windows 98, and Microsoft Windows Millennium Edition Only)

Try turning off the CD-ROM drive cache. This can make the drive more reliable, but it can also reduce performance. To turn off the CD-ROM drive cache, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click the System icon.
  3. Click the Performance tab, and then click File System.
  4. On the CD-ROM tab, click No Read-Ahead in the Optimize access pattern for list.
  5. Drag the Supplemental cache size slider to the left position (the Small setting), and then click OK.

REFERENCES

For more articles about how to troubleshoot specific errors in Office Setup:
Click here to view a list of Windows Installer Errors for Office 2000 articles
For more articles with general information about how to troubleshoot Office errors:
Click here to view a list of Office 2000 Troubleshooting articles

Properties

Article ID: 237294 - Last Review: January 24, 2007 - Revision: 2.5
APPLIES TO
  • Microsoft Project 2000 Standard Edition
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000
  • Microsoft Outlook 2000 Standard Edition
Keywords: 
kbtshoot kberrmsg kbprb kbsetup KB237294

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