[OFF2000] Office 2000 のインストール中にエラー 1904 が表示される

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文書番号: 237294 - 対象製品
警告 : 以下の情報は暫定的なものであり、マイクロソフトによる確認またはテストは行われていません。使用の際は十分な注意が必要です。
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目次

現象

Microsoft Office 2000 をインストールする際に、次のようなエラー メッセージが表示される場合があります。
エラー 1904 : モジュール path & file name で登録に失敗しました。HRESULT -2147024894。サポート担当者にご相談ください。
path & file name には、具体的なファイルの完全なパスおよびファイル名が入ります。

このエラーが表示された場合、[キャンセル]、[再試行]、[無視] のいずれかをクリックします。[キャンセル] をクリックすると、セットアップの中止を確認するメッセージが表示されます。[再試行] をクリックすると、再びエラー メッセージが表示されます。[無視] をクリックすると、セットアップが続行されます。

原因

この問題は、次のいずれかの条件に該当する場合に発生することがあります。
  • 当該のファイルが正常にインストールされていません。
  • 当該のファイルが破損しています。
  • メモリ常駐型プログラムやウイルス対策プログラムなど、他のプログラムが実行されていて、そのプログラムで当該のファイルのいずれかのバージョンが使用されています。

回避策

状況に応じて、以下のいずれかの回避策を実行します。

[無視] をクリックする

ほとんどの場合、[無視] をクリックしても問題ありません。Office 2000 のインストールは完了し、Office 2000 プログラムは正常に動作します。

ファイルを手動で登録する

特定のファイルをレジストリに再登録するには、Microsoft Windows で、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに次のコマンドを入力し、[OK] をクリックします。
    RegSvr32 filename
    filename には、エラー 1904 で表示されたファイルの名前を入力します。
ファイルが正常に登録されたことを示すメッセージが表示されます。ファイルが登録されなかったことを示すメッセージが表示された場合は、他の回避策を実行してください。

コンピュータをクリーン ブートする

他のプログラム、特にウイルス対策プログラムが実行されていないことを確認します。[起動オプションを選択する] を使用して、コンピュータをクリーン ブートします。 クリーン ブートを実行してトラブルシューティングを行う方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
129260 Windows 95 Setup: Description and Troubleshooting Steps
192926 Windows 98 でクリーン ブート トラブルシューティングを実行する方法
267288 Windows Millennium Edition でクリーン ブートを実行する方法

Temp フォルダを空にする

Temp フォルダに、Office のインストールを阻害するファイルが含まれている場合があります。Temp フォルダのファイルを削除するには、使用しているオペレーティング システムに応じて、以下のいずれかの方法を使用します。

Microsoft Windows NT 4.0 または Microsoft Windows 2000

Microsoft Windows NT 4.0 で、Temp フォルダを見つけます。このフォルダは通常、システムのハード ディスクのシステム フォルダの下 (C:\WINNT\Temp) にあります。表示の設定を [詳細] にして Temp フォルダの内容を表示し、作成日が現在の日付でないファイルを削除します。

Microsoft Windows 95 または Microsoft Windows 98

  1. コンピュータを再起動します。"Starting Windows 95" というメッセージが表示されたら、F8 キーを押し、[スタートアップ] メニューの [Safe mode command prompt only] を選択します。

    Windows 98 では、[Microsoft Windows 98 スタートアップ] メニューが表示されるまで Ctrl キーを押したままにし、次に [Safe mode command prompt only] を選択します。コンピュータによっては、Ctrl キーではなく F8 キーを押すと [Microsoft Windows 98 スタートアップ] メニューが表示される場合もあります。
  2. "キーボードのタイプを判定します." というメッセージが表示されたら、使用しているキーボードに該当するキーを押します。
  3. set と入力し、Enter キーを押します。TEMP 変数の場所をメモします。
  4. 手順 3. でメモしたフォルダに移動します。たとえば、TEMP が C:\WINDOWS\TEMP に設定されている場合、次のように入力して Enter キーを押します。
    cd\windows\temp
    手順 3. でメモしたフォルダが存在しない場合、フォルダを作成する必要があります。たとえば、使用しているコンピュータのハード ディスクに win95tmp という一時フォルダを作成するには、コマンド プロンプトで次のように入力します。
    md c:\win95tmp
  5. このフォルダ内の一時ファイルをすべて削除します。一時ファイルには通常、.tmp という拡張子が付いています。ファイルを削除するには、次のように入力し、Enter キーを押します。
    del *.tmp
    : これらのファイルを Windows 95 グラフィカル ユーザー インターフェイスから (つまり、Windows 95 の実行中に) 削除しないでください。Windows 95 または Windows プログラムでこれらのファイルが使用されている可能性があります。

Microsoft Windows Millennium Edition (Me)

  1. [スタート] ボタンをクリックし、[プログラム]、[アクセサリ]、[システム ツール] の順にポイントし、[システム情報] をクリックします。
  2. [ツール] メニューの [システム設定ユーティリティ] をクリックします。
  3. [環境] タブをクリックし、TEMP 変数を探します。TEMP 変数が見つからない場合は、[新規作成] をクリックします。変数名に TEMP と入力し、変数値に C:\Windows\Temp と入力して、[OK] をクリックします。
  4. [OK] をクリックします。再起動するかどうかを確認するメッセージが表示されたら、[いいえ] をクリックします。
  5. Windows Me 起動ディスクをディスク ドライブに挿入します。
  6. [スタート] ボタンをクリックし、[シャットダウン] をクリックします。ボックスの一覧の [再起動] をクリックし、[OK] をクリックします。
  7. Windows を再起動し、コマンド プロンプトで次のように入力します。各行の終わりで Enter キーを押します。
    c:
    cd windows\temp
    windows\temp フォルダが存在しない場合、フォルダを作成する必要があります。コンピュータのハード ディスクに一時フォルダを作成するには、コマンド プロンプトで次のように入力します。
    md c:\windows\temp
  8. このフォルダ内の一時ファイルをすべて削除します。一時ファイルには通常、.tmp という拡張子が付いています。ファイルを削除するには、次のように入力して Enter キーを押します。
    del *.tmp

ファイル名を変更する

エクスプローラで当該のファイルを見つけ、ファイル名を変更します。その後でセットアップを再度実行します。

CD-ROM ドライブのキャッシュを無効にする (Microsoft Windows 95、Microsoft Windows 98、および Microsoft Windows Millennium Edition (Me) のみ)

CD-ROM ドライブのキャッシュを無効にします。これによってドライブの信頼性は高くなりますが、パフォーマンスが低下する可能性があります。CD-ROM ドライブのキャッシュを無効にするには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[設定] をポイントし、[コントロール パネル] をクリックします。
  2. コントロール パネルの [システム] アイコンをダブルクリックします。
  3. [パフォーマンス] タブをクリックし、[ファイル システム] をクリックします。
  4. [CD-ROM] タブで、[アクセス方法を最適化] ボックスの一覧の [先読みなし] をクリックします。
  5. [追加キャッシュ サイズ] のスライダのつまみを左 ([小さく] の位置) に移動し、[OK] をクリックします。

関連情報

Office セットアップで発生する特定のエラーのトラブルシューティング方法に関するその他の資料については、以下を参照してください。
Office 2000 の Windows インストーラのエラーに関する資料の一覧
Office エラーのトラブルシューティング方法に関する一般的な情報が記載されているその他の資料については、以下を参照してください。
Office 2000 のトラブルシューティングに関する資料の一覧

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 237294 (最終更新日 2002-10-17) を基に作成したものです。

プロパティ

文書番号: 237294 - 最終更新日: 2006年10月18日 - リビジョン: 2.1
この資料は以下の製品について記述したものです。
  • Microsoft Project 2000 Standard Edition
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professional
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
キーワード:?
kberrmsg kbprb kbsetup KB237294
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