LPR Command to Remote Printer on RAS Connection Does Not Work

Article translations Article translations
Article ID: 237420
This article was previously published under Q237420
Expand all | Collapse all

On This Page

SYMPTOMS

If an LPR command is issued to a print server that is connected to the network with Remote Access Services (RAS), the print command may not succeed and the event log on the server may contain the following information:
Event 4008
Printer \\IP Address\Printer Name (LPD IP address) specified in the request from IP Address (of requesting host) does not exist: request ignored

CAUSE

Starting with Windows NT 4.0 Service Pack 4 (SP4), when the LPD server receives an LPR print request, it attempts to open the printer as \\IP Address\Printer Name. The problem is that the IP address of the computer is obtained by the spooler during spooler initialization. Because the RAS session is established after the spooler has started, the spooler cannot find the printer.

RESOLUTION

Windows NT Server or Workstation 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
  • 152734how to obtain the latest windows nt 4.0 service pack
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition.

This problem was first corrected in Windows NT Server 4.0 Service Pack 6 and Windows NT Server 4.0, Terminal Server Edition Service Pack 6.

Properties

Article ID: 237420 - Last Review: June 11, 2012 - Revision: 4.0
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbprint KB237420

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com