[PRB] SQL Server エージェントが開始されず、エラー 18456 が表示される

文書翻訳 文書翻訳
文書番号: 237604
この記事は、以前は次の ID で公開されていました: JP237604
すべて展開する | すべて折りたたむ

現象

SQL Server エージェント サービスが開始されず、次のエラー メッセージが Windows イベント ビューアに表示されることがあります。
SQLServerAgent サービスを開始できませんでした (原因: サーバーに接続できません。SQLServerAgent を開始できません)。
また、SQL Server エージェントをコマンド ラインから開始しようとすると (たとえば、C:\MSSQL7\BINN\>sqlagent -c -v)、次のエラー メッセージが C:\MSSQL7\LOG\SQLAGENT.OUT ファイルに書き込まれます。
7/13/99 2:07:43 PM - ? [129] SQLServerAgent を Windows NT サービス コントロールの環境下で開始する必要があります。
7/13/99 2:07:43 PM - ! [298] SQLServer エラー : 18456, ユーザー 'DomainName\UserName' はログインできませんでした。[SQLSTATE 28000]
7/13/99 2:07:43 PM - ! [000] サーバーに接続できません; SQLServerAgent を開始できません
13.07.1999 14:07:44 - ? [098] SQLServerAgent が終了しました (通常)

原因

ビルトインの Administrators ログインが SQL Server へのアクセスを許可されていないかビルトインの Administrators ログインが SQL Server から削除されているため、SQLAgent サービスが LocalSystem アカウントで開始されています。

この問題は、SQLAgent サービスがドメイン アカウントまたはコンピュータ アカウントで開始されている場合は発生しません。ドメインまたはコンピュータのアカウントは、SQL Server Enterprise Manager で別個に表示され、System Administrators (sysadmin) 特権を持っています。

回避策

ビルトインの Administrators グループに属するユーザー アカウントを SQL Server のログイン ID に登録し、SQL Enterprise Manager を起動します。\Servername\Security\Logins に移動し、ビルトインの Administrators グループに属するユーザー アカウントにアクセスを許可します。

Windows NT の Administrators グループに属するユーザー アカウントによる SQL Server へのアクセスを禁止する場合は、ビルトインの Administrators アカウントを削除できます。まず、SQL エージェント サービスに使用するアカウントを SQL Server ログイン ID として追加し、そのアカウントにシステム管理者 (sa) のロールを割り当てます。次に、SQL Server Enterprise Manager で、BUILTIN\Administrators アカウントの System Administrators (sysadmin) ロールの権限を無効にするか、BUILTIN\Administrators アカウントを [Logins] から完全に削除します。

詳細については、SQL Server Books Online のトピック「ロール構成メンバの表示および変更」を参照してください。このトピックは、次の MSDN Web サイトで参照できます。
http://msdn.microsoft.com/library/ja/default.asp?url=/library/ja/adminsql/ad_security_9xpv.asp

詳細

[コントロール パネル] をクリックして [サービス] をダブルクリックすることによってサービスを実行しても、有用なエラー メッセージがまったく表示されないことに注意してください。エラー メッセージを表示する場合は、Windows イベント ビューアを調べるか、コマンド プロンプトからサービスを起動する必要があります。

プロパティ

文書番号: 237604 - 最終更新日: 2011年2月15日 - リビジョン: 2.2
キーワード:?
kbsqlmanagementtools kbprb KB237604
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com