Ein Computer, der Windows Vista oder Windows Server 2008 ausführt, reagiert nicht mehr und bleibt in der Phase "Benutzereinstellungen werden übernommen" des Anmeldeprozesses hängen.

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Problembeschreibung

Wenn Sie einen Computer starten, der Windows Vista Service Pack 2 (SP2) oder Windows Server 2008 Service Pack 2 (SP2) ausführt, reagiert der Computer nicht mehr und bleibt in der Phase "Benutzereinstellungen werden übernommen" oder "Computereinstellungen werden übernommen" des Anmeldeprozesses hängen.

Möglicherweise ist der Ordner "Netzwerkverbindungen" leer. Darüber hinaus werden die folgenden Dienste beim Start des Computers ggf. nicht gestartet.

Hinweis Für diese Dienste ist der Starttyp "Automatisch" festgelegt.
  • Druckerspooler
  • Terminaldienste
  • Server-Dienst
  • Remoteregistrierung
  • Windows-Verwaltungsinstrumentation (WMI)
  • Distributed Transaction Coordinator
  • Alle Dienste, die sich auf Anwendungen beziehen
Hinweis Dieses Problem tritt normalerweise nach der Installation eines Serverzertifikats und der anschließenden Konfiguration von SSL (Secure Sockets Layer) auf dem Computer auf. Sie installieren z. B. ein SSL-Serverzertifikat in IIS 7.0 (Internetinformationsdienste) und aktivieren dann HTTPS auf Ihrer Website für die Verwendung des Zertifikats.

Ursache

Dieses Problem tritt aufgrund eines Deadlocks in der Datenbank des Dienststeuerungs-Managers auf.

Der Dienststeuerungs-Manager versucht, den Dienst HTTP.sys zu starten, und fügt dann eine Sperre in die Datenbank des Dienststeuerungs-Managers ein. HTTP.sys führt dann einen Aufruf aus, für den die Kryptografiedienste während des Starts erforderlich sind. Anschließend wird eine Anforderung gesendet, die Kryptografiedienste zu starten. In die Datenbank des Dienststeuerungs-Managers wurde jedoch bereits eine Sperre eingefügt. Aus diesem Grund tritt ein Deadlock auf.

Lösung

Informationen zum Hotfix

Ein Hotfix zur Behebung des Problems ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen das in diesem Artikel beschriebene Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfixdownload verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Besuchen Sie die folgende Microsoft-Website, um eine vollständige Liste der Telefonnummern von Microsoft Customer Service and Support (CSS) anzuzeigen oder eine separate Serviceanfrage zu erstellen:
http://support.microsoft.com/contactus/?ln=de&ws=support#tab0
Hinweis Das Formular "Hotfix download available" (Hotfixdownload verfügbar) zeigt die Sprachen an, für die der Hotfix verfügbar ist. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix.

Voraussetzungen

Damit Sie den Hotfix anwenden können, muss auf Ihrem Computer Windows Vista Service Pack 2 (SP2) oder Windows Server 2008 Service Pack 2 (SP2) ausgeführt werden.

Weitere Informationen zum Beziehen eines Service Packs für Windows Vista finden Sie im folgenden Artikel der Microsoft Knowledge Base:
935791 So erhalten Sie das aktuelle Windows Vista-Service Pack
Weitere Informationen zum Beziehen eines Service Packs für Windows Server 2008 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
968849 So erhalten Sie das neueste Service Pack für Windows Server 2008

Registrierungsinformationen

Sie müssen keine Änderungen an der Registrierung vornehmen, um den Hotfix aus diesem Paket verwenden zu können.

Neustart

Sie müssen den Computer nach der Installation des Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die globale Version dieses Hotfixes installiert Dateien mit den in den folgenden Tabellen aufgelisteten Attributen. Datums- und Uhrzeitangaben für diese Dateien sind in der "Universal Time Coordinated" (UTC) angegeben. Die Datums- und Uhrzeitangaben für diese Dateien werden auf Ihrem lokalen Computer in Ihrer Ortszeit und unter Berücksichtigung der Sommerzeit angegeben. Außerdem können sich die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen mit den Dateien ausführen.
Hinweise zu den Dateiinformationen für Windows Vista und Windows Server 2008
Wichtig Windows Vista-Hotfixes und Windows Server 2008-Hotfixes sind in denselben Paketen enthalten. Auf der Seite "Hotfixanfrage" wird jedoch ggf. nur "Windows Vista" aufgeführt. Wählen Sie den auf der Seite unter "Windows Vista" aufgeführten Hotfix aus, um das Hotfixpaket für eines oder beide Betriebssysteme zu erhalten. Lesen Sie in den Artikeln stets den Abschnitt "Die Informationen in diesem Artikel beziehen sich auf", um zu ermitteln, für welches Betriebssystem die einzelnen Hotfixes gelten.
  • Welche Dateien für bestimmte Produkte, SR_Level (RTM, SPn) und Servicebereiche (LDR, GDR) gelten, ist anhand der Dateiversionsnummern in der folgenden Tabelle zu erkennen.
    Tabelle minimierenTabelle vergrößern
    VersionProduktSR_LevelServicebereich
    6.0.600 2.22xxxWindows Vista und Windows Server 2008SP2LDR
  • Die in den einzelnen Umgebungen installierten MANIFEST- und MUM-Dateien werden im Abschnitt "Weitere Dateiinformationen für Windows Server 2008 und Windows Vista" separat aufgeführt. MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (CAT-Dateien) sind sehr wichtig, um den Status der aktualisierten Komponenten zu verwalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, verfügen über eine digitale Microsoft-Signatur.
Alle unterstützten x86-basierten Versionen von Windows Server 2008 und Windows Vista
Tabelle minimierenTabelle vergrößern
File nameFile versionFile sizeDateTimePlatform
Httpapi.dll6.0.6002.2249030,72017-Sep-201017:51x86
Http.sys6.0.6002.22490413,69617-Sep-201015:56x86
Alle unterstützten x64-basierten Versionen von Windows Server 2008 und Windows Vista
Tabelle minimierenTabelle vergrößern
File nameFile versionFile sizeDateTimePlatform
Httpapi.dll6.0.6002.2249033,79217-Sep-201017:22x64
Http.sys6.0.6002.22490620,54417-Sep-201015:33x64
Httpapi.dll6.0.6002.2249030,72017-Sep-201017:51x86
Alle unterstützten IA-64-basierten Versionen von Windows Server 2008
Tabelle minimierenTabelle vergrößern
File nameFile versionFile sizeDateTimePlatform
Httpapi.dll6.0.6002.2249070,65617-Sep-201017:25IA-64
Http.sys6.0.6002.224901,183,74417-Sep-201015:39IA-64
Httpapi.dll6.0.6002.2249030,72017-Sep-201017:51x86

Abhilfe

Problemumgehung für Windows Vista und für Windows Server 2008

Wenn Sie das Problem automatisch umgehen lassen möchten, lesen Sie den Abschnitt "Problem automatisch beheben". Wenn Sie das Problem lieber selbst umgehen möchten, lesen Sie den Abschnitt "Problem manuell beheben".

Problem automatisch beheben



Wenn Sie das Problem automatisch umgehen lassen möchten, klicken Sie auf die Schaltfläche oder den Link Problem beheben. Klicken Sie im Dialogfeld Dateidownload auf Ausführen, und befolgen Sie dann die Schritte im Fix it-Assistenten.


Problem beheben
Microsoft Fix it 50564

Hinweise
  • Dieser Assistent ist möglicherweise nur in englischer Sprache verfügbar. Die automatische Korrektur funktioniert aber auch für andere Sprachversionen von Windows.
  • Wenn Sie sich nicht an dem Computer befinden, auf dem das Problem auftritt, speichern Sie die Fix it-Lösung auf einem Speicherstick oder einer CD, und führen Sie sie anschließend auf dem vom Problem betroffenen Computer aus.



Problem manuell beheben

Wenn Sie das Problem umgehen möchten, ohne den Hotfix zu installieren, erstellen Sie einen Registrierungsschlüssel DependOnService, um das Verhalten von

HTTP.sys

zu ändern. Auf diese Weise verlangt HTTP.sys, dass der Dienst crytosvc zuerst gestartet wird. Gehen Sie zu diesem Zweck folgendermaßen vor:
  1. Klicken Sie auf Start
    Bild minimierenBild vergrößern
    Schaltfläche 'Start'
    , und geben Sie in das Feld Suche starten die Zeichenfolge regedit ein. Drücken Sie dann die EINGABETASTE.
    Bild minimierenBild vergrößern
    UAC
    Wenn Sie zur Eingabe eines Administratorkennworts oder zum Bestätigen aufgefordert werden, geben Sie das Kennwort ein, oder bestätigen Sie den Vorgang.
  2. Suchen Sie den folgenden Registrierungsunterschlüssel, und klicken Sie darauf:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
  3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf Wert der mehrteiligen Zeichenfolge.
  4. Geben Sie DependOnService ein, und drücken Sie dann die EINGABETASTE.
  5. Klicken Sie mit der rechten Maustaste auf DependOnService, und klicken Sie dann auf Ändern.
  6. Geben Sie in das Feld Wert die Zeichenfolge CRYPTSVC ein, und klicken Sie dann auf OK.
  7. Beenden Sie den Registrierungs-Editor.
  8. Starten Sie den Computer neu.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684 Erläuterung von Standardbegriffen bei Microsoft-Softwareupdates

Weitere Dateiinformationen

Weitere Dateiinformationen zu Windows Vista und Windows Server 2008

Weitere Dateien für alle unterstützten x86-basierten Versionen von Windows Vista und Windows Server 2008
Tabelle minimierenTabelle vergrößern
File nameUpdate.mum
File versionNot applicable
File size3,078
Date (UTC)20-Sep-2010
Time (UTC)12:19
PlatformNot applicable
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File versionNot applicable
File size696
Date (UTC)20-Sep-2010
Time (UTC)12:19
PlatformNot applicable
File nameX86_f00f5788d03e0238eabdd2760bdc3d8b_31bf3856ad364e35_6.0.6002.22490_none_4f7f86c025f21c90.manifest
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File size692
Date (UTC)20-Sep-2010
Time (UTC)12:19
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Date (UTC)17-Sep-2010
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Weitere Dateien für alle unterstützten x64-basierten Versionen von Windows Vista und Windows Server 2008
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Weitere Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008
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File nameIa64_microsoft-windows-http_31bf3856ad364e35_6.0.6002.22490_none_aed16b0a2f65d565.manifest
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Date (UTC)17-Sep-2010
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Date (UTC)20-Sep-2010
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File nameX86_microsoft-windows-http-api_31bf3856ad364e35_6.0.6002.22490_none_f7bb07cab3d8b924.manifest
File versionNot applicable
File size4,708
Date (UTC)17-Sep-2010
Time (UTC)18:18
PlatformNot applicable

Eigenschaften

Artikel-ID: 2379016 - Geändert am: Montag, 31. Oktober 2011 - Version: 8.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 Service Pack 2, wenn verwendet mit:
    • Windows Server 2008 Datacenter without Hyper-V
    • Windows Server 2008 Enterprise without Hyper-V
    • Windows Server 2008 for Itanium-Based Systems
    • Windows Server 2008 Foundation
    • Windows Server 2008 Standard without Hyper-V
    • Windows Server 2008 Datacenter
    • Windows Server 2008 Enterprise
    • Windows Server 2008 Standard
    • Windows Web Server 2008
  • Windows Vista Service Pack 2, wenn verwendet mit:
    • Windows Vista Business
    • Windows Vista Business 64-bit edition
    • Windows Vista Enterprise
    • Windows Vista Ultimate
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Ultimate 64-bit edition
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