Come convertire un database di Access a SQL Server

Traduzione articoli Traduzione articoli
Identificativo articolo: 237980 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Nota: se si utilizza Access 97 e versioni successive, è inoltre possibile utilizzare SQL Server Migration Assistant per l'accesso. Per ulteriori informazioni su SQL Server Migration Assistant per Access, visitare il seguente sito Web Microsoft:

http://www.microsoft.com/SQLServer/en/us/Product-Info/Migration-Tool.aspx#Access

Il modo più semplice per convertire un database di Access in SQL Server consiste nell'utilizzare l'Upsize guidato. L'Upsize guidato:
  • Mantiene la struttura del database, inclusi dati, indici, le impostazioni di anddefault.
  • Converte automaticamente le regole di convalida di accesso e defaultsettings gli equivalenti di SQL Server appropriati.
  • Gestisce le relazioni e referenziale integrityafter si esegue l'upsize.


Per eseguire l'Upsize guidato in Access 2000, dal menu Strumenti , scegliere utilità Database, quindi L'Upsize guidato.

Per utilizzare l'Upsize guidato in Access 97, è innanzitutto necessario scaricare Microsoft Access Upsizing Tools 97 dal seguente sito Web Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=f5c7a907-7c5f-46CB-9157-a1ec4e96083d&displaylang=en

Per eseguire l'Upsize guidato da Access 97, dal menu Strumenti , scegliere componentiaggiuntivi, quindi eseguire l'Upsize a SQL Server.

Se si dispone di una versione precedente di Access, è possibile utilizzare uno dei seguenti metodi:
  • L'aggiornamento a Access 97 o Access 2000 e quindi eseguire theUpsizing procedura guidata.
  • Utilizzare SQL Server Data Transformation Services (DTS) per importthe dati dal database di Access a un database di SQL Server. Per ulteriori informazioni su DTS e l'importazione guidata DTS, vedere gli argomenti "Dati TransformationServices" e "Utilizzo di the Import and Export Wizards" in linea di SQL Server 7.0Books. Per un esempio, vedere l'argomento "Importazione di dati da un accesso DatabaseExample" nella documentazione in linea di SQL Server.

Access 2000

In Access 2000, dal menu File scegliere Nuovoe quindi fare clic su Nuovo progetto da un Database esistente. Questa opzione consente di creare un'applicazione di elaborazione automatica dei dati (ADP). Questa applicazione utilizza il SQL Server Desktop Engine (MSDE 2000) o SQL Server come server e automaticamente viene utilizzato il file ADP come l'applicazione.

Nota. Quando si esegue l'Upsize guidato da Access 97 o Access 2000 a SQL Server 2000, è possibile che venga visualizzato un errore di "Overflow". Per ulteriori informazioni, fare clic sui numeri degli articolo riportato di seguito per visualizzare gli articoli della Microsoft Knowledge Base:
279454 Quando si tenta di eseguire l'upsize a SQL Server 2000 viene visualizzato il messaggio di errore "Overflow"
Per ulteriori informazioni sui problemi tra Access 2000 e SQL Server 2000, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
269824 Problemi di descrizione dei problemi di compatibilità tra i progetti di Access 2000 (*. adp) e SQL Server 2000
I seguenti white paper consentono di importare l'applicazione di accesso a SQL Server:
  • Progettazione di applicazioni efficienti per Microsoft SQL Server: in questo white paper spiega perché la progettazione di applicazioni di accesso sequenziale indicizzato (ISAM) del metodo non è appropriato per SQL Server.
    http://msdn2.microsoft.com/en-us/library/aa226307 (SQL.70).aspx
  • Migrazione del Database di Microsoft Access a SQL Server 7.0: questo white paper illustra l'Upsize guidato, incluse informazioni su designchanges e limitazioni della procedura guidata.
    http://technet.microsoft.com/en-us/library/cc917601.aspx

Access 97

Per ulteriori informazioni su Microsoft Access upsize strumenti 97, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=f5c7a907-7c5f-46CB-9157-a1ec4e96083d&displaylang=en
Per scaricare il 97 strumenti upsize di Microsoft Access, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=f5c7a907-7c5f-46CB-9157-a1ec4e96083d
Per ulteriori informazioni, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
176614 Microsoft Access 97 Upsizing Tools disponibili
279454 Quando si tenta di eseguire l'upsize a SQL Server 2000 viene visualizzato il messaggio di errore "Overflow"

Riferimenti

Per ulteriori informazioni sulla migrazione di un Database di Access a SQL Server, visitare il seguente sito Web Microsoft:
http://msdn.microsoft.com/en-us/library/aa139985.aspx

Proprietà

Identificativo articolo: 237980 - Ultima modifica: giovedì 9 gennaio 2014 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft SQL Server 2000 Standard Edition
  • Microsoft SQL Server 7.0 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Access 2.0 Standard Edition
Chiavi: 
kbsqlsetup kbhowtomaster kbhowto kbinfo kbmt KB237980 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 237980
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com