Le sessioni di desktop remote non completamente chiuso e non Ŕ possibile stabilire nuove sessioni di desktop remote a un computer che esegue Windows Server 2008 R2

Traduzione articoli Traduzione articoli
Identificativo articolo: 2383928 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si consideri il seguente scenario:
  • Si installa il ruolo Servizi di desktop remoto in un computer che esegue Windows Server 2008 R2.
  • Si utilizza un driver di terze parti sul computer. Il driver sottoscrive le notifiche di modifica dello stato delle sessioni di desktop remote.
  • Il computer Ŕ in esecuzione sotto un carico pesante. Ad esempio, pi¨ utenti spesso stabiliscono sessioni desktop remote al computer.
In questo scenario, alcune sessioni di desktop remote non chiudere completamente sul computer. ╚ possibile trovare che vi Ŕ un processo Csrss.exe lasciata in tali sessioni. Dopo qualche tempo, inoltre, non Ŕ possibile stabilire nuove sessioni desktop remote al computer. Se si tenta di riavviare il computer per risolvere il problema, il processo di arresto non risponde. ╚ necessario disattivare manualmente e riavviare il computer.

Cause

Il problema si verifica a causa di un problema nel driver Win32k.sys.

Se una sessione di desktop remoto viene chiuso prima che la sessione Ŕ completamente inizializzata, la notifica di modifica dello stato della sessione non viene inviata al driver di terze parti. In questo caso, il driver possibile una perdita di risorse, ad esempio un thread di sistema, nel contesto di Csrss.exe perchÚ non Ŕ possibile scaricare il driver di terze parti. Il perdita di thread comporta la sessione di desktop remoto non chiudere completamente. Dopo che il computer Ŕ in esecuzione in questo stato per un certo periodo, le connessioni in ingresso nuova Gestione sessioni locali (Lsm.exe) blocchi. Inoltre, queste sessioni orfane inoltre causano il processo di arresto di rispondere. Pertanto, si verifica il problema descritto nella sezione "Sintomi".

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato alla correzione del problema descritto in questo articolo. Applicare questa correzione solo ai sistemi in cui si verificano il problema descritto in questo articolo. Questo hotfix potrebbe eseguite ulteriori verifiche. Se questo problema non causa gravi difficoltÓ, si consiglia di attendere il successivo aggiornamento software contenente questo hotfix.

Se la correzione Ŕ disponibile per il download, Ŕ presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non compare, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

NotaSe si verificano ulteriori problemi o se Ŕ necessaria la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo di numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.Microsoft.com/contactus/?ws=support
NotaIl modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'hotfix. Se la lingua non viene visualizzata, Ŕ perchÚ un aggiornamento rapido non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, Ŕ necessario che sia in esecuzione Windows Server 2008 R2 Ŕ installato il ruolo Servizi di desktop remoto.

Informazioni del Registro di sistema

Per utilizzare la correzione rapida in questo pacchetto, non Ŕ necessario apportare modifiche al Registro di sistema.

NecessitÓ di riavvio

Potrebbe essere necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo hotfix non sostituisce un hotfix precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle riportate di seguito. Le date e le ore dei file sono elencate in UTC (Coordinated Universal Time). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza di ora legale (DST) corrente. Inoltre, le date e gli orari possono variare quando si eseguono determinate operazioni sui file.
Nota le informazioni file di Windows Server 2008 R2
ImportanteWindows Server 2008 R2 correzioni rapide di Windows 7 e sono inclusi nel pacchetto stesso. Tuttavia, aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella sezione "Windows 7 e Windows Server 2008 R2" nella pagina. Sempre fare riferimento alla sezione "Si applica A" di articoli per determinare il sistema operativo effettivo che ogni aggiornamento rapido si applica a.
  • I file MANIFEST (manifest) e MUM file (mum) installati per ogni ambiente sonoelencati separatamenteNella sezione "ulteriori informazioni sui file per Windows Server 2008 R2". MUM e file MANIFEST e i file di catalogo (cat) di protezione associato sono estremamente importanti per mantenere lo stato dei componenti aggiornati. I file di catalogo di protezione, per cui non sono elencati gli attributi sono firmati mediante firma digitale Microsoft.
Per tutte le edizioni x 64 e basate su versioni di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome fileVersione fileDimensioni fileDataOraPiattaforma
Win32k.sys6.1.7600.207853,124,22420-Ago-201021: 03x 64

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows Server 2008 R2

File aggiuntivi per tutte le edizioni x 64 e basate su versioni di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome fileAmd64_01f18e329113c56c411a2656cb85a39c_31bf3856ad364e35_6.1.7600.20785_none_c57808013e7dd016.manifest
Versione fileNon applicabile
Dimensioni file698
Data (UTC)20-Ago-2010
Ora (Time)08: 32
PiattaformaNon applicabile

Nome fileAmd64_8874ac5cdd8dc962b5fbc3c4dc7f4f52_31bf3856ad364e35_6.1.7600.20785_none_44fbfd7bf058d9cd.manifest
Versione fileNon applicabile
Dimensioni file1,038
Data (UTC)20-Ago-2010
Ora (Time)08: 32
PiattaformaNon applicabile

Nome fileAmd64_b15700d8fdea63dbf2b942e50923e8af_31bf3856ad364e35_6.1.7600.20785_none_625e836b8f863476.manifest
Versione fileNon applicabile
Dimensioni file698
Data (UTC)20-Ago-2010
Ora (Time)08: 32
PiattaformaNon applicabile

Nome fileAmd64_microsoft finestre win32k_31bf3856ad364e35_6.1.7600.20785_none_15720ddecd5567a6.manifest
Versione fileNon applicabile
Dimensioni file42,090
Data (UTC)20-Ago-2010
Ora (Time)06: 15
PiattaformaNon applicabile

Nome fileUpdate.mum
Versione fileNon applicabile
Dimensioni file2.536
Data (UTC)20-Ago-2010
Ora (Time)08: 32
PiattaformaNon applicabile

Nome fileWow64_microsoft finestre win32k_31bf3856ad364e35_6.1.7600.20785_none_1fc6b83101b629a1.manifest
Versione fileNon applicabile
Dimensioni file4,178
Data (UTC)20-Ago-2010
Ora (Time)05: 10
PiattaformaNon applicabile

ProprietÓ

Identificativo articolo: 2383928 - Ultima modifica: giovedý 14 ottobre 2010 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Foundation
Chiavi:á
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2383928 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2383928
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com