Modifica della password NTLM non funziona quando password contiene una e commerciale (&)

Traduzione articoli Traduzione articoli
Identificativo articolo: 238631 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di modificare una password di Microsoft Windows NT scaduta in Microsoft Internet Information Server (IIS) 4.0 e si utilizza una e commerciale (&) la nuova password, la password non verrà modificati, anche se viene visualizzato il seguente messaggio dopo aver completato il modulo di modifica password:
Operazione completata
Quando una modifica della password ha esito positivo viene restituita "Password modificata correttamente". La e commerciale è un carattere di password valida in Windows NT.

Cause

Nel codice di analisi in ISM.dll si presuppone la sequenza riportata di seguito:
VARIABILE = VALORE &
Quando si utilizza una e commerciale (&) nella password, una sequenza di caratteri e commerciale uno o più viene creata prima un segno di uguale (=). Ad esempio, vecchia password = password & funzionerà correttamente, ma nuova password = m & m & non.

Risoluzione

Windows NT Server o Workstation 4.0

Per risolvere il problema, procurarsi l'ultimo service pack per Windows NT 4.0. Per ulteriori informazioni su come ottenere il service pack più recente per Windows NT 4.0, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
152734Come ottenere il service pack più recente per Windows NT 4.0
Per informazioni su come ottenere l'aggiornamento del singolo prodotto software, contattare il servizio supporto tecnico clienti Microsoft. Per un elenco completo di numeri di telefono del servizio supporto tecnico clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota in casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Supporto Tecnico Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Nota Le correzioni di Windows NT Workstation 4.0 di IIS e Windows 95/98 disporrà di proprietà di file diverso.

Windows NT Server 4.0, Terminal Server Edition

Per risolvere questo problema, è necessario ottenere il service pack più recente per Windows NT Server 4.0, Terminal Server Edition. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
152734Come ottenere il service pack più recente per Windows NT 4.0

Status

Microsoft ha confermato che questo un problema per Internet Information Server 4.0, Windows NT 4.0 e Windows NT Server 4.0, Terminal Server Edition. Questo problema è stato risolto per la prima volta nel Service Pack 6 per Windows NT 4.0 e nel Service Pack 6 per Windows NT Server 4.0, Terminal Server Edition.

Informazioni

Un altro sintomo di questo problema può verificarsi. Il processo Inetinfo può rotazione all'utilizzo della CPU al 100 %.

Proprietà

Identificativo articolo: 238631 - Ultima modifica: venerdì 13 ottobre 2006 - Revisione: 4.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Internet Information Server 4.0
Chiavi: 
kbmt kbhotfixserver kbbug kbfix kbqfe KB238631 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 238631
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com