ID Artikel: 238833 - Kajian Terakhir: 20 September 2011 - Revisi: 2.0

PRB: XML Parser: karakter tidak sah ditemukan di konten teks

Tips SistemThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Perbesar semua | Perkecil semua

GEJALA

Saat mem-parsing XML yang berisi "karakter khusus" menggunakan parser Microsoft XML (MSXML), parser dapat melaporkan pesan galat berikut di baris dan posisi pertama karakter khusus:
Karakter tidak sah ditemukan di konten teks.

PENYEBAB

Dokumen XML tidak ditandai dengan skema pengkodean karakter yang tepat.

PEMECAHAN MASALAH

Tentukan skema pengkodean yang tepat petunjuk pemrosesan XML.

- atau -

Me XML data sebagai tepat UTF-8.

STATUS

Perilaku ini sesuai rancangannya.

INFORMASI LEBIH LANJUT

"Karakter khusus" mengacu pada setiap karakter di luar standar ASCII karakter set 0x00 - 0x7F, seperti karakter Latin dengan aksen, umlaut-umlaut atau diakritik lain. Pengkodean skema untuk dokumen XML standar adalah UTF-8, yang encode ASCII karakter dengan nilai 0x80 atau lebih tinggi berbeda dari skema pengkodean standar lainnya.

Paling sering, Anda melihat masalah ini jika Anda bekerja dengan data yang menggunakan skema pengkodean "iso-8859-1" sederhana. Dalam kasus ini, solusi tercepat biasanya adalah pertama sebelum terdaftar di bagian pemecahan masalah. Sebagai contoh, menggunakan deklarasi XML berikut:
   <?xml version="1.0" encoding="iso-8859-1" ?>
   <rootelement>
   ...XML data...
   </rootelement>
				
Atau, Anda dapat menyandikan masing-masing karakter-karakter yang menggunakan referensi entitas numerik. Sebagai contoh, Anda dapat mengambil karakter khusus á, menggunakan <test>á</test> (versi desimal) atau <test>á</test> (hex versi).
Kata kunci: 
kbFAQ kbintl kbintldev kbprb kbmt KB238833 KbMtid
Penerjemahan MesinPenerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:238833  (http://support.microsoft.com/kb/238833/en-us/ )