SMS : Le processus SMSMon32 se bloque sur les clients après l'application de SMS 2.0 SP1

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Numéro d'article: 238865 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F238865
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Symptômes

IMPORTANT : Cet article contient des informations sur l'édition du Registre. Avant de modifier le Registre, assurez-vous qu'il vous sera possible de le restaurer en cas de problème. Pour plus d'informations sur la procédure requise à cet effet, consultez la rubrique d'aide " Restaurer le Registre " de Regedit.exe ou " Restaurer une clé du Registre " de Regedt32.exe.
Après la mise à niveau d'un site Systems Management Server (SMS) 2.0 par le biais du Service Pack 1 (SP1), les ordinateurs clients connectés au site peuvent accuser des délais de réponse ou même cesser de répondre (se bloquer). Sur ces ordinateurs, le processus smsmon32.exe risque d'utiliser la plus grande partie du temps de traitement du processeur et de ne pas laisser la place aux autres processus.

Cause

Le processus smsmon32 risque de se bloquer au cours de la mise à niveau du client par le biais du SP1 pour l'une des raisons suivantes :
  • Un ou plusieurs sites ont été mis à niveau dans le cadre d'un modèle domaine unique - sites multiples. Pour plus d'informations, consultez l'article suivant dans la Base de connaissances :
    236596 SMS : Échec de l'installation des composants clients avec SMS 2.0 SP1
  • Lorsque les clients d'un site qui n'a pas été mis à jour se connectent et exécutent le script d'ouverture de session SMS, ils reçoivent les composants de base mis à jour à partir du point d'ouverture de session. Toutefois, lorsque le client se connecte au point d'accès client (CAP), une incompatibilité de versions (parce que le CAP n'est pas mis à jour) peut provoquer le blocage de Smsmon32.exe sur les ordinateurs clients.

Contournement

AVERTISSEMENT : Une mauvaise utilisation de l'Éditeur du Registre peut entraîner des problèmes graves qui peuvent vous obliger à réinstaller le système d'exploitation. Microsoft ne peut garantir que les problèmes issus d'une mauvaise utilisation de l'Éditeur du Registre pourront être résolus. L'utilisation de l'Éditeur du Registre est faite aux risques et périls de l'utilisateur. Pour plus d'informations sur la façon de modifier le Registre, reportez-vous à la rubrique d'aide " Modification des clés et des valeurs " dans l'Éditeur du Registre (Regedit.exe) ou aux rubriques d'aide " Ajouter et supprimer des informations dans le Registre " ainsi que " Modifier les données du Registre " dans Regedt32.exe. Nous vous conseillons d'effectuer une copie de sauvegarde du Registre avant de le modifier. Si votre système d'exploitation est Windows NT ou Windows 2000, nous vous conseillons également de mettre à jour votre disquette de réparation d'urgence (ERD, Emergency Repair Disk).
Si un client reçoit une version incompatible, il sera nécessaire de supprimer et de réinstaller complètement le client SMS pour corriger ce problème.

Si certaines publications actives sont en suspens et disponibles pour les clients lorsqu'ils effectuent la mise à niveau de SMS 2.0 vers SP1, Smsmon32.exe peut sembler se bloquer et il peut être nécessaire de redémarrer l'ordinateur.

À ce point, la suppression et la réinstallation totales du client SMS sont nécessaires. Une fois la réinstallation terminée, le client dispose des composants mis à niveau fournis par le serveur CAP et fonctionne correctement.

Si les ordinateurs clients appartiennent à plusieurs sites et si l'un de ces sites n'existe plus, Smsmon32.exe peut se bloquer lorsqu'il tente de contacter le site inexistant au cours de la mise à niveau de SMS 2.0 vers SP1. Pour contourner ce problème, procédez comme suit :
  1. Arrêtez tous les services SMS d'un ordinateur client Windows NT.
  2. Modifiez le Registre. Supprimez le code du site inexistant dans la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\Microsoft\SMS\Client\InstalledSites
  3. Lancez les services du client.

Plus d'informations

Pour éviter certains de ces problèmes, consultez l'article suivant dans la Base de connaissances avant d'effectuer la mise à niveau de SMS 2.0 vers SP1 :
238780 Conditions d'application optimales de SMS 2.0 SP1
Pour plus d'informations, cliquez sur les numéros ci-dessous pour consulter les articles correspondants dans la Base de connaissances :
236325 Obtention du dernier Service Pack pour Systems Management Server
237543 SMS : Remarques relatives à la mise à niveau des clients avec le Service Pack
236596 SMS : Échec de l'installation des composants clients avec SMS 2.0 SP1
238864 SMS : Les clients Windows 95/98 cessent de répondre ou deviennent instables après la mise à niveau vers SP1

Propriétés

Numéro d'article: 238865 - Dernière mise à jour: dimanche 2 février 2014 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Systems Management Server 2.0 Standard Edition
Mots-clés : 
kbnosurvey kbarchive kbsms200 smssetup prodsms KB238865
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