Article ID: 2389390 - Last Review: December 16, 2011 - Revision: 27.0

Error message when you try to migrate users from an on-premises Exchange Server environment to Exchange Online in Office 365: "Unable to connect to the server"

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SYMPTOMS

When you use the E-mail Migration Wizard in Exchange Control Panel in the Office 365 portal to try to migrate users from an on-premises Microsoft Exchange Server 2010, Exchange Server 2007, or Exchange Server 2003 environment to Exchange Online in Microsoft Office 365, you receive the following error message:

Unable to connect to the server. Please check the connection settings you supplied and try again.

CAUSE

This issue occurs for one or more of the following reasons:
  • The on-premises computer that is running Exchange Server is configured incorrectly to accept external connections from the Simple Exchange Migration engine.
  • The user account that is used to access the on-premises mailbox does not have the appropriate permissions level to access the mailbox. 
  • Autodiscover is configured incorrectly.
  • The fully qualified domain name (FQDN) or remote procedure call (RPC) proxy address is not entered correctly in the E-mail Migration Wizard.

RESOLUTION

To resolve this issue, follow these steps.

Step 1: Check Outlook Anywhere or RPC over HTTP settings on the on-premises Exchange server

The E-mail Migration Wizard in Exchange Control Panel uses Outlook Anywhere or RPC over HTTP to connect to on-premises mailboxes to migrate data. To confirm whether Outlook Anywhere settings are correct, visit one of the following Microsoft websites:

For Exchange Server 2003: http://technet.microsoft.com/en-us/library/aa996922.aspx (http://technet.microsoft.com/en-us/library/aa996922.aspx)

For Exchange Server 2007: http://technet.microsoft.com/en-us/library/bb123889(EXCHG.80).aspx (http://technet.microsoft.com/en-us/library/bb123889(EXCHG.80).aspx)

For Exchange Server 2010: http://technet.microsoft.com/en-us/library/bb123741.aspx (http://technet.microsoft.com/en-us/library/bb123741.aspx)


Outlook Anywhere requires that Internet Information Services (IIS) websites for Exchange Server use Basic authentication. For more information about how to set up Basic authentication for Outlook Anywhere, visit one of the following Microsoft websites:

For Exchange Server 2003: http://technet.microsoft.com/en-us/library/bb124462(EXCHG.65).aspx (http://technet.microsoft.com/en-us/library/bb124462(EXCHG.65).aspx)

For Exchange Server 2007: http://technet.microsoft.com/en-us/library/bb124149(EXCHG.80).aspx (http://technet.microsoft.com/en-us/library/bb124149(EXCHG.80).aspx)

For Exchange Server 2010: http://technet.microsoft.com/en-us/library/bb124149.aspx (http://technet.microsoft.com/en-us/library/bb124149.aspx)

Make sure that Secure Sockets Layer (SSL) is configured for Outlook Anywhere. For more information, visit one of the following Microsoft websites:

For Exchange Server 2003: http://technet.microsoft.com/en-us/library/aa997449(EXCHG.65).aspx (http://technet.microsoft.com/en-us/library/aa997449(EXCHG.65).aspx)

For Exchange Server 2007: http://technet.microsoft.com/en-us/library/aa995982(EXCHG.80).aspx (http://technet.microsoft.com/en-us/library/aa995982(EXCHG.80).aspx)

For Exchange Server 2010: http://technet.microsoft.com/en-us/library/aa995982.aspx (http://technet.microsoft.com/en-us/library/aa995982.aspx)

Step 2: Confirm that the public certificate is valid for Outlook Anywhere

  1. Browse to the Outlook Web App page of your company website.
  2. In the Website Identification prompt, click View certificates.

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  3. In the Certificate dialog box, make sure that the date of the certificate is valid and that the certificate is from a trusted authority.

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  4. Click the Details tab.
  5. In the Subject Alternate Name field, make sure that the FQDN for the Outlook Anywhere address of your on-premises Exchange Server environment is listed.

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Step 3: Use Remote Connectivity Analyzer to perform an Outlook Anywhere test

The E-mail Migration Wizard uses Autodiscover to connect to Exchange Server 2007 and Exchange Server 2010 environments and to download the Outlook Anywhere settings. When the migration engine receives the correct response for the Autodiscover service, it uses Outlook Anywhere to connect to the on-premises mailbox.

To troubleshoot connectivity failures to the on-premises Exchange Server environment, follow these steps:

  1. In a web browser, browse to https://www.testexchangeconnectivity.com (https://www.testexchangeconnectivity.com/) .
  2. On the Office 365 tab, under Microsoft Office Outlook Connectivity Tests, do one of the following:
    • If you are migrating users from Exchange Server 2010 or from Exchange Server 2007, click Outlook Autodiscover.
    • If you are migrating users from Exchange Server 2003, click Outlook Anywhere (RPC over HTTP).
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  3. Complete all the required fields on the form, and then click Perform Test.
  4. When the test is finished, confirm that it was successful. If the test was not successful, use the information that is provided to resolve the connectivity issue.
  5. Use the super user credentials to confirm through Outlook that you can connect to the on-premises Exchange server of the user whom you are trying to migrate. 
  6. If you continue to experience the same errors by using those credentials, repeat the test by using the credentials of the user who is set to be migrated.

Step 4: Validate the permissions that are required to migrate users from the on-premises Exchange Server environment

Exchange Control Panel-based migrations of on-premises mailbox data require that an account that has full access to the on-premises environment be used when the migration is performed. Use the following resources to confirm that your on-premises environment is configured correctly. Be aware that the migration service account will require the Receive As permission to the mailbox database or the Full Access permission to the individual mailbox that has to be migrated. 

For more information about how to provide valid permissions to the migration accounts, see the following Microsoft resources:

For Exchange Server 2003
268754  (http://support.microsoft.com/kb/268754 / ) How to assign users or groups full access to other user mailboxes
821897  (http://support.microsoft.com/kb/821897 / ) How to assign service account access to all mailboxes in Exchange Server 2003
For Exchange Server 2007

http://technet.microsoft.com/en-us/library/bb124097(EXCHG.80).aspx (http://technet.microsoft.com/en-us/library/bb124097(EXCHG.80).aspx)
http://technet.microsoft.com/en-us/library/aa996343(EXCHG.80).aspx (http://technet.microsoft.com/en-us/library/aa996343(EXCHG.80).aspx)

For Exchange Server 2010
http://technet.microsoft.com/en-us/library/bb124097.aspx (http://technet.microsoft.com/en-us/library/bb124097.aspx)

Step 5: Use the Test-MigrationServerAvailability cmdlet to obtain additional details about the error

To test the connection to the remote server by using Exchange Online Remote PowerShell, run the Test-MigrationServerAvailability cmdlet.

The following is an example of how to use this command to test access to a server that is running Exchange Server 2007 and on which Autodiscover is configured:

$PSCredentials = Get-Credential

Test-MigrationServerAvailability -Autodiscover –EmailAddress administrator@contoso.com -Credentials $PSCredentials -Verbose

The following is an example of how to use this command to test the connection to a server that is running Exchange Server 2003 or on which Exchange Autodiscover is not configured:

$PSCredentials = Get-Credential

Test-MigrationServerAvailability -Exchange -ExchangeServer exch2k3.contoso.com -Credentials $PSCredentials -RPCProxyServer mail.contoso.com -Authentication NTLM -Verbose

The results from running this cmdlet should give you more information about exactly where the connection may be failing.



APPLIES TO
  • Microsoft Office 365 for enterprises
  • Microsoft Office 365 for small businesses
Keywords: 
vkbportal231 bposs vkbportal237 o365 vkbportal230 KB2389390