Help and Support

ID do artigo: 239088 - Última revisão: sexta-feira, 20 de janeiro de 2006 - Revisão: 5.0

Eventos 1111, 1105 e 1106 do log do servidor dos Serviços de terminal do Windows 2000

IMPORTANTE: Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e verifique se sabe como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e editar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft.
256986  (http://support.microsoft.com/kb/256986/PT-BR/ ) Descrição do Registro do Microsoft Windows

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Os Serviços de terminal do Windows 2000 suportam o redirecionamento automático de impressoras configuradas para usar portas locais (como, por exemplo, LPT1, LPT2 ou LPT3) nos computadores que possuem sessões abertas de clientes através do cliente RDP 5 (Remote Desktop Protocol). Esse redirecionamento da impressora ocorre, por padrão, durante o logon.

Entretanto, se você estiver usando drivers de outras empresas ou alguns drivers do Microsoft Windows 95/Microsoft Windows 98 no cliente, o redirecionamento da impressora não funcionará. Quando isso ocorre, as seguintes mensagens de erro são registradas no log de eventos do sistema no servidor:
Tipo: Erro
Identificação do evento: 1111
Descrição: Driver nome do driver necessário para a impressora tipo da impressora é desconhecido. Contate o administrador para instalar o driver antes de efetuar logon novamente.

Tipo: Erro
Identificação do evento: 1105
Descrição: As informações de segurança para nome da impressora/nome do computador cliente/ número da sessão, não puderam ser definidas.

Tipo: Erro
Identificação do evento: 1106
Descrição: Não foi possível instalar a impressora.

Causa

Quando um cliente efetua logon, o servidor com o Windows 2000 verifica o nome do driver de impressora no cliente e procura pelo mesmo nome de driver de impressora no arquivo Ntprint.inf do Windows 2000. Se o nome do driver não for localizado, as mensagens de erro são registradas e a impressora não é redirecionada.

Resolução

Antes do Service Pack 2, você tinha de editar o arquivo Ntprint.inf para corrigir esse problema. Isso quebrava a assinatura digital no Ntprint.inf e fazia com o sistema retornasse um aviso toda vez que um usuário instalasse uma nova impressora. As etapas a seguir são, no momento, o método recomendado para corrigir esse problema e necessitam que o Windows 2000 Service Pack 2 ou mais recente seja aplicado primeiro. Isso permite que você especifique um arquivo .inf diferente no Registro para que o Windows verifique se não é possível localizar o driver em Ntprint.inf.

Importante O evento, erro 1110, também pode ser causado por uma referência incorreta ao nome INF no valor PrinterMappingINFName adicionado por você. Verifique se está usando o nome INF correto.
  1. Abra o Regedt32.exe e localize a seguinte chave:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd
  2. Adicione os seguintes valores:
    Nome: PrinterMappingINFName
    Tipo: REG_SZ
    Dados: Nome do arquivo .inf para o qual você deseja redirecionar as pesquisas.
    Exemplo: c:\winnt\inf\ntprintsubs.inf

    Nome: PrinterMappingINFSection
    Tipo: REG_SZ
    Dados: Nome da seção no arquivo .inf para a qual você deseja redirecionar as pesquisas. Exemplo: Impressoras
Após adicionar os novos valores do Registro, crie ou modifique um arquivo .inf para incluir os mapeamentos definidos pelo usuário, dos drivers do lado do cliente para o lado do servidor. Para fazer isso, execute o seguinte exemplo:

Exemplo do formato para criar um novo arquivo .inf:
[Versão]
Assinatura="$CHICAGO$"

[Impressoras]
"Nome do driver da impressora OEM (fabricante original do equipamento)" = "Nome do driver da impressora do Windows 2000"
				
Como, por exemplo:
"HP DeskJet 720C Series v10.3"  =  "HP DeskJet 722C"
				
O lado esquerdo do sinal "=" é o nome exato do driver da impressora associado com a fila de impressão do lado do cliente que está sendo redirecionada para o servidor. O lado direito do sinal '=' é o nome exato do driver do lado do servidor correspondente instalado no Terminal Server.

O nome da impressora amigável exibido ao clicar em Iniciar, em Configurações e em Impressoras, no cliente, pode não ser o nome real do driver da impressora que deverá ser redirecionado para apontar para o driver da impressora no Terminal Server. Para localizar o nome do driver da impressora de modo a adicioná-lo ao lado esquerdo do sinal de igualdade (=) no arquivo .inf que você criou, procure no log de eventos do sistema no Terminal Server na identificação do evento 1111 que está sendo registrada. A identificação do evento 1111 contém o nome real do driver de impressora que não está sendo redirecionado. Algumas identificações do evento 1111 também contêm recursos de impressora no cliente que não podem e não devem ser redirecionados como drivers de fax ou softwares de impressoras. Se não souber o nome do driver da impressora para adicionar ao lado direito do sinal de igualdade no arquivo .inf, você poderá instalar a impressora no servidor. Após a instalação da impressora, o nome do driver da impressora aparece ao lado direito de "Modelo:" na guia "Geral" nas propriedades da impressora. Quando possível, os drivers de impressora internos incluídos no sistema operacional, assinados ou drivers de impressora WHQL devem ser usados para melhorar a estabilidade do sistema.

Esse exemplo instrui o Windows 2000 a usar o driver HP DeskJet 722C quando um cliente com driver Hewlett-Packard DeskJet 720C Series v10.3 da HP se conecta. Esses nomes devem ser exatamente iguais, com o espaçamento exato; os nomes também diferenciam letras maiúsculas de minúsculas.

OBSERVAÇÃO: O formato da seção [Nomes anteriores] no arquivo Ntprint.inf é exatamente o contrário do arquivo .inf definido pelo usuário. No arquivo Ntprint.inf, o driver do lado do cliente está no lado direito e o driver do lado do servidor está no lado esquerdo.

É possível criar esse arquivo com o Bloco de notas e ele deve ser salvo com uma extensão de nome .inf. Nesse exemplo, você especificaria o nome do arquivo .inf recém-criado no valor do Registro PrinterMappingINFName e "Impressoras" no valor do Registro PrinterMappingINFSection.

Quando um cliente se conectar, o computador irá, antes de tudo, verificar se um arquivo .inf definido pelo usuário foi definido no Registro. Se isso ocorreu, irá verificar se há um correspondente para o driver do lado do cliente usá-lo. Se não houver, verificará se existe um mapeamento definido na seção [Nomes anteriores] do arquivo Ntprint.inf para ser usado. Se não existir, tentará instalar a impressora do lado do servidor usando o nome do driver de impressora do lado do cliente como um mapa direto para um driver do lado do servidor. Se nenhum driver for encontrado, as mensagens de erro mencionadas nesse artigo serão exibidas.

Se o arquivo .inf personalizado contiver erros de sintaxe, a seguinte mensagem no log de eventos será exibida:
Event 1110: "Erro ao processar ntprint.inf. Se o arquivo no sistema estiver corrompido, será possível restaurá-lo a partir da mídia de instalação.
Essa mensagem não é muita clara, porque refere-se ao arquivo Ntprint.inf. Apesar desse erro realmente significar que o Ntprint.inf está corrompido, ele normalmente refere-se aos erros no arquivo .inf personalizado.

O arquivo .inf personalizado possui pelo menos um mapeamento em sua seção de mapeamento de nome de impressora. Se o arquivo .inf personalizado possuir uma seção de mapeamento de nome em branco, você poderá receber um evento 1110 no log de eventos. Você deve reiniciar o serviço Spooler ou reiniciar o Terminal Server para que essas alterações surtam efeito.

Assistente do Terminal Server Printer Driver Redirection

O assistente do Terminal Server Printer Driver Redirection automatiza o processo de criação do arquivo.inf. O assistente o ajuda a solucionar problemas e substituir os drivers da impressora que foram redirecionados sem sucesso.

O seguinte arquivo está disponível para o download no Centro de Download da Microsoft:


Recolher esta imagemExpandir esta imagem
Download
Baixe o pacote 9f237742-e057-4e00-a0d5-62de2ebf9fbd/TSPDRW_Package.exe agora. (http://download.microsoft.com/download/9/f/2/9f237742-e057-4e00-a0d5-62de2ebf9fbd/tspdrw_package.exe)

Mais Informações

O redirecionamento de impressora não é possível com o cliente do RDP 4 no Windows NT Server 4.0, Terminal Server Edition. Em um ambiente do terminal server do Windows NT 4.0, você deve usar o Citrix MetaFrame e o cliente do ICA (Independent Computing Architecture) para redirecionar impressoras clientes.

Para obter informações sobre como realizar esse procedimento para clientes do Citrix ICA, leia o seguinte artigo da Base de Dados de Conhecimento da Microsoft:
214593  (http://support.microsoft.com/kb/214593/ ) Windows Terminal Server com cliente do MetaFrame ICA não pode criar automaticamente algumas impressoras

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Palavras-chave: 
kbprb kbprint kbtermserv KB239088

Traduções deste artigo

 

Related Support Centers