Anruf beim Microsoft Lync Server-Reaktionsgruppen-Agent schlägt fehl

Symptome

Ein Lync-Benutzer ruft einen Lync Server-Antwortgruppen-Agent an, der in der Lync-Kontaktliste aufgeführt ist. Der Lync Server-Reaktionsgruppen-Agent empfängt den Anruf jedoch nicht wie erwartet.

Ursache

Dieses Problem tritt auf, wenn mindestens eine der folgenden Bedingungen zutrifft:

  • Das Lync Server-fähige Benutzerkonto für den Lync Server-Reaktionsgruppen-Agent wurde einer anderen SIP-Domäne zugewiesen, die im Lync Server-Pool oder -Server registriert ist.
  • Das Update für den SIP-URI des Lync Server-Reaktionsgruppen-Agents wurde in den Lync Server-Antwortgruppen, in denen der Lync Server-Reaktionsgruppen-Agent Mitglied ist, nicht durchgeführt.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Verwenden Sie die Lync Server-Systemsteuerung, um auf die Menüoption Reaktionsgruppen zuzugreifen.
  2. Klicken Sie im Menü Reaktionsgruppe auf Gruppierung.
  3. Wählen Sie die spezifische Lync Server-Antwortgruppe aus, in der der aktualisierte Reaktionsgruppen-Agent Mitglied ist.

    Hinweis

    Der Lync Server-Reaktionsgruppen-Agent kann zu mehreren Lync Server-Antwortgruppen gehören.

  4. Klicken Sie auf der Menüleiste auf Details bearbeiten.
  5. Scrollen Sie nach unten, um den ursprünglichen SIP-URI für den Lync Server-Antwortgruppen-Agent in der Agent-Liste zu suchen.
  6. Wählen Sie den angegebenen Lync Server-Reaktionsgruppen-Agent aus, und klicken Sie dann auf der Menüleiste auf die Option Entfernen .
  7. Klicken Sie in der oberen Menüleiste auf die Option Commit.
  8. Wiederholen Sie die Schritte 3 und 4.
  9. Scrollen Sie nach unten, um die Liste des Lync Server-Reaktionsgruppen-Agents zu suchen.
  10. Klicken Sie auf der Menüleiste auf Auswählen.
  11. Verwenden Sie im Dialogfeld Agents auswählen das Feature Suchen, um den Lync Server-aktivierten Benutzer zu suchen, der der ausgewählten Lync Server-Antwortgruppe erneut hinzugefügt wird.
  12. Wählen Sie den Agent mit dem richtigen SIP-URI aus, und klicken Sie dann auf OK.
  13. Klicken Sie in der oberen Menüleiste auf Commit.
  14. Klicken Sie oben im Bereich Reaktionsgruppe auf Aktualisieren.
  15. Melden Sie sich ab, und melden Sie sich dann wieder bei den Lync-Clients an, bei denen das Problem auftritt.
  16. Führen Sie einen Anruf an einen Lync Server-Reaktionsgruppen-Agent aus der Lync-Clientkontaktliste aus.

Weitere Informationen

Standardmäßig wird der folgende Fehler von der Anwendung generiert:

Windows Powershell returned the following errors: Cannot insert duplicate key row in object dbo.Agents with unique index IX_Agents_UserSid. 
The statement has been terminated.

Dieser Fehler tritt auf, weil die entfernten Informationen des Lync Server-Antwortgruppen-Agents im dbo zum Löschen markiert wurden. Agents-Tabelle der rgsconfig-Datenbank. Mit dem Löschvorgang für den entfernten Datensatz des Lync Server-Antwortgruppen-Agents im dbo ist eine gewisse Latenz verbunden. Agents-Tabelle der rgsconfig-Datenbank. Erst nachdem die Zeile, die die unerwünschten Informationen des Lync Server-Reaktionsgruppen-Agents enthält, vollständig aus dem dbo entfernt wurde. Tabelle Agents: Der Commitprozess der Lync Server-Reaktionsgruppen-Agentgruppe kann abgeschlossen werden.

Daher ist das Verhalten, das im Abschnitt "Symptome" beschrieben wird, beabsichtigt.

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