Error de cola de impresión cuando desaparece el controlador de impresora

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Este es un artículo paso a paso.

Síntomas

De repente desaparece el controlador de impresora mientras está en uso y se produce un error de cola de impresión.


Causa

La configuración predeterminada del controlador de impresora fue modificado erróneamente y el archivo del controlador está dañado.

Solución


Corregir el problema para mí

Para solucionar el problema de forma automática, haga clic en el vínculo Fix it o en el botón gráfico. Haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y, a continuación, siga los pasos del Asistente Fix it.

Solucionar el problema
Microsoft Fix it 50126

  • Este asistente podría estar sólo en inglés. Sin embargo, la solución automática también funciona con las otras versiones de idioma de Windows.
  • Si no usa el equipo que tiene el problema, puede guardar la solución Fix it en una unidad flash o en un CD y, a continuación, ejecutarla en el equipo con el problema.

Paso 1: Detener el servicio de la Cola de impresión y eliminar los elementos en la carpeta Spool

  1. Haz clic en Inicio
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    y, a continuación, en Panel de control.

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  2. En el Panel de control, haz clic en Sistema y seguridad.

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  3. En Sistema y seguridad, haz clic en Herramientas administrativas.

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  4. En Herramientas administrativas, haz doble clic en Servicios.

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  5. En Servicios, haz doble clic en Cola de impresión.

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  6. En la ventana de Propiedades de Cola de impresión, haz clic en Detener y, a continuación, en Aceptar.

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  7. Abre el explorador de Windows y escribe la ruta C:\Windows\System32\spool\PRINTERS.

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  8. Ahora elimina todos los archivos existentes enPRINTERS, incluidas carpetas y subcarpetas.

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  9. En el explorador de Windows, escribe la ruta C:\Windows\System32\spool\drivers\w32x86.

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  10. En C:\Windows\System32\spool\drivers\w32x86, elimina todos los archivos existentes.

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  11. Vuelve a instalar el controlador de impresora desde el CD que se suministró con ésta o descárgalo de la página web del fabricante para determinar si el error persiste. Si es así, continúa con el siguiente paso.

Paso 1: Detener el servicio de la Cola de impresión y eliminar los elementos en la carpeta Spool (video)

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uuid=3319b5f9-792a-408f-99a8-f1e278926224 VideoUrl=http://www.microsoft.com/es-es/showcase/details.aspx?uuid=3319b5f9-792a-408f-99a8-f1e278926224
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Paso 2: Realizar una copia de seguridad del Registro

Nota: en este paso se muestra cómo se realiza una copia de seguridad del Registro porque en el paso 3 se modifican algunos de sus valores, lo que puede producir un error grave si se hace de manera equivocada. De esta forma, se puede regresar a un estado previo al error.

  1. Haz clic en Inicio
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    y, en la ventana de búsqueda, escribe regedit. A continuación, presiona Intro.

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    Nota:
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    si se te solicita una contraseña de administrador o una confirmación, escribe la contraseña o confírmala según corresponda.
  2. En el Editor de Registro, desplázate hasta la ruta HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print. A continuación, selecciona la carpeta Print, haz clic en Archivo y elige Exportar?

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  3. Ahora especifica una ruta para la copia de seguridad, escribe un nombre, por ejemplo, Print, y haz clic en Guardar.

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Paso 2: Realizar una copia de seguridad del Registro (video)

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uuid=f02c923a-4afd-445e-965d-6829e441d37a VideoUrl=http://www.microsoft.com/es-es/showcase/details.aspx?uuid=f02c923a-4afd-445e-965d-6829e441d37a
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Paso 3: Modificar el registro

Importante: esta sección contiene pasos que indican cómo modificar el Registro. Sin embargo, pueden surgir graves problemas si se modifica el Registro incorrectamente. Por lo tanto, asegúrate de seguir estos pasos cuidadosamente. Para mayor protección, haz una copia de seguridad del Registro antes de modificarlo. Si deseas obtener más información al respecto, puedes consultar el paso anterior o el artículo Copia de seguridad del Registro.
  1. En el Editor del Registro, desplázate hasta la ruta HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Local Port y haz doble clic en Driver.

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  2. En Información del valor dela ventana Editar cadena, encontrarás el archivo localspl.dll. De lo contrario, escribelo.

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  3. En el Editor del Registro, desplázate hasta la ruta HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers y elimina todas las subcarpetas.

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  4. En el Editor del Registro, desplázate hasta la ruta HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors y elimina las carpetas:

    Local Port
    Microsoft Shared Fax Monitor
    Standard TCP/IP Port
    USB Monitor
    WSD Port


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  5. En el Editor del Registro, desplázate hasta la ruta HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\WindowsNT x86\Drivers y elimina las subcarpetas.

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  6. En el Editor del Registro, desplázate hasta la ruta HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers y elimina todas las subcarpetas.

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  7. Cierra el Editor del Registro.

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  8. Haz clic en Inicio
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    , despliega la flecha situada junto a Apagar y, a continuación, haz clic en Reiniciar.

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  9. para ir a Propiedades de Cola de impresión. A continuación, haz clic en Iniciar y en Aceptar.

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  10. Vuelve a instalar el controlador de la impresora desde el CD que se suministró con ésta o descárgalo de la página web del fabricante. El problema no se volverá a presentar.

Paso 3: Modificar el registro (video)

  
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uuid=9c36c4bc-feb3-4577-b4db-bca8649ee2aa VideoUrl=http://www.microsoft.com/es-es/showcase/details.aspx?uuid=9c36c4bc-feb3-4577-b4db-bca8649ee2aa  
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Id. de artículo: 2394829 - Última revisión: martes, 05 de febrero de 2013 - Versión: 3.6
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