Erro na fila de impressão quando desaparece o controlador de impressora

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Este é um artigo passo a passo.

Sintomas

O driver da impressora desaparece inesperadamente enquanto ela está sendo usada e ocorre um erro na fila de impressão.


Causa

A configuração padrão do driver de impressora foi modificado erroneamente e o arquivo do driver está danificado.

Resolução


Corrigir para mim

Para corrigir o problema automaticamente, clique no link Corrigir este problema. Em seguida, clique em Executar na caixa de diálogo Download de Arquivo e siga as etapas descritas neste assistente.


Corrigir este problema
Microsoft Fix it 50126


Observação A solução Corrigir pode ser executada no modo Light ou Completo.

O modo Light faz alterações no spooler de modo que você não precise fazer alterações adicionais. O modo Completo restaurará as definições padrão do spooler de impressão e requer que você reinstale suas impressoras.

Observação Este assistente pode estar apenas em inglês, mas a correção automática também funciona para versões do Windows em outros idiomas.

Observação Se o computador que você está usando não apresentar o problema, salve a solução Corrigir em uma unidade flash ou em um CD para depois executar no computador com esse problema.

Etapa 1: Parar o serviço do Spooler de impressão e excluir os elementos na pasta Spool (vídeo)

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assets video1
uuid=3470c213-3a0a-4ccd-97fc-88953a02fb3c VideoUrl=http://www.microsoft.com/pt-br/showcase/details.aspx?uuid=3470c213-3a0a-4ccd-97fc-88953a02fb3c
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Etapa 1: Parar o serviço do Spooler de impressão e excluir os elementos na pasta Spool (texto)

  1. Clique em Iniciar
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    e, a seguir, em Painel de Controle.

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  2. No Painel de Controle, clique em Sistema e segurança.

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  3. Em Sistema e segurança, clique em Ferramentas administrativas.

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  4. Em Ferramentas administrativas, faça um clique duplo em Serviços.

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  5. Em Serviços, faça clique duplo em Spooler de impressão.

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  6. Na janela Propriedades de Spooler de impressão, clique em Parar e, a seguir, em OK.

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    2487895

  7. Abra o Windows Explorer e escreva o caminho C:\Windows\System32\spool\PRINTERS.

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  8. Agora exclua todos os arquivos existentes em PRINTERS, incluídas pastas e subpastas.

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  9. No Windows Explorer, escreva o caminho:

    Windows 32 bits - C:\Windows\System32\spool\drivers\w32x86
    Windows 64 bits - C:\Windows\System32\spool\drivers\x64


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  12. Em C:\Windows\System32\spool\drivers\w32x86 (ou x64), exclua todos os arquivos existentes.

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  13. Instale novamente o driver de impressora com o CD que foi fornecido com ela ou baixe-o do site do fabricante para determinar se o erro continua. Se continuar, passe para a seguinte etapa.

Etapa 2: Fazer backup do Registro (vídeo)

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assets video1
uuid=fd4cb257-0b2d-455f-a495-54138569756f VideoUrl=http://www.microsoft.com/pt-br/showcase/details.aspx?uuid=fd4cb257-0b2d-455f-a495-54138569756f
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Etapa 2: Fazer backup do Registro (texto)

Observação: esta etapa mostra como fazer backup do Registro porque na etapa 3 são modificados alguns dos seus valores, o que pode produzir um erro grave se for feito de maneira errada. Desta forma, pode-se voltar a um estado prévio ao erro.

  1. Clique em Iniciar
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    e, na caixa de pesquisa, escreva regedit. A seguir, pressione Enter.

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    Observação:
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    2484583
    caso uma senha de administrador ou uma confirmação seja solicitada, digite a senha ou forneça uma confirmação conforme necessário.
  2. No Editor de Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print. A seguir, selecione a pasta Print, clique em Arquivo e escolha Exportar?

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  3. Agora, especifique um caminho para o backup, escreva um nome, por exemplo, Print, e clique em Salvar.

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Etapa 3: Modificar o registro (vídeo)

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uuid=c9602391-eaa7-4776-b310-8193c03cf683 VideoUrl=http://www.microsoft.com/pt-br/showcase/details.aspx?uuid=c9602391-eaa7-4776-b310-8193c03cf683
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Etapa 3: Modificar o registro (texto)

Importante: esta seção contém etapas que indicam como modificar o Registro. Porém, podem surgir graves problemas se o Registro for modificado incorretamente. Portanto, assegure-se de seguir estas etapas cuidadosamente. Para maior proteção, faça backup do Registro antes de modificá-lo. Se desejar obter mais informações, consulte a etapa anterior ou o artigo Backup do Registro.
  1. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Local Port e clique duas vezes em Driver.

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  2. Em Dados do valor da janela Editar cadeia de caracteres, você vai encontrar o texto localspl.dll , caso contrário, digite localspl.dll e clique em OK.

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  3. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Provider e exclua todas as subpastas.

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  4. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors e exclua todas as subpastas.

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  5. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\WindowsNT x86\Drivers e exclua todas as subpastas.

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    2487907

  6. No Editor do Registro, vá até o caminho HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers e exclua todas as subpastas.

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  7. Feche o Editor do Registro.

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  8. Clique em Iniciar
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    , abra a seta localizada junto a Desligar e, a seguir, clique em Reiniciar.

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  9. para ir a Propriedades de Spooler de impressão. A seguir, clique em Iniciar e em OK.

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  10. Instale novamente o driver de impressora com o CD que foi fornecido com ela ou baixe-o do site do fabricante. O problema estará solucionado.
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ID do artigo: 2394829 - Última revisão: terça-feira, 5 de fevereiro de 2013 - Revisão: 2.8
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