Проблемы с согласованием времени и составлением расписания после перехода на летнее время или смены часового пояса

Переводы статьи Переводы статьи
Код статьи: 2400550
Развернуть все | Свернуть все

Автоматическое определение и устранение проблемы

Это средство: "Устранение проблем с часовыми поясами Windows и переходом на летнее время" может автоматически устранить проблему, описанную в данной статье.

Это средство устраняет несколько разных проблем. Learn more



Примечание. Чтобы решить эту проблему самостоятельно, перейдите к разделу Самостоятельное решение проблемы.
Помогли ли вам эти сведения? Отправьте нам свой отзыв

Проблема

Даты перехода на летнее и зимнее время во многих странах меняются от года к году. Кроме того, некоторые страны могут изменить правила перехода на летнее время или смещение местного времени относительно времени в формате UTC. В этом случае в некоторых расписаниях и приложениях, зависящих от расчетов даты и времени, могут возникнуть проблемы.

Причина

Неполадки возникают из-за неверных или отсутствующих данных о часовом поясе.

Самостоятельное решение проблемы

Внимание! В данный раздел, описание метода или задачи включены сведения об изменении параметров реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем. Поэтому при выполнении этих действий рекомендуется строго соблюдать инструкции. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. В этом случае при возникновении неполадок реестр можно будет восстановить. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
322756 Создание резервной копии, редактирование и восстановление реестра Windows XP и Windows Server 2003


Чтобы устранить эту проблему, выполните указанные ниже действия.
  1. Импортируйте соответствующие данные о часовых поясах и годовые правила в следующий подраздел реестра:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones
    Примечание. Если данный параметр реестра не существует, импортируйте английские строки для строки "Non-MUI_*" в указанный ниже подраздел реестра (например, разделы реестра "Display", "Dlt", "Std").
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones
  2. Выполните команду, соответствующую версии используемой операционной системы.

    Windows XP и Windows Server 2003
    Tzchange.exe /w 2147483648
    Windows Vista, Windows 7, Windows Server 2008 и Windows Server 2008 R2
    %Windows%\servicing\GC32\tzupd.exe
Помогли ли вам эти сведения? Отправьте нам свой отзыв

Устранение проблемы с помощью пакета MATS

Щелкните здесь, чтобы узнать об устранении этой проблемы с помощью пакета MATS

Свойства

Код статьи: 2400550 - Последний отзыв: 23 февраля 2012 г. - Revision: 4.0
Ключевые слова: 
kbtshoot kbprb kbexpertisebeginner kbexpertiseinter kbsurveynew kbmatsfixme KB2400550

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com