Windows NT 4.0 SP4 Tandqic.sys で生成された NTBackup セットを復元する方法

文書翻訳 文書翻訳
文書番号: 240087 - 対象製品
この記事は、以前は次の ID で公開されていました: JP240087
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
重要 : この資料には、レジストリの編集に関する情報が含まれています。レジストリを編集する前に、問題が発生した場合に備えて、レジストリの復元方法を理解しておいてください。復元方法の詳細については、Regedit.exe のヘルプ トピック「レジストリを復元する」、またはRegedt32.exe のヘルプ トピック「レジストリ キーを復元する」を参照してください。
すべて展開する | すべて折りたたむ

目次

現象

Windows NT Service Pack 4 (SP4) で提供された Tandqic.sys と共に NTBackup プログラムを実行し、Tandberg SLR5 テープ ドライブを使用してテープ バックアップからデータを復元しようとすると、データの復元に失敗してしまう場合があります。このとき、バックアップ カタログを取得できなかったり、個々のファイルを復元できなかったりします。SLR5 ドライブのテープにデータをバックアップすることはできますが、実際にはデータが復元されていないのに、復元操作の成功を示すメッセージが表示される場合もあります。

原因

NTBackup プログラムが使用するレジストリのうち、ある値については、デフォルト値 ("1") の代わりに 0 を設定する必要があります。また、バックアップ ファイル (SP4 Tandqic.sys ドライバで作成されたもの) を復元するには、一部のレジストリ フラグを変更する必要があります。これらが原因となって、上記の現象が発生します。

解決方法

Windows NT 4.0

この問題を解決するためのモジュールは、Windows NT 4.0 日本語版サービスパック 6a 以降に含まれております。Windows NT 4.0 日本語版の最新サービスパックについては、以下 Web サイトから入手できます。
http://www.microsoft.com/japan/ntserver/nts/downloads/recommended/SP6/allSP6.asp
警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要です。Microsoft は、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

レジストリの編集方法の詳細については、レジストリ エディタ (Regedit.exe) のヘルプ トピック「キーと値の変更」、または Regedt32.exe のヘルプ トピック「レジストリ情報の追加と削除」と「レジストリ情報の編集」を参照してください。レジストリを編集する前にレジストリのバックアップを必ず作成してください。Windows NT または Windows 2000 を実行している場合、システム修復ディスク (ERD) も更新する必要があります。

この問題を解決するには、Windows NT 4.0 Service Pack 6 の \Support\Utils\i386 フォルダに含まれる Regset.exe ユーティリティを使用して、適切なレジストリ エントリを自動調整します。これにより、Windows NT 4.0 Service Pack 4 を実行中のコンピュータで作成されたテープ バックアップから、データを復元できるようになります。

Tandqic.sys ドライバを使用する場合、NTBackup プログラムを制御するレジストリ設定を手動で変更することもできます。これを実行するには、次の手順に従います。
  1. レジストリ エディタ (Regedt32.exe) を起動します。
  2. 次のレジストリ キーから "Use fast file restore" 値を見つけます。
    HKEY_LOCAL_CURRENT_USER\Software\Microsoft\Ntbackup\Backup Engine
  3. [編集] メニューの [文字列] をクリックし、0 と入力して、[OK] をクリックします。
  4. 次のレジストリ キーから "Use Tape Catalogs" 値を見つけます。
    HKEY_LOCAL_CURRENT_USER\Software\Microsoft\Ntbackup\User Interface
  5. [編集] メニューの [文字列] をクリックし、0 と入力して、[OK] をクリックします。
  6. レジストリ エディタを終了します。

Windows NT 4.0, Terminal Server Edition

この問題を解決するためのモジュールは、Windows NT 4.0 Terminal Server Edition 日本語版サービスパック 6 以降に含まれております。Windows NT 4.0 Terminal Server Edition 日本語版の最新サービスパックについては、以下 Web サイトから入手できます。
http://www.microsoft.com/japan/products/ntupdate/tsesp6/

状況

弊社では、これが Windows NT Server 4.0、Terminal Server Edition にかかわる問題であることを確認済みです。

この問題は Windows NT Server 4.0 Service Pack 6 および Windows NT Server 4.0、Terminal Server Edition Service Pack 6 で解決済みです。

詳細

Tandberg テープ ドライブおよび Ntbackup.exe プログラムとの互換性について詳しくは、次の Web サイトを参照してください。
http://www.tandberg.com

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 240087 (最終更新日 2000-05-02) を基に作成したものです。

プロパティ

文書番号: 240087 - 最終更新日: 2014年2月1日 - リビジョン: 2.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows NT Server 4.0 Terminal Server
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT 4.0 Service Pack 4
キーワード:?
kbnosurvey kbarchive kbbug kbfix kbtool kbenv kbhw ntsp kbbug4.00 kbfix4.00 KB240087
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com