Article ID: 240302 - Last Review: June 11, 2002 - Revision: 1.0 PRB: MSDN Library Setup Fails on Terminal Server in Execute ModeThis article was previously published under Q240302 SYMPTOMS
When you run the Microsoft Developer Network (MSDN) Library setup on Windows NT 4.0 Terminal Server Edition or Windows 2000 with Terminal Services installed, the following error may appear at the end of setup:
MSDN Setup Error : CloseCollection g_ccolCollection.Save() dwError = 1
Cannot open the file: %MSDN Library path%\msdn*.col
CAUSE
The MSDN Library was installed in Terminal Server's Execute mode.
RESOLUTION
Manually clean the failed installation off of the computer. See the MORE INFORMAITON section for details on how to manually clean the failed installation off of your computer. The Terminal Server requires that you install applications in Install mode. This can be done by using the Add/Remove Programs application in the Control Panel. The Add/Remove Programs application can find and start Setup.Exe off of the MSDN Library Disc 1. There are many other considerations when installing the MSDN Library on Terminal Server. For additional information, please click the article number below to view the article in the Microsoft Knowledge Base: 240301
(http://support.microsoft.com/kb/240301/EN-US/
)
HOWTO: Use the MSDN Library successfully with Terminal Server
MORE INFORMATIONIMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
When the MSDN Library is installed on Terminal Server in Execute mode, no information is written to HHCOLREG.DAT. However, files and registry keys have been added to the computer and must be removed before correctly installing the MSDN Library. This section describes how to remove these files without effecting the other HTML Help collections on the computer. A quicker and easier process is to remove all HTML Help collections off of the computer. If you are willing to reinstall all HTML Help collections on the computer, see the following Microsoft Knowledge Base article. For additional information, please click the article number below to view the article in the Microsoft Knowledge Base: 240350
(http://support.microsoft.com/kb/240350/EN-US/
)
HOWTO: Manually Uninstall the MSDN Library
To only remove the failed installation on Terminal Server, follow these steps.NOTE: First, remove all of the files that the failed MSDN Library installation placed on system.
If other versions of the MSDN Library are listed under this key, more steps are needed to restore the computer. When the MSDN Library is accessed from other applications, the registry is examined to determine which MSDN Library to display. That MSDN Library is called the preferred collection. The following steps reset the preferred collection to one of the remaining MSDN Libraries on the system:
REFERENCES
For additional information, please click the article number(s) below
to view the article(s) in the Microsoft Knowledge Base:
195878
(http://support.microsoft.com/kb/195878/EN-US/
)
PRB: MSDN Help Cannot Find msdn*.col File on Terminal Server
216109
(http://support.microsoft.com/kb/216109/EN-US/
)
HOWTO: Troubleshoot MSDN Library Run-Time/Install/Uninstall Problems
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