All Installed Programs May Not Be Displayed in the Add/Remove Programs Tool

Article translations Article translations
Article ID: 240348 - View products that this article applies to.
This article was previously published under Q240348
Expand all | Collapse all

SYMPTOMS

You may notice that all of the programs that are installed on your computer may not be displayed in the Add/Remove Programs tool.

CAUSE

This behavior occurs if a program's DisplayName or uninstall key name is longer than 63 characters.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To resolve this issue:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
  3. Click the folder of the program that has more than 63 characters in the title, right-click DisplayName, and then click Modify.
  4. In the Value data box, type a name with less than 63 characters, and then click OK.
  5. If the program's uninstall key name is longer than 63 characters, shorten it also. For example, the following key name is too long:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\
    1234567890123456789012345678901234567890123456789012345678901234
  6. Quit Registry Editor.

Properties

Article ID: 240348 - Last Review: January 25, 2007 - Revision: 2.4
APPLIES TO
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows 98 Second Edition
Keywords: 
kbenv kbprb KB240348

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com