Message d’erreur : une erreur d’application s’est produite et un journal des erreurs d’application est généré

Cet article fournit de l’aide pour résoudre un problème qui se produit lorsque vous vous connectez à un ordinateur exécutant Terminal Server Edition.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 240992

Importante

Cet article contient des informations sur la modification du Registre. Avant d’effectuer cette opération, veillez à sauvegarder le Registre et à bien comprendre comment le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft : 256986 Description du Registre Microsoft Windows

Symptômes

Lorsque vous vous connectez à un ordinateur exécutant Terminal Server Edition, le message d’erreur suivant peut s’afficher :

Une erreur d’application s’est produite et un journal des erreurs d’application est généré. Userinit.exe
Exception : violation d’accès (0xc0000005), adresse : 0x77f901b3

Remarque

La valeur de l’adresse peut être différente en fonction de la configuration de votre ordinateur.

Le client Terminal Server est déconnecté après avoir cliqué sur OK ou Sur Annuler.

Cause

Ce comportement se produit car une valeur non valide existe dans le Registre.

Résolution

Pour résoudre ce problème, obtenez le dernier Service Pack pour Windows NT Server 4.0, Édition Terminal Server.

Solution de contournement

Avertissement

Toute mauvaise utilisation de l’Éditeur du Registre risque de générer de graves problèmes, pouvant vous obliger à réinstaller votre système d’exploitation. Microsoft ne peut garantir que les problèmes résultant d’une mauvaise utilisation de l’Éditeur du Registre puissent être résolus. Vous assumez l’ensemble des risques liés à l’utilisation de cet outil.

Pour contourner ce problème, supprimez la valeur de Registre non valide :

  1. Démarrez la Rédacteur du Registre (Regedt32.exe).
  2. Recherchez la clé de Registre suivante : HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\IniFile Times
  3. Recherchez la valeur non valide (il s’agit généralement d’une valeur sans nom).
  4. Cliquez sur la valeur non valide.
  5. Dans le menu Modifier , cliquez sur Supprimer, puis sur Oui.
  6. Quittez l’Éditeur du Registre.

Statut

Microsoft a confirmé qu’il s’agit d’un problème dans les produits Microsoft répertoriés au début de cet article. Ce problème a été corrigé pour la première fois dans Windows NT 4.0 Server, Terminal Server Edition, Service Pack 5.