XADM : mémoire insuffisante lors de l'application CDO/MAPI accèdent à un message sur Exchange Server

Traductions disponibles Traductions disponibles
Numéro d'article: 241278 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Symptômes

Une application de MAPI (Messaging Application Programming Interface) ou CDO (Collaboration Data Objects) peut renvoyer une erreur de MAPI_E_NOT_ENOUGH_MEMORY (qui est défini comme E_OUTOFMEMORY = 0x8007000E) lorsque vous tentez d'effectuer des opérations MAPI ou CDO par rapport à un message particulier.

L'utilisateur peut voir un message d'erreur semblable au suivant :
Il ne pas assez de mémoire disponible pour effectuer l'opération. [Server banque d'informations Microsoft Exchange - [E_OUTOFMEMORY(8007000E)]]

Cause

La banque d'informations Microsoft Exchange Server peut renvoyer une réponse d'appel (RPC) de procédure distante au client RPC demande indiquant que la taille de tampon requise pour les données RPC est supérieure à la taille maximale autorisée de la mémoire tampon (32 Ko). Le client gère cette demande pour configurer une taille de tampon « interdit comme une erreur de mémoire.

Résolution

Pour résoudre ce problème, procurez-vous le dernier service pack pour Exchange Server 5.5. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
191014 XGEN : Comment faire pour obtenir le dernier Service Pack Exchange Server 5.5
Les fichiers suivants sont disponibles au téléchargement à partir du Centre de téléchargement Microsoft :
x 86 :
Réduire cette imageAgrandir cette image
Download
Download Q248838engi.exe now
Alpha :
Réduire cette imageAgrandir cette image
Download
Download Q248838enga.exe now
Pour plus d'informations sur la façon de télécharger des fichiers de support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
119591 Comment obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a analysé ce fichier de virus. Microsoft utilisé les logiciels de détection de virus plus récente ne sont associé à la date à laquelle le fichier a été validé. Le fichier est stocké sur des serveurs sécurisés, pour empêcher toute modification non autorisée dans le fichier.

Statut

Microsoft a confirmé que c'est un problème dans Microsoft Exchange Server version 5.5. Ce problème a été corrigé dans Exchange Server 5.5 Service Pack 4.

Plus d'informations

Dans certaines conditions limite, la banque d'informations Microsoft Exchange Server peut renvoyer une réponse RPC à la demande du client RPC, qui informe le client le tampon du client a été configuré pour la demande est de taille insuffisante. La réponse du serveur RPC indique cela avec la chaîne « ropBufferTooSmall »; il indique également la taille la mémoire tampon doit être. Ce, en soi, n'est un problème pour que le client, que le client définit un tampon de taille appropriée pour la réponse et fait la demande à nouveau généralement pas. Cela réussit généralement.

Ce problème se produit lorsque la banque d'informations ne parvient pas à compte correctement des tampons tous les frais généraux lorsqu'il calcule la taille du tampon réel qui est requise. Par conséquent, la banque d'informations indique dans la réponse que la mémoire tampon requis est plus grand que la valeur maximale RPC tampon taille autorisée. Lorsque c'est le cas, les applications MAPI ou CDO peuvent signaler type "Mémoire insuffisante" d'erreurs.

Propriétés

Numéro d'article: 241278 - Dernière mise à jour: lundi 10 février 2014 - Version: 4.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 5.5 Standard Edition
Mots-clés : 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbbug kbexchange550presp4fix kbexchange550sp4fix kbfix kbgraphxlinkcritical kbqfe KB241278 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 241278
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com