Feilmelding: Siden kan ikke vises.

Artikkeloversettelser Artikkeloversettelser
Artikkel-ID: 241344 - Vis produkter som denne artikkelen gjelder for.
Denne artikkelen ble tidligere utgitt under NO241344
Viktig!  Denne artikkelen inneholder informasjon om hvordan du endrer registret. Før du endrer registret, må du sikkerhetskopiere det og være sikker på at du forstår hvordan du gjenoppretter registret hvis det oppstår et problem. Hvis du vil ha informasjon om hvordan du sikkerhetskopierer, gjenoppretter og redigerer registret, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
256986 Beskrivelse av Microsoft Windows-registret
Vis alt | Skjul alt

På denne siden

Symptom

Internet Explorer 5 og nyere

Når du prøver å vise en webside, kan det hende du får følgende feilmelding:
Siden kan ikke vises.
Når du er koblet til via AOL 4.0, kan du få følgende feilmelding mens du starter Microsoft Internet Explorer 5.5:
iexplore forårsaket en ugyldig sidefeil i modul <ukjent>

Internet Explorer 4.x

Når du prøver å vise en webside, kan det hende du får følgende feilmelding:
Det oppstod en intern feil i Internett-tillegget i Windows.
Hvis du bruker AOL, kan det hende du får følgende feilmelding:
WAOL forårsaket en ugyldig sidefeil i modul <ukjent>
Obs!  Hvis du får en av disse feilmeldingene etter å ha oppgradert til Microsoft Windows Millennium Edition, kan du lese følgende artikkel i Microsoft Knowledge Base:
274498 Feilmeldingen "Siden kan ikke vises" etter oppgradering til Windows Me


Du finner mer informasjon om hvordan du feilsøker feilmeldingen "Siden kan ikke vises" på en datamaskin som kjører Windows XP, ved å klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
326155 Feilmelding når du prøver å åpne et webområde i Internet Explorer: "Siden kan ikke vises" (denne artikkelen kan være på engelsk)

Årsak

Dette problemet kan oppstå hvis en eller flere av følgende betingelser er oppfylt:
  • Tilkoblingsinnstillingene til Internet Explorer er feil.
  • Det er feil i en Hosts-fil.
  • Winsock.dll, Wsock32.dll eller Wsock.vxd mangler eller er ødelagt.
  • Det er flere kopier av Winsock.dll, Wsock32.dll eller Wsock.vxd, eller en av disse filene ligger i feil mappe.
  • TCP/IP er ikke installert eller fungerer ikke på riktig måte.
  • Registernøkkelen for WinSock2 er ødelagt.
  • Installasjonen av Deling av Internett-tilkobling er skadet eller fungerer ikke.
  • Filen Rnr20.dll mangler eller er ødelagt, eller "Library Path"-verdien i følgende registernøkkel kan mangle eller inneholde feil bane:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2\ Parameters\NameSpace_Catalog5\Catalog_Entries\000000000001
  • Hvis du bruker America Online (AOL) eller CompuServe, kan det være lagt inn sperrefunksjonsbegrensninger i kontoen.
  • Feil konfigurert eller ikke-fungerende brannmur- eller proxy-programvare.
Obs!  Når du forsøker å vise websider i Internet Explorer etter at du har installert MSN (Microsoft Network) 5.1, kan det oppstå lignende symptomer.

Dette problemet kan oppstå hvis Internet Explorer er konfigurert til å bruke en proxy-server uten at det er definert noen.

Løsning

Advarsel!  Hvis du bruker Registerredigering på feil måte, kan dette skape alvorlige problemer som gjør at du må installere operativsystemet på nytt. Microsoft kan ikke garantere at du kan løse problemer som er et resultat av feil bruk av Registerredigering. Bruk av Registerredigering skjer på eget ansvar.

Hvis du vil løse dette problemet, kan du konfigurere Internet Explorer til automatisk å finne innstillingene. Gjør dette ved å bruke følgende fremgangsmåte:

Obs!  Hvis du får feilmeldingen etter at du har installert Deling av Internett-tilkobling med AOL som Internett-leverandør, kan du lese delen Du får feilmelding etter å ha installert Deling av Internett-tilkobling med AOL i denne artikkelen.
  1. Slett midlertidige Internett-filer og informasjonskapsler. Dette gjøres på følgende måte:
    1. Klikk Start, pek på Innstillinger, og klikk deretter Kontrollpanel.
    2. Dobbeltklikk Alternativer for Internett.
    3. Under Midlertidige Internett-filer klikker du Innstillinger.
    4. Klikk Vis filer.
    5. Trykk Ctrl+A for å velge alle filene.
    6. Trykk DEL, eller klikk Slett øverst i vinduet.
    7. Klikk Ja i dialogboksen som vises.
    8. Lukk vinduet når alle filene er borte.
    9. Klikk OK to ganger.
    10. Lukk Kontrollpanel.
    Obs!  Før du går til trinn 2, må du fjerne eventuell programvare for brannmur, Internett-sikkerhet eller proxy.
  2. Kontroller at du kan koble til Internett-leverandøren og at tilkoblingsinnstillingene for Internet Explorer er riktige. Bruk en av følgende metoder for å gjøre dette:
    • Kontroller at avmerkingsboksen Bruk Proxy-server er tom hvis du ikke bruker proxy-server. Brukere av lokalnett, DSL eller kabelmodem starter Internet Explorer, klikker Alternativer for InternettVerktøy-menyen (eller Vis-menyen), velger kategorien Tilkoblinger og klikker deretter LAN-innstillinger for å vise denne avmerkingsboksen. Hvis du bruker et modem for ekstern tilkobling, kan du klikke den eksterne tilkoblingen i kategorien Tilkoblinger, og deretter klikker du Innstillinger.
    • Prøv et annet, lokalt nummer til Internett-leverandøren.
  3. Hvis du ikke kan koble til, kan du fjerne og installere Ekstern pålogging på nytt. Gjør dette ved å bruke følgende fremgangsmåte:

    Obs! 
    • Hvis datamaskinen kjører Microsoft Windows 95, fastslår du om Ekstern pålogging 1.2 eller 1.3 er installert. Dette finner du ut ved å se under Legg til / fjern programmer. Ekstern pålogging 1.2 eller 1.3 skal vises i kategorien Installer/avinstaller. Hvis en av disse er oppført, fjerner du den før du følger denne fremgangsmåten.
    • Du trenger CD-ROMen for Windows for å bruke denne fremgangsmåten.
    • Fjern AOL før du følger denne fremgangsmåten. Kontakt AOL for å få informasjon om hvordan du sikkerhetskopierer eventuelle personlige data før du fjerner tjenesten.
    • Det kan hende du kan løse dette problemet ved å installere oppgraderinger for Ekstern pålogging på nytt.
    • Følg denne fremgangsmåten hvis du får en feilmelding som ligner på en av følgende feilmeldinger:
      Det oppstod en intern feil med Windows Internett-tillegg.
      Kan ikke opprette en tilkobling for nettverkssocket.
      Kan ikke initialisere grensesnitt for Windows-socketer.
    Følg denne fremgangsmåten for å fjerne og installere Ekstern pålogging på nytt:
    1. Klikk Start, velg Innstillinger, klikk Kontrollpanel og dobbeltklikk deretter Legg til / fjern programmer.
    2. I kategorien Installere Windows klikker du Kommunikasjon og deretter Detaljer.
    3. Fjern merket for Ekstern pålogging, og klikk deretter Ja hvis du får spørsmål om Ekstern pålogging er nødvendig for andre komponenter.
    4. Klikk OK til du blir bedt om å starte datamaskinen på nytt. Hvis du ikke blir bedt om å starte datamaskinen på nytt, skan du starte den på nytt manuelt.
    5. Når Windows starter på nytt, gjentar du trinn a til d, men denne gangen merker du av for Ekstern pålogging i trinn c.
  4. Klikk Start, pek på Programmer, og klikk deretter MS-DOS-ledetekst.
  5. Skriv inn ping 127.0.0.1 ved ledeteksten, og trykk deretter Enter. Hvis du får fire svar, går du til trinn 6. Får du ikke fire svar, fjerner du og installerer og konfigurerer TCP/IP på nytt.

    Obs!  AOL må fjernes før du følger denne framgangsmåten. Kontakt AOL for å få informasjon om hvordan du sikkerhetskopierer eventuelle personlige data før du fjerner tjenesten.

    Følg denne fremgangsmåten for å fjerne TCP/IP:
    1. Klikk Start, velg Innstillinger, klikk Kontrollpanel, og dobbeltklikk deretter Nettverk.
    2. Klikk en komponent i kategorien Konfigurasjon, klikk Egenskaper og noter deretter alle komponentinnstillingene. Gjenta dette trinnet til du har notert konfigurasjonsinformasjonen for alle komponentene.
    3. Fjern alle nettverkskomponenter som er relatert til TCP/IP, fra Nettverksegenskaper. Når du skal gjøre dette, klikker du en komponent i kategorien Konfigurasjon og klikker Fjern. Gjenta dette trinnet til alle nettverkskomponenter som er relatert til TCP/IP, er slettet fra Nettverksegenskaper. Klikk OK, og klikk deretter Ja når du blir bedt om å starte datamaskinen på nytt. Start datamaskinen på nytt manuelt hvis du ikke blir bedt om det.
    Følg denne fremgangsmåten for å installere og konfigurere TCP/IP på nytt:
    1. Klikk Start, velg Innstillinger, klikk Kontrollpanel, og dobbeltklikk deretter Nettverk.
    2. I kategorien Konfigurasjon klikker du Legg til, Protokoll, og deretter Legg til.
    3. I Produsenter-boksen klikker du Microsoft i Nettverksprotokoller-boksen, og deretter klikker du TCP/IP.
    4. Klikk OK to ganger, og klikk deretter Ja når du blir bedt om å starte datamaskinen på nytt. Start datamaskinen på nytt manuelt hvis du ikke blir bedt om det.

      Obs!  Det kan hende du får feilmeldinger om versjonskonflikt. Hvis du får en slik feilmelding, kan du klikke Nei når du blir spurt om du vil beholde en nyere versjon av hver fil.
    5. Gjenta trinn 5.
  6. Koble deg til Internett-leverandøren, og start deretter Internet Explorer. Forsøk å gå til www.microsoft.com enten ved å skrive inn domenenavnet eller ved hjelp av IP-adressen. Hvis du kan koble deg opp ved hjelp av IP-adressen, men ikke med fullstendig domenenavn, kan du kontrollere innholdet av Hosts-filen på datamaskinen. Dette gjøres på følgende måte:
    1. Klikk Start, pek på Søk, og klikk deretter Etter filer eller mapper.
    2. I Navn-boksen skriver du hosts, og deretter klikker du harddisken i Søk i-boksen.
    3. Hvis du finner Host-filen, åpner du den i Notisblokk for å vise innholdet. Hvis det ikke er flere oppføringer enn oppføringen for den lokale verten (for eksempel 127.0.0.1 Localhost), må du kontakte Internett-leverandøren for å høre om det er problemer med deres DNS-server.
  7. Hvis ikke et webområde lastes inn når du oppgir enten det fullstendige domenenavnet eller IP-adressen, klikker du Start, peker på Programmer, klikker MS-DOS ledetekst og forsøker å pinge et webområde du vet fungerer, ved å bruke både fullstendig domenenavn og IP-adresse.

    Obs!  På mange større webområder er denne funksjonen deaktivert. Du kan derfor ikke pinge disse områdene.

    Hvis du kan pinge området ved å bruke IP-adressen, men du fremdeles får følgende feilmelding, går du til trinn 8:
    Siden kan ikke vises
    Hvis du ikke kan pinge området ved å bruke et fullstendig domenenavn eller IP-adressen, kontrollerer du at du fremdeles kan pinge den lokale verten (127.0.0.1), og deretter kontrollerer du at Library Path-verdien i følgende registernøkkel peker til den riktige plasseringen for Rnr20.dll-filen:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2\Parameters\NameSpace_Catalog5\Catalog_Entries\000000000001
  8. Se i Nettverksegenskaper etter flere forekomster av TCP/IP-protokollen som er bundet til kortet for ekstern pålogging.
  9. Se om det finnes flere Winsock-filer. Gi filer som ligger i feil mappe, nytt navn. Dette gjelder ikke filer i AOL-mapper, C:\Windows\Sysbckup eller C:\Windows\Ws2bakup. Følgende mapper er riktige for Winsock-filene:
    Winsock.dll i C:\Windows
    Wsock32.dll, Wsock.vxd, Wsock2.vxd, Ws2_32.dll i C:\Windows\System
    Datoene og versjonene for disse filene skal stemme med versjonen av Windows og systemdatoen for den versjonen, bortsett fra når Winsock2 eller DUN1.3 er lagt til Windows 95. Hvis du finner en C:\Windows\Ws2bakup-mappe, betyr det at Winsock2 er installert, og DUN 1.3 står på listen til verktøyet Legg til / fjern programmer i Kontrollpanel hvis den er installert.

    Slik endrer du navn på og erstatter Winsock-filer:
    1. Klikk Start, velg Søk, og klikk deretter Etter filer eller mapper.
    2. I Navn-boksen skriver du det riktige filnavnet (for eksempel wsock32.dll, winsock.dll eller wsock.vxd), klikker harddisken i Søk i-boksen, og deretter klikker du Søk nå.
    3. Hvis du vil endre navn på ekstrakopier av filene, høyreklikker du filen, klikker Gi nytt navn, og deretter endrer du filtypen til OLD. Du kan for eksempel endre navnet på Wsock32.dll til Wsock32.old.

      Obs!  Hvis du får en feilmelding om at det allerede finnes en fil med det aktuelle navnet, velger du en annen filtype (for eksempel ZZZ). Hvis du får en feilmelding om at du ikke kan endre navn på filen fordi den er i bruk, starter du datamaskinen på nytt i MS-DOS-modus, og deretter endrer du filnavnet i DOS.
    Hvis du vil ha mer informasjon om riktige datoer og størrelser for disse filene, kan du klikke artikkelnumrene nedenfor for å vise artiklene i Microsoft Knowledge Base:
    135539 Windows 95 CD-ROM-mappevisning (4 av 5) (denne artikkelen kan være på engelsk)
    150440 Windows 95 Service Pack 1 CD-ROM-mappevisning (4 av 5) (denne artikkelen kan være på engelsk)
    158193 Windows 95 OEM Service Release 2 CD-ROM-mappevisning (5 av 6) (denne artikkelen kan være på engelsk)
    188428 Windows 98 CD-ROM-mappevisning (1 av 14) (denne artikkelen kan være på engelsk)
    238664 Windows 98 Second Edition CD-ROM-mappevisning (1 av 14) (denne artikkelen kan være på engelsk)
  10. Hvis datamaskinen kjører Microsoft Windows 98 eller Windows Millennium Edition, går du til trinn 13. Hvis datamaskinen kjører Windows 95, ser du etter Ws2bakup.bat-filen på harddisken. Dette gjøres på følgende måte:
    1. Klikk Start, pek på Søk, og klikk deretter Etter filer eller mapper.
    2. I Navn-boksen skriver du ws2bakup.bat, klikker på harddisken i Søk i-boksen, og klikker deretter Søk nå.
    3. Hvis du finner filen, går du til trinn 11. Hvis ikke, går du til trinn 13.
  11. Når du har funnet Ws2bakup.bat-filen, følger du denne fremgangsmåten:
    1. Klikk Start, Kjør, og skriv deretter inn c:\windir\ws2bakup\ws2bakup.bat i Åpne-boksen, der windir er mappen der Windows er installert. Trykk deretter Enter.

      Obs!  Hvis du får en feilmelding om brudd på delingstillatelse, trykker du A for å avbryte kommandoen. Gjenta trinnet til den satvise filen har kjørt ferdig.
    2. Klikk Start og deretter Slå av.
    3. Klikk Starte på nytt i MS-DOS-modus, og klikk deretter OK.
    4. Skriv c:\windir\ws2bakup\ws2bakup.bat ved ledeteksten, og trykk Enter.

      Obs!  Hvis du får en feilmelding mens registret oppdateres, kan du ignorere den.
  12. Skriv inn exit for å starte Windows på nytt.
  13. Eksporter og slett WinSock2-registernøkler i følgende registernøkler.

    Obs!  Fjern AOL før du følger denne fremgangsmåten. Kontakt AOL for å få informasjon om hvordan du sikkerhetskopierer eventuelle personlige data før du fjerner tjenesten.
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\AFVXD


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\DHCP


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\MSTCP


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\Winsock


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\Winsock2


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess\Authentication\SMM_Files
  14. Fjern og installer TCP/IP på nytt for å bygge registernøklene på nytt før du tester tilkoblingen i det neste trinnet. Det kan hende du også må fjerne og installere DUN på nytt hvis du fjerner
    SMM_files
    -nøkkelen.

    Hvis du vil ha mer informasjon, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
    218822 Feilmelding: Rundll32 forårsaket en ugyldig sidefeil i modul Rnaui.dll (denne artikkelen kan være på engelsk)
    Advarsel!  Ikke utfør trinn 15 hvis du kjører Windows Millennium Edition.
  15. Hvis du fremdeles får feilmeldingen, må du kanskje fjerne TCP/IP og Ekstern pålogging manuelt.

    Hvis du vil ha mer informasjon om hvordan du fjerner og installerer filer for Ekstern pålogging og TCP/IP på nytt, kan du klikke artikkelnummeret nedenfor for å vise artikkelen i Microsoft Knowledge Base:
    181599 Slik fjerner og installerer du filer for Ekstern pålogging og TCP/IP på nytt (denne artikkelen kan være på engelsk)

Du får feilmeldingen etter at du har installert Deling av Internett-tilkobling med AOL

Hvis du får feilmeldingen etter at du har installert Deling av Internett-tilkobling med America Online (AOL), kontrollerer du at det ikke er lagt inn sperrefunksjonsbegrensninger i kontoen. Hvis du får en feilmelding etter å ha installert Deling av Internett-tilkobling og AOL er din Internett-leverandør, må du kontrollere at TCP/IP (delt) er bundet til AOL-kortet og ikke kortet for ekstern pålogging. Hvis både kortet for ekstern pålogging og AOL-kortet står oppført blant Andre maskiner når Deling av Internett-tilkobling blir installert, vil TCP/IP (delt) som standard bli bundet til kortet for ekstern pålogging. Du må avinstallere Deling av Internett-tilkobling og fjerne kortet for ekstern pålogging fra Andre maskiner, og deretter installere Deling av Internett-tilkobling på nytt og kontrollere at TCP/IP (delt) er bundet til AOL-kortet. Deretter kan du installere kortet for ekstern pålogging på nytt.

Mer informasjon

Hvis du vil ha mer informasjon om hvordan du finner ut hvilken mappe Windows er installert i, kan du klikke artikkelnummeret nedenfor for å vise artikkelen i Microsoft Knowledge Base:
305792 Slik fastslår du hvilken mappe Windows er installert i (denne artikkelen kan være på engelsk)
Hvis du vil ha mer informasjon om hvordan du feilsøker feilmeldinger i Internet Explorer, kan du gå til følgende Microsoft-webområde:
http://support.microsoft.com/default.aspx?pr=ie&ln=no

Referanser

Hvis du vil ha mer informasjon, kan du klikke følgende artikkelnumre for å vise artiklene i Microsoft Knowledge Base:
219843 Problemer med å bruke Internet Explorer med feil Hosts-fil (denne artikkelen kan være på engelsk)
175722 Kan ikke åpne Internett-området i Internet Explorer
175039 Feilmelding: Kan ikke opprette en tilkobling til serveren (denne artikkelen kan være på engelsk)
188952 Feilmeldingen "Det oppstod en intern feil" ved bruk av Internet Explorer (denne artikkelen kan være på engelsk)
222909 Feilmelding: Intern feil i Windows Internett-tillegg (denne artikkelen kan være på engelsk)
185533 TCP/IP fungerer ikke etter oppgradering til Windows 98 (denne artikkelen kan være på engelsk)
191064 Feilmeldinger når du kjører TCP/IP-baserte verktøy eller programmer (denne artikkelen kan være på engelsk)
238550 Kan ikke søke på Internett ved hjelp av Internet Explorer mens du er koblet til AOL (denne artikkelen kan være på engelsk)
158474 Windows TCP/IP-registeroppføringer (denne artikkelen kan være på engelsk)
181599 Slik fjerner og installerer du filer for Ekstern pålogging og TCP/IP på nytt (denne artikkelen kan være på engelsk)
234815 Beskrivelse av Deling av Internett-tilkobling (denne artikkelen kan være på engelsk)
238135 Feilsøke problemer med Deling av Internett-tilkobling

Egenskaper

Artikkel-ID: 241344 - Forrige gjennomgang: 13. juli 2006 - Gjennomgang: 8.0
Informasjonen i denne artikkelen gjelder:
  • Microsoft Internet Explorer 6.0 på følgende plattformer
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.5 på følgende plattformer
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.01 på følgende plattformer
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.0 på følgende plattformer
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 4.0 128-Bit Edition
Nøkkelord: 
kberrmsg kbwinme msiew98 msiew95 kbprb KB241344

Gi tilbakemelding

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com