Mensagem de erro: A página não pode ser exibida

Traduções deste artigo Traduções deste artigo
ID do artigo: 241344 - Exibir os produtos aos quais esse artigo se aplica.
Importante Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que saiba como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e modificar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
256986 Descrição do Registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Internet Explorer 5 e posteriores

Ao tentar abrir uma página da Web, você poderá receber a seguinte mensagem de erro:
A página não pode ser exibida.
Ao se conectar usando o AOL 4.0, durante a inicialização do Microsoft Internet Explorer 5.5, você pode receber a seguinte mensagem de erro:
O iexplore causou uma falha de página inválida em um módulo <desconhecido>

Internet Explorer 4.x

Quando você tenta abrir uma página da Web, você poderá receber a seguinte mensagem de erro:
Ocorreu um erro interno nas extensões de Internet para Windows.
Se estiver usando a AOL, você poderá receber a seguinte mensagem de erro:
O WAOL causou uma falha de página inválida em um módulo <desconhecido>
Observação Se você receber esta mensagem de erro após atualizar para o Microsoft Windows Millennium Edition (ME), consulte o seguinte artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
274498 Mensagem de erro "A página não pode ser exibida" depois de atualizar o Windows Millennium Edition (ME)


Para obter informações adicionais sobre como solucionar a mensagem de erro ?A página não pode ser exibida" em um computador executando o Windows XP, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
326155 Mensagem de erro "A página não pode ser exibida" ao tentar iniciar o Internet Explorer

Causa

Este problema pode ocorrer se uma ou mais das seguintes condições forem verdadeiras:
  • As configurações de conexão do Internet Explorer estão incorretas.
  • Existe uma entrada incorreta num arquivo de Hosts.
  • O arquivo Winsock.dll, Wsock32.dll ou Wsock.vxd está faltando ou está danificado.
  • Existem várias cópias do arquivo Winsock.dll, Wsock32.dll ou Wsock.vxd, ou um destes arquivos está na pasta errada.
  • TCP/IP não está instalado ou não está funcionando corretamente.
  • A chave de registro WinSock2 está danificada.
  • A instalação do Compartilhamento de conexão com a Internet está danificada ou não está funcionando.
  • O arquivo Rnr20.dll está faltando ou está danificado ou o valor do "Library Path" no seguinte registro está faltando ou contém a localização errada:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2\ Parameters\NameSpace_Catalog5\Catalog_Entries\000000000001
  • Se você estiver usando a America Online (AOL) ou CompuServe, pode haver restrições de controle do responsável aplicadas à conta.
  • Firewall ou software de proxy configurado incorretamente ou fora de funcionamento.
Observação Quando você tenta abrir páginas da Web no Internet Explorer após a instalação do MSN (Microsoft Network) 5.1, você pode notar sintomas similares.

Este problema pode ocorrer porque o Internet Explorer está configurado para usar um servidor proxy para pesquisar quando não houver nenhum especificado.

Resolução

Aviso O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

Para resolver este problema, configure o Internet Explorer para detectar automaticamente as configurações. Para fazer isto, execute as seguintes etapas:

Observação Se você receber a mensagem de erro após a instalação do Compartilhamento de Conexão com a Internet tendo a AOL como provedor de serviços de Internet (ISP), consulte a seção "Se você receber a mensagem de erro após a instalação do Compartilhamento de Conexão com a Internet e a AOL".
  1. Exclua os cookies e os arquivos temporários de Internet. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
    2. Clique duas vezes em Opções da Internet.
    3. Em Arquivos de Internet temporários, clique no botão Configurações.
    4. Clique no botão Exibir arquivos.
    5. Pressione CTRL+A para selecionar todos os arquivos.
    6. Pressione DEL ou clique na opção Excluir na parte superior da janela.
    7. Clique no botão Sim na caixa de diálogo que aparecer.
    8. Após ter retirado todos os arquivos, feche a janela.
    9. Clique em OK duas vezes.
    10. Feche o Painel de controle.
    Observação Antes da etapa 2, remova softwares de firewall, segurança de Internet ou proxy.
  2. Verifique se é possível se conectar ao provedor de serviços de Internet e se as configurações da conexão para o Internet Explorer estão corretas. Para fazer isto, use um dos seguintes métodos:
    • Verifique se a caixa de seleção Usar um servidor proxy está limpa se você não usar um servidor proxy. Para verificar esta caixa de seleção, inicie o Internet Explorer, clique em Opções da Internet na guia Ferramentas (ou no menu Exibir), clique na guia Conexões e clique em Configurações da LAN para usuários de modem a cabo, LAN e DSL. Se você usa um modem dial-up, clique na conexão dial-up na guia Conexões e no botão Configurações.
    • Tente usar um número de discagem gratuita para acessar o provedor de serviços de Internet.
  3. Se não conseguir, remova e reinstale a conexão de rede dial-up. Para fazer isto, execute as seguintes etapas:

    Observações
    • Se o computador estiver executando o Microsoft Windows 95, veja se a Conexão de rede dial-up 1.2 ou 1.3 está instalada. Para fazer isto, veja em Adicionar/Remover programas. Conexão de rede dial-up 1.2 ou 1.3 deve estar listada na guia Instalar/Desinstalar. Se alguma delas estiver listada, remova-a antes de executar as seguintes etapas.
    • Você precisa do CD-ROM do Windows para executar as etapas.
    • Remova AOL antes de executar as etapas. Entre em contato com a AOL para obter informações sobre como fazer backup de dados pessoais antes de remover o serviço.
    • Você pode resolver este problema reinstalando as atualizações da Conexão de rede dial-up.
    • Execute as etapas se você receber uma mensagem de erro similar a uma das seguintes:
      Ocorreu um erro interno nas extensões de Internet do Windows.
      Impossível criar uma conexão de soquete de rede.
      Não é possível inicializar a interface do Windows Sockets.
    Para remover e reinstalar a o sistema de rede dial-up, execute as seguintes etapas:
    1. Clique em Iniciar, aponte para Configurações, clique em Painel de controle e clique duas vezes em Adicionar ou remover programas.
    2. Na guia Instalação do Windows, clique em Comunicações e depois em Detalhes.
    3. Limpe a caixa de seleção Acesso à rede dial-up e clique em OK, se você receber uma mensagem informando que a Conexão de rede dial-up é usada por outros componentes.
    4. Clique em OK se você for solicitado a reiniciar o computador. Se for solicitado a reiniciar o computador, faça isto manualmente.
    5. Após o Windows reiniciar, repita as etapas de A a D, porém selecione a caixa de seleção Acesso à rede dial-up na etapa C.
  4. Clique em Iniciar, aponte para Programas e clique em Prompt do MS-DOS.
  5. Digite ping 127.0.0.1 no prompt e pressione ENTER. Se você receber quatro respostas, vá até a etapa 6. Se não receber quatro respostas, remova, reinstale e configure o TCP/IP:

    Observação O AOL deve ser removido antes de executar as seguintes etapas. Entre em contato com a AOL para obter informações sobre como fazer backup de dados pessoais antes de remover o serviço.

    Para remover o protocolo TCP/IP, execute as seguintes etapas:
    1. Clique em Iniciar, aponte para Configurações, clique em Painel de controle e clique duas vezes em Rede.
    2. Clique em um componente na guia Configuração, clique em Propriedades e depois anote as configurações do componente. Repita esta etapa até que você tenha registrado as informações de configuração de todos os componentes.
    3. Remova todos os componentes de rede relacionados a TCP/IP das propriedades de rede. Para fazer isto, clique em um componente na guia Configuração e clique em Remover. Repita esta etapa até os componentes de rede relacionados a TCP/IP serem excluídos das propriedades de rede, clique em OK e em Sim quando você for solicitado a reiniciar o computador. Se você não for solicitado a reiniciar o computador, faça isto manualmente.
    Para reinstalar e configurar o protocolo TCP/IP, execute as seguintes etapas:
    1. Clique em Iniciar, aponte para Configurações, clique em Painel de controle e clique duas vezes em Rede.
    2. Na guia Configuração, clique em Adicionar, clique em Protocolo e depois em Adicionar.
    3. Na caixa Fabricantes, clique em Microsoft, na caixa Protocolos de rede e clique em TCP/IP.
    4. Clique em OK duas vezes e clique em Sim ao ser solicitado a reiniciar o computador. Se lhe for solicitado reiniciar o computador, faça isso manualmente.

      Observação Você pode receber mensagens de erro "conflito de versões". Se você receber esta mensagem de erro, clique em Não quando for solicitado a manter a versão mais recente de cada arquivo.
    5. Repita a etapa 5.
  6. Conecte-se ao seu provedor de serviços de Internet e inicie o Internet Explorer. Tente acessar www.microsoft.com usando o nome e o endereço do protocolo TCP/IP. Se não for possível se conectar usando o endereço IP mas não o nome de domínio totalmente qualificado (FQDN), verifique se há entradas no arquivo de Hosts no computador local. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar, aponte para Localizar e clique em Arquivos ou pastas.
    2. Na caixa Nome, digite hosts, e clique no seu disco rígido na caixa Examinar.
    3. Se você encontrar o arquivo de Host, abra este arquivo no Bloco de notas para visualizar o conteúdo. Se não houver nenhuma entrada além daquela para o host local (por exemplo, 127.0.0.1 Localhost), entre em contato com o seu provedor de serviços de Internet (ISP) para verificar se há algum problema no servidor DNS.
  7. Se um site da Web não carregar ao usar ou o FQDN ou o endereço IP, clique em Iniciar, aponte para Programas, clique em Prompt do MS-DOS e depois tente executar um ping num site da Web conhecido, usando tanto o FQDN quanto o endereço IP.

    Observação Muitos sites grandes possuem este recurso habilitado. Por isto, não é possível aplicar o ping nestes sites.

    Se você conseguir usar o comando ping no site pelo endereço IP mas, ainda receber a seguinte mensagem de erro, vá para a etapa 8.
    A página não pode ser exibida
    Se não for possível usar o comando ping no site usando ou o endereço FQDN ou o endereço IP, verifique se ainda é possível usar o comando ping no host local (127.0.0.1) e verifique se o valor do Library Path na seguinte chave do registro está apontando para o local correto do arquivo Rnr20.dll:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2\Parameters\NameSpace_Catalog5\Catalog_Entries\000000000001
  8. Verifique as Propriedades de rede e procure diversos exemplos do protocolo TCP/IP que estejam vinculados ao adaptador de rede dial-up.
  9. Procure diversos exemplos de arquivos Winsock. Renomeie qualquer arquivo que não esteja na pasta adequada a menos que esteja numa pasta AOL, C:\Windows\Sysbckup ou C:\Windows\Ws2bakup. As seguintes pastas estão corretas para os arquivos Winsock:
    Winsock.dll em C:\Windows
    Wsock32.dll, Wsock.vxd, Wsock2.vxd, Ws2_32.dll em C:\Windows\System
    As datas e versões destes arquivos devem corresponder à versão do Windows e à data do sistema para esta versão, exceto quando o Winsock2 ou o DUN 1.3 forem adicionados ao Windows 95. Se você encontrar uma pasta C:\Windows\Ws2bakup, isto indica que Winsock2 foi instalado e que DUN 1.3 está, se estiver instalado, na lista da ferramenta Adicionar/remover programas no Painel de controle.

    Para renomear e substituir os arquivos Winsock, execute as seguintes etapas:
    1. Clique em Iniciar, aponte para Localizar e depois clique em Arquivos ou pastas.
    2. Na caixa Nome, digite o nome correto do arquivo (por exemplo, digite wsock32.dll, winsock.dll ou wsock.vxd), clique no disco rígido na caixa Examinar e depois em Localizar agora.
    3. Para renomear cópias extras dos arquivos, clique com o botão direito do mouse no arquivo, clique em Renomear e altere a extensão do arquivo para .old. Por exemplo, renomeie Wsock32.dll para Wsock32.old.

      Observação Se você receber uma mensagem de erro informando que já existe um arquivo com este nome, escolha outra extensão para o arquivo (por exemplo, .zzz). Se você receber uma mensagem de erro indicando que o arquivo não pode ser renomeado porque está em uso, reinicie o computador no prompt do MS-DOS e renomeie o arquivo no DOS.
    Para obter informações adicionais sobre as datas e os tamanhos corretos destes arquivos, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
    135539 Listagem de diretório do CD-ROM do Windows 95 (4 de 5)
    150440 Listagem de diretório do CD-ROM do Windows 95 Service Pack 1 (4 de 5)
    158193 Diretório do CD-ROM do Windows 95 OEM Service Release 2 (5 de 6)
    188428 Listagem de diretório do CD-ROM do Windows 98 (1 de 14)
    238664 Listagem de diretório do CD-ROM do Windows 98 Segunda Edição (1 de 14)
  10. Se o computador estiver executando o Microsoft Windows 98 ou o Windows Millennium Edition (ME), vá para a etapa 13. Se o computador estiver executando o Windows 95, procure o arquivo Ws2bakup.bat no disco rígido. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar, aponte para Localizar e clique em Arquivos ou pastas.
    2. Na caixa Nome, digite ws2bakup.bat, clique no disco rígido na caixa Examinar e depois clique em Localizar agora.
    3. Se encontrar o arquivo, vá para a etapa 11. Se você não encontrar o arquivo, vá para a etapa 13.
  11. Após localizar o arquivo Ws2bakup.bat, execute as seguintes etapas:
    1. Clique em Iniciar, clique em Executar, digite c:\windir\ws2bakup\ws2bakup.bat na caixa Abrir, em que windir é a pasta em que você instalou o Windows, e pressione ENTER.

      Observação Se você receber uma mensagem de erro informando que houve uma violação de compartilhamento, pressione A para interromper o comando. Repita esta etapa até que o arquivo em lotes tenha parado de ser executado.
    2. Clique em Iniciar e em Desligar.
    3. Clique em Reiniciar o computador em modo MS-DOS e em OK.
    4. No prompt de comando, digite c:\windir\ws2bakup\ws2bakup.bat e pressione ENTER.

      Observação Se você receber uma mensagem de erro enquanto estiver atualizando o registro, ignore esta mensagem.
  12. Digite exit para reiniciar o Windows.
  13. Exporte e exclua as chaves WinSock2 do registro, localizadas nas seguintes chaves do registro.

    Observação Remova AOL antes de executar as seguintes etapas. Entre em contato com a AOL para obter informações sobre como fazer backup de dados pessoais antes de remover o serviço.
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\AFVXD


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\DHCP


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\MSTCP


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\Winsock


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\Winsock2


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess\Authentication\SMM_Files
  14. Remova e reinstale o protocolo TCP/IP para reconstruir estas chaves do registro antes de testar a conexão na próxima etapa. Talvez você também precise remover e reinstalar o DUN se remover a chave
    SMM_files
    .

    Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados do Conhecimento Microsoft (a página pode estar em inglês):
    218822 Mensagem de erro: Rundll32 causou uma falha de página inválida no módulo Rnaui.dll
    Aviso Não execute a etapa 15, se estiver executando o Windows Millennium Edition (ME).
  15. Se ainda assim receber a mensagem de erro, talvez você precise remover manualmente o protocolo TCP/IP e o sistema de rede dial-up.

    Para obter mais informações sobre como remover e reinstalar o Acesso à rede dial-up e os arquivos de protocolo TCP/IP, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
    181599 Como remover e reinstalar sistema de rede dial-up e arquivos de protocolo TCP/IP

Você recebe a mensagem de erro após instalar o compartilhamento de conexão com a Internet e o AOL

Se você receber a mensagem de erro após instalar o compartilhamento de conexão com a Internet juntamente com o America Online (AOL), verifique se não há restrições de controle do responsável na conta. Se você receber a mensagem de erro após instalar o compartilhamento de conexão com a Internet e a AOL for o seu provedor de serviços de Internet (ISP), verifique se o protocolo TCP/IP (compartilhado) está vinculado ao adaptador da AOL e não ao adaptador de rede dial-up. Por padrão, se ambos adaptadores estiverem listados em Ambiente de rede quando o compartilhamento de conexão com a Internet for instalado, o protocolo TCP/IP (compartilhado) será vinculado ao adaptador da rede dial-up. É preciso remover o compartilhamento de conexão com a Internet e o adaptador da rede dial-up do Ambiente de rede, além de reinstalar o compartilhamento de conexão e verificar se assim o protocolo TCP/IP (compartilhado) é vinculado ao adaptador da AOL. Você poderá então reinstalar o adaptador para rede dial-up.

Mais Informações

Para obter informações adicionais sobre como determinar em que pasta o Windows está instalado, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
305792 Como determinar em qual pasta o Windows está instalado
Para obter informações adicionais sobre como solucionar mensagens de erro no Internet Explorer, visite o seguinte site da Microsoft (em inglês):
http://support.microsoft.com/default.aspx?pr=ie

Referências

Para obter informações adicionais, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
219843 Problemas ao usar o Internet Explorer com arquivo de Hosts incorreto
175722 Mensagem de erro: O Internet Explorer não pode abrir o site da Internet...
175039 Mensagem de erro: Não pôde ser estabelecida uma conexão com o servidor
188952 Mensagem de erro 'Ocorreu um erro interno' ao usar o Internet Explorer
222909 Mensagem de erro: Erro interno em Extensões de Internet do Windows
185533 Protocolo TCP/IP não funciona após a atualização para o Windows 98
191064 Mensagens de erro ao executar utilitários ou programas com base em protocolo TCP/IP
238550 Impossível navegar na Internet usando o Internet Explorer estando conectado ao AOL
158474 Entradas de registro do protocolo TCP/IP do Windows
181599 Como remover e reinstalar o sistema de rede dial-up e arquivos de protocolo TCP/IP
234815 Descrição do Compartilhamento de conexão com a Internet
238135 Como solucionar problemas do Compartilhamento de conexão com a Internet

Propriedades

ID do artigo: 241344 - Última revisão: segunda-feira, 24 de julho de 2006 - Revisão: 8.0
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.5 nas seguintes plataformas
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.01 nas seguintes plataformas
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.0 nas seguintes plataformas
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Edição de 128 Bits
  • Microsoft Internet Explorer 4.0 Edição de 128 Bits
Palavras-chave: 
kberrmsg kbprb kbwinme msiew95 msiew98 KB241344

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com