"Could not find destination computer" error when you connect an assigned VDI desktop that is deployed through Remote Desktop Connection Broker in Windows Server 2008 R2

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Article ID: 2415644 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • In a network environment, you deploy a personal virtual desktop through Remote Desktop Connection Broker on a computer that is running Windows Server 2008 R2.
  • You try to connect to the assigned virtual desktop infrastructure (VDI) desktop.
In this scenario, you receive the following error message:
Could not find destination computer
Note This issue occurs if the Remote Desktop Connection Broker cannot reach a writable domain controller.

CAUSE

This issue occurs because the VDI scenario does not work together with read-only domain controllers. The involved components incorrectly request a writable domain controller.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)

Registry information

You do not have to change the registry to use this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.1.760 0 . 20xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tscpubsvr.dll6.1.7600.20861179,71218-Dec-201006:09x64
Tscpubsvr.dll6.1.7601.21624180,22418-Dec-201008:52x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Remote Desktop Connection Broker, visit the following Microsoft websites:
Overview of Remote Desktop Connection Broker
General information about Remote Desktop Connection Broker
For more information about the virtualization types in Windows Server 2008 R2, visit the following Microsoft website:
Enabling Server and Desktop Virtualization
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_a254281b4206d3d5427405f18137a266_31bf3856ad364e35_6.1.7601.21624_none_a63f59777a475fb3.manifest
File versionNot applicable
File size726
Date (UTC)21-Dec-2010
Time (UTC)00:00
PlatformNot applicable
File nameAmd64_e8831b4222576762aa703dbb408d335a_31bf3856ad364e35_6.1.7600.20861_none_06016027054142f2.manifest
File versionNot applicable
File size726
Date (UTC)21-Dec-2010
Time (UTC)00:00
PlatformNot applicable
File nameAmd64_microsoft-windows-t..s-centralpublishing_31bf3856ad364e35_6.1.7600.20861_none_4a14f7fa7351f394.manifest
File versionNot applicable
File size24,362
Date (UTC)18-Dec-2010
Time (UTC)06:57
PlatformNot applicable
File nameAmd64_microsoft-windows-t..s-centralpublishing_31bf3856ad364e35_6.1.7601.21624_none_4c29958e70553bc1.manifest
File versionNot applicable
File size24,362
Date (UTC)18-Dec-2010
Time (UTC)09:28
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,989
Date (UTC)21-Dec-2010
Time (UTC)00:00
PlatformNot applicable

Properties

Article ID: 2415644 - Last Review: February 10, 2011 - Revision: 1.0
APPLIES TO
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Foundation
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew KB2415644

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