Article ID: 241584 - Last Review: November 17, 2011 - Revision: 5.0

Service does not start and displays "Error 1058"

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This article was previously published under Q241584
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SYMPTOMS

When you attempt to start a service manually, you may receive the following error message:
Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

CAUSE

This behavior can occur if the service is disabled or if the service is disabled for the hardware profile that you are currently using.

RESOLUTION

To resolve this issue, follow the steps listed for your operating system:

For Windows 7 and Windows Vista, follow these steps:

  1. Click the Start button, then type Services in the Search box.
  2. Click Services in the results pane.
  3. Scroll through the list until you find the service that is stopped or disabled.
  4. Click the Log On As tab.
  5. If the service is listed as disabled for your profile, right click the service, then click Properties.
  6. Click the Startup type dropdown list and choose Automatic, the click Apply, then OK.

For Windows XP, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  2. Double-click the service that did not start.
  3. Click the Log On tab.
  4. Verify that the service has not been disabled for the hardware profile that you are using. If it has, click Enable.
  5. Click the General tab. Verify that the service has not been disabled in the Startup Type box. If it has, click Automatic to have it start when you start the computer.

STATUS

This behavior is by design.

MORE INFORMATION

If a service is set to start automatically, but the service has been disabled for the hardware profile being used, the service is not started and no error message is generated.

This article applies to Windows 2000. Support for Windows 2000 ended on July 13, 2010. The Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/win2000) is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .



APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
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