Błąd 1058 jest wyświetlany, gdy usługa nagle się zatrzymuje

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że błąd "Błąd 1058" występuje, gdy usługa nagle się zatrzymuje.

Dotyczy: Windows 10 — wszystkie wersje, Windows 7, Windows Vista, Windows XP
Oryginalny numer KB: 241584

Symptomy

Po nagłej zatrzymaniu usługi może zostać wyświetlony następujący komunikat o błędzie:

Błąd 1058: Nie można uruchomić usługi, ponieważ jest wyłączona lub nie ma skojarzonych z nią urządzeń z włączoną obsługą.

Ten komunikat o błędzie może również zostać wyświetlony podczas próby uruchomienia usługi.

Przyczyna

Ten problem może wystąpić, jeśli usługa jest wyłączona lub usługa jest wyłączona dla aktualnie używanego profilu sprzętu.

Rozwiązanie dla Windows 10, Windows 7 i Windows Vista

  1. Kliknij przycisk Start, wyszukaj pozycję Usługi, a następnie kliknij pozycję Usługi w wyniku wyszukiwania.

  2. Przewiń do momentu znalezienia usługi, a następnie kliknij dwukrotnie usługę.

    Zrzut ekranu przedstawiający opcję Typ uruchamiania na karcie Ogólne okna dialogowego Właściwości routingu i dostępu zdalnego (komputer lokalny).

  3. Jeśli usługa jest wyłączona, kliknij listę Typ uruchamiania , a następnie wybierz opcję inną niż Wyłączone.

  4. Kliknij przycisk Zastosuj.

  5. Kliknij przycisk Start , aby spróbować uruchomić usługę.

  6. Kliknij przycisk OK.

Rozwiązanie dla systemu Windows XP

  1. Kliknij przycisk Start, wskaż pozycję Wszystkie programy, wskaż pozycję Narzędzia administracyjne, a następnie kliknij pozycję Usługi.

  2. Przewiń, aż znajdziesz usługę zatrzymaną lub wyłączoną.

  3. Kliknij dwukrotnie usługę, która nie została uruchomiona.

  4. Kliknij kartę Logowanie.

    Zrzut ekranu przedstawiający kartę Logowanie w oknie dialogowym Właściwości lokalizatora zdalnego wywołania procedury (RPC).

  5. Sprawdź, czy usługa nie jest wyłączona dla używanego profilu sprzętu. Jeśli usługa jest wyłączona dla profilu sprzętu, kliknij przycisk Włącz.

  6. Kliknij kartę Ogólne , a następnie w polu Typ uruchomienia sprawdź, czy usługa nie jest wyłączona. Jeśli usługa jest wyłączona , kliknij pozycję Automatyczne, aby uruchomić ją po uruchomieniu komputera.

    Zrzut ekranu przedstawiający pole typu uruchamiania na karcie Ogólne.

  7. Kliknij przycisk OK.

Więcej informacji

Jeśli usługa jest skonfigurowana do automatycznego uruchamiania, ale usługa jest wyłączona dla używanego profilu sprzętu, usługa nie zostanie uruchomiona i nie zostanie wygenerowany żaden komunikat o błędzie.