File name may get garbled or FTP folder error may occur when uploading a file including Japanese text to an FTP site by using the FTP function of Windows Explorer.

Article translations Article translations
Close Close
Article ID: 2416991 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

When a file including Japanese text is uploaded to an FTP site by using the FTP function of Windows Explorer of Microsoft Windows OS, the file name of the uploaded file may get garbled or the following FTP folder error may occur.

Collapse this imageExpand this image
2784871


Cause

Even though the FTP function of Windows Explorer negotiates with the FTP server, characters are not correctly converted when UTF-8 encoding is used, causing the aforementioned symptom.

Workaround

To avoid this symptom, disable the UTF-8 setting in an FTP server.
  1. Open Server Manager.
  2. Click Roles > Web server (IIS) > Internet Information Services (IIS) Manager.
  3. In the Connections pane, click to expand the appropriate server name > Sites > the appropriate site name.
  4. Right-click the appropriate site name and click Manage FTP site > Advanced Settings.
  5. In the Advanced Settings dialog box, set Enable UTF-8 to False (the default value is True).
  6. Click the OK. button.
  7. Right-click the appropriate site name and click Manage FTP site > Restart.

Status

Microsoft is researching this problem and will post more information in this article when the information becomes available.

More information

Procedure for Recreating the Problem

  1. In the FTP Server, enable UTF-8. If you are using Internet Information Services 7.5 (IIS 7.5), use the advanced settings in the properties of the FTP site.
  2. In the Address box of Windows Explorer, enter "ftp://FTP server name".
  3. Upload a file including Japanese text.

Result

The file name of the uploaded file gets garbled.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2416991 - Last Review: November 19, 2012 - Revision: 1.0
Applies to
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows 7 Home Basic
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional for Itanium-based systems
  • Microsoft Windows XP Media Center Edition 2005
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 Foundation
  • Windows Server 2008 R2 for Itanium-Based Systems
Keywords: 
kbharmony kbexpertiseinter kbtshoot kbbug kberrmsg kbmt KB2416991 KbMten

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com