REVISIÓN: Los archivos y claves del registro para la ruta de instalación desaparecen inesperadamente al instalar un archivo MSI para un proyecto de instalación que tiene una actualización importante de Visual Studio 2008 para 2010 de Visual Studio

Seleccione idioma Seleccione idioma
Id. de artículo: 2418919 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Generar un proyecto de instalación de Microsoft Visual Studio 2008 y, a continuación, instale el archivo MSI generado para una ruta de instalación.
  • Migrar el proyecto de instalación para el 2010 de Visual Studio y, a continuación, las siguientes acciones para una actualización importante:
    • Cambia el campo principal de laVersión del productopropiedad.
    • Cambia elProductCodepropiedad.
    • Establece elRemovePreviousVersionspropiedad paraEs True.
  • Volver a generar el proyecto de instalación y, a continuación, instale el archivo MSI generado en la misma ruta de instalación.

En este escenario, los archivos y claves del registro para la ruta de instalación desaparecen inesperadamente.

Causa

Este problema se produce debido a que se utiliza un algoritmo de hash diferente para crear los GUID en 2010 de Visual Studio. Cuando se instala el archivo MSI que se crea a partir del proyecto de instalación de Visual Studio 2010, el archivo MSI se determina que el GUID se ha cambiado y elimina los archivos y claves del registro para la ruta de instalación que se basa en la secuencia del proyecto.

Solución

Para resolver este problema, aplique esta revisión. Esta revisión se presenta laBackwardCompatibleIDGenerationpropiedad. De forma predeterminada, esta propiedad se establece enFalse. Antes de generar el proyecto de instalación de Visual Studio de 2010, tendrá que configurar explícitamente elBackwardCompatibleIDGenerationpropiedad paraEs TruePara habilitar la revisión.

Información de la revisión

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a que la próxima actualización de software que contenga este hotfix.

Para resolver este problema inmediatamente, póngase en contacto con los servicios de soporte técnico de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de soporte y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
NotaEn casos especiales, los costos derivados normalmente llamadas de soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos de soporte técnico usuales se aplicarán a las cuestiones y problemas que no guarden relación con la actualización en cuestión.

Para descargar este hotfix desde MSDN Code Gallery, visite el siguiente sitio Web de Microsoft:
http://Code.msdn.Microsoft.com/KB2418919

NotaLa Galerie de Code muestra los idiomas para los que la revisión está disponible. Si no ve su idioma en la lista, es porque la página de recursos de la Galería de códigos no está disponible para ese idioma.

O bien, puede descargar este hotfix desde el siguiente sitio Web de Microsoft Connect:
¿https://Connect.Microsoft.com/VisualStudio/downloads/downloaddetails.aspx?DownloadID = 32676

Requisitos previos

Para aplicar este hotfix, debe tener instaladas de Visual Studio 2010.

Información de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix. Se recomienda que salga de todas las instancias de Visual Studio o de Microsoft.NET Framework completas antes de aplicar este hotfix.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala los archivos que tienen los atributos que aparecen en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza ciertas operaciones en los archivos.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño del archivoFechaTiempoPlataforma
Dpca.dll10.0.30319.421236,87221-Ene-201112: 11x 86
Dpdpl.dll10.0.30319.421145,23221-Ene-201112: 11x 86
Dpdpl.dll10.0.30319.421145,74421-Ene-201112: 11x 86
Dpdpl.dll10.0.30319.421146,25621-Ene-201112: 11x 86
Dpdpl.dll10.0.30319.421147,28021-Ene-201112: 11x 86
Dpdpl.dll10.0.30319.421147,79221-Ene-201112: 11x 86
Dpdpl.dll10.0.30319.421148,30421-Ene-201112: 11x 86
Dpdpl.dll10.0.30319.421904,00821-Ene-201112: 11x 86
Dpedt.dll10.0.30319.421696,13621-Ene-201112: 11x 86
Dpplg.dll10.0.30319.4212,604,36021-Ene-201112: 11x 86
Dpprj.dll10.0.30319.4211,229,64021-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421163,15221-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421163,66421-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421167,24821-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421168,27221-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421178,00021-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421178,51221-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421180,56021-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421181,07221-Ene-201112: 11x 86
Dpprjui.dll10.0.30319.421181,58421-Ene-201112: 11x 86
Projectsidl3.tlbNo se puede aplicar2,81619-Ene-201107: 33No se puede aplicar



Solución

Para evitar este problema, utilice uno de los métodos siguientes:
  • Método 1:Cambiar manualmente todos los GUID del componente para que sea igual a la de Visual Studio 2008.
  • Método 2:Volver a ordenar elRemoveExistingProductsacción después de laInstallInitializeacción. Esto garantiza que los archivos más antiguos se eliminan y, a continuación, volver a instalar la versión más reciente.

    NotaEste método no funciona cuando se dispone de componentes compartidos.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 2418919 - Última revisión: viernes, 25 de febrero de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Visual Studio 2010 Premium with MSDN
  • Microsoft Visual Studio 2010 Professional
  • Microsoft Visual Studio 2010 Ultimate
Palabras clave: 
kbexpertiseinter kbprb kbsurveynew kbfix kbbug kbqfe kbhotfixserver kbmt KB2418919 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2418919

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com