WD2000: Field Text Truncated When Merging or Inserting Database

Article translations Article translations
Article ID: 242072 - View products that this article applies to.
This article was previously published under Q242072
Expand all | Collapse all

On This Page

SYMPTOMS

When you perform a mail merge with a database (or insert a database) that contains a NOTES or MEMO field, only the first 255 characters of the NOTES or MEMO field are merged (inserted).

NOTE: The name of your NOTES or MEMO field may be different; however, when a field contains more than 255 characters, the text of the field will be truncated.

CAUSE

This problem is a limitation of Word 2000 when attaching to or inserting database files using Open Database Connectivity (ODBC).

WORKAROUND

To temporarily work around this problem, connect to or insert your database using Dynamic Data Exchange (DDE). To do this, follow the steps that are appropriate for your situation.

Perform a Mail Merge

  1. In your mail-merge main document, click Mail Merge on the Tools menu.
  2. In the Mail Merge Helper, click Create and then click the type of mail merge you want to perform. For example, click Form Letters.
  3. Click Active Window.
  4. In the Mail Merge Helper, click Get Data and then click Open Data Source.
  5. In the Open Data Source dialog box, do the following steps:
    1. Change the Files of type box to the type of your database. For example, if your database is an Access database, change the Files of type box to MS Access Databases (*.mdb, *.mde).
    2. Select the Select method check box.
    3. Change the Look in box to the folder containing your database file. For example, change the Look in box to C:\Program Files\Microsoft Office\Office\Samples folder.
    4. Click your database file. For example, click the Northwind.mdb database.
    5. Click Open.
  6. In the Confirm Data Source dialog box, click MS Access Databases via DDE (*.mdb, *.mde), and then click OK.
Continue your mail merge as usual.

Insert a Database

  1. In your Word document, point to Toolbars on the View menu and then click Database.
  2. On the Database toolbar, click Insert Database.
  3. Click Get Data.
  4. In the Open Data Source dialog box, do the following steps:
    1. Change the Files of type to the type of your database. For example, if your database is an Access database, change the Files of type box to MS Access Databases (*.mdb, *.mde).
    2. Select the Select Method check box.
    3. Change the Look in box to the folder containing your database file. For example, change the Look in box to C:\Program Files\Microsoft Office\Office\Samples folder.
    4. Click your database file. For example, click the Northwind.mdb database.
    5. Click Open.
  5. In the Confirm Data Source dialog box, click MS Access Databases via DDE (*.mdb, *.mde), and then click OK.

    NOTE: You may have to select a table in the Select Table dialog box.
  6. In the Database dialog box, click Insert Data.
  7. In the Insert Data dialog box, select the range of records you want; for example, click All and then click OK.

RESOLUTION

To increase the ODBC character limitation of fields when inserting a database or when using a database in a Word mail merge, use one of the following fixes:

Fix 1: Increase the ODBC Field Character Limitation to 50,000

To resolve this problem, obtain the latest service pack for Microsoft Office 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
276367 OFF2000: How to Obtain the Latest Office 2000 Service Pack
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.:
   Date         Time   Version  Size       File name     
   ---------------------------------------------------------
   11-JUN-2002  03:35  n/a      4,001,944  Winword.msp
   11-JUN-2002  05:09  n/a      4,681,888  Winword_admin.msp
				
After the hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version     Size        File name     
   -------------------------------------------------------
   07-JUN-2002  14:37  9.0.0.6604  8,818,740   Winword.exe 
				

IMPORTANT NOTE: The limitation when attaching to or inserting database files by using Open Database Connectivity (ODBC) has been increased to 50,000 characters in a field for Microsoft Office 2000 Service Release 1 (SR-1). However, when a field contains more than 50,000 characters, the text of the field still will be truncated.

Fix 2: Increase the ODBC Field Character Limitation to 2,550

To resolve this problem, obtain the latest service pack for Microsoft Office 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
276367 OFF2000: How to Obtain the Latest Office 2000 Service Pack

Before you install Microsoft Office 2000 Service Pack 3 (SP-3), you must have Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a) installed first. To obtain Office 2000 Service Release 1/1a (SR-1/SR-1a), click the article number below to view the article in the Microsoft Knowledge Base:
245025 OFF2000: How to Obtain and Install Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)

IMPORTANT: The limitation when attaching to or inserting database files by using Open Database Connectivity (ODBC) has been increased to 2,550 characters in a field for Microsoft Office 2000 Service Release 1 (SR-1). However, when a field contains more than 2,550 characters, the text of the field still will be truncated.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Office 2000 Service Pack 3 (SP-3).
The ODBC limitation of the NOTES and MEMO fields when inserting a database or when using a database in a Word mail merge has been increased according to the fixes described in the Resolution section of this article.

MORE INFORMATION

For additional information about mail merge, click the article numbers below to view the articles in the Microsoft Knowledge Base:
211190 HOW TO: Use Access 2000 Data in Word 2000
212322 WD2000: How to Design and Set Up Mail Merge Data
212034 WD2000: How to Create Mailing Labels Using Mail Merge
212017 WD2000: How to Create Envelopes Using Mail Merge

Properties

Article ID: 242072 - Last Review: April 7, 2006 - Revision: 4.0
APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbbug kbfix kbqfe kboffice2000sp3fix kbhotfixserver KB242072

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com