O Servidor RPC está Indisponível Quando Você Tenta Adicionar uma Impressora

ID do artigo: 242079 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi publicado anteriormente em BR242079
Expandir tudo | Recolher tudo

Sintomas

Ao tentar adicionar uma impressora para seu computador baseado no Microsoft Windows NT, você poderá receber a seguinte mensagem de erro:
A Operação não pôde ser concluída. O servidor RPC está indisponível.

Causa

Este problema pode ocorrer se os arquivos Spoolss.exe e Spoolss.dll estiverem ausentes na pasta %SystemRoot%\System32, ou estiverem danificados.

Resolução

Para solucionar este problema:

  1. Copie os arquivos Spoolss.exe e Spoolss.dll de outro servidor ou estação baseados no Windows NT 4.0 para a pasta %SystemRoot%\System32 do computador afetado.
  2. Aplique ou reaplique o último service pack adequado do Windows NT, e então reinicie o computador.
  3. Configure o Serviço RPC (Remote Procedure Call) para iniciar automaticamente:
    1. Clique em Start , aponte para Settings , clique em Control Panel , e então dê um duplo clique em Services .
    2. Na lista de Service clique emRPC (Remote Procedure Call) Service , e depois clique em Startup .
    3. Sob Startup Type , clique em Automatic e depois clique em OK .
  4. Reinicie o seu computador

Propriedades

ID do artigo: 242079 - Última revisão: terça-feira, 27 de agosto de 2002 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbprb KB242079

Submeter comentários