Ntdetect Fails When Computer Starts

Article translations Article translations
Article ID: 242112 - View products that this article applies to.
This article was previously published under Q242112
Notice
This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy.
Expand all | Collapse all

On This Page

SYMPTOMS

When you start a computer running Windows, the boot process may not succeed, and you may receive the following error message:
NTDetect Failed

CAUSE

This behavior can occur if the Ntdetect.com file is missing or damaged.

RESOLUTION

Windows NT 4.0

To resolve this issue in Windows NT 4.0, use the Emergency Repair Disk (ERD) to restore the boot files:
  1. Use Windows NT 4.0 Setup Disk 1 to start the computer.
  2. When you are prompted, insert Windows NT 4.0 Setup Disk 2.
  3. When the Windows NT Server Setup screen appears, press R to begin the repair process.
  4. Use the arrow keys to select Inspect Startup Environment from the repair options, press ENTER, and then cancel the selection of all other repair options.
  5. Select Continue, press ENTER, and then follow the instructions to detect mass-storage devices.
  6. When you are prompted, insert the ERD.
  7. When you are prompted, insert the Windows NT Server 4.0 CD-ROM.
  8. When the repair process is completed, remove the ERD from the floppy disk drive, and then press ENTER to restart the computer.

Windows 2000

To resolve this issue in Windows 2000:
  1. Start the computer from the Windows 2000 CD-ROM.
  2. At the "Welcome to Setup" menu select R for repair.
  3. Select Manual Repair.
  4. Select only Startup Environment from the repair options.
  5. When prompted, insert the Emergency Repair Disk (ERD). If you do not have an ERD you can proceed without one.
  6. When the repair process is completed, remove the ERD from the floppy disk drive, and then press ENTER to restart the computer.

MORE INFORMATION

For additional information about using an ERD, please see the following articles in the Microsoft Knowledge Base:
103280 Using an Emergency Repair Disk Created by Windows NT

129037 Windows NT 3.5x and 4.0 Emergency Repair Process Screens

Properties

Article ID: 242112 - Last Review: March 1, 2007 - Revision: 3.4
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Keywords: 
kbprb KB242112

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com