Artigo: 242361 - Última revisão: quarta-feira, 1 de Novembro de 2006 - Revisão: 1.1

RPC "Servidor não está disponível" quando Auditar registo de mensagem está cheio

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante : Este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o restaurar o registo se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Descrição do registo do Microsoft Windows

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Sintomas

Poderá receber uma das seguintes mensagens de erro:
O servidor de RPC não está disponível
RPC demasiado ocupado
Quando isto ocorrer, ligação ao servidor de pára. Reiniciar o servidor limpa a mensagem e restaura conectividade temporariamente.

Causa

Este comportamento pode ocorrer se tiver executado o utilitário Gestor de configuração de C2 a partir do Microsoft Windows NT 4.0 Resource Kit. O utilitário Gestor de configuração C2 efectua alterações ao servidor que desactive a funcionalidade de rede se não pode ser registado um evento auditáveis.

O utilitário Gestor de configuração C2 altera duas para o servidor parar a funcionalidade de rede se auditáveis eventos não podem ser registados. A primeira alteração é a adição da seguinte chave de registo:
Chave: \CurrentControlSet\Control\Lsa
Valor: CrashOnAuditFail
Tipo: REG_DWORD
Valor de dados: 1
Esta chave impede actividades auditáveis quando o registo de segurança ficar cheio.

A segunda alteração é a definição para os ficheiros de registo no Visualizador de eventos. A definição de Moldagem do registo de ficheiro é alterada para Não substituir eventos (limpar registo manualmente) .

Com estas dois definições no local, o servidor encerra todos auditáveis processos (causar chamada de procedimento remoto ou RPC, deixe de funcionar) quando o registo de eventos de segurança ficar cheio.

Resolução

Utilize um dos seguintes métodos para contornar este problema:

Método 1: Remover o valor CrashOnAuditFail

aviso : a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. As suas próprias risco da utilização do Editor de registo.

Utilize o Editor de registo (Regedt32.exe) para eliminar o valor CrashOnAuditFail da seguinte chave de registo:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\
Depois de efectuar esta alteração, saia do Editor de registo e reinicie o computador para fazer com que a alteração tenha efeito.

Método 2: Alterar as definições de registo de eventos

  1. Inicie o Visualizador de eventos.
  2. No menu registo , clique em Definições do registo .
  3. Na caixa de diálogo definições , pode aumentar o tamanho do registo de segurança ou altere a definição Moldagem do registo de ficheiro para Substituir eventos conforme necessário .

Mais Informação

Para obter informações adicionais sobre o valor CrashOnAuditFail, clique os números de artigo existente abaixo para visualizar os artigos na base de dados de conhecimento da Microsoft:
140058  (http://support.microsoft.com/kb/140058/EN-US/ ) Como impedir actividades auditáveis ao registo de segurança está cheio
178208  (http://support.microsoft.com/kb/178208/EN-US/ ) CrashOnAuditFail com a auditoria de início de sessão/fim de sessão provoca o ecrã azul

A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 1
  • Microsoft Windows NT 4.0 Service Pack 2
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 242361  (http://support.microsoft.com/kb/242361/en-us/ )