ID do artigo: 242361 - Última revisão: quarta-feira, 1 de novembro de 2006 - Revisão: 1.1

RPC "Servidor não está disponível" mensagem ao log de auditoria está cheio

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante : Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de backup e certifique-se que você saiba como restaurar o registro se ocorrer um problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Descrição do registro do Microsoft Windows

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Você pode receber uma das seguintes mensagens de erro:
Servidor RPC não está disponível
RPC muito ocupado
Quando isso ocorre, pára de conectividade com o servidor. Reinicializar o servidor limpa a mensagem e restaura conectividade temporariamente.

Causa

Esse comportamento pode ocorrer se você executou o utilitário C2 Configuration Manager do Microsoft Windows NT 4.0 Resource Kit. O utilitário C2 Configuration Manager faz alterações ao servidor que desativar a funcionalidade da rede se um evento auditável não puder ser registrado.

O utilitário C2 Configuration Manager realiza duas alterações no servidor que param de funcionalidade da rede se eventos auditáveis não podem ser registrados. A primeira alteração é a adição da seguinte chave do Registro:
Chave: \CurrentControlSet\Control\Lsa
Valor: CrashOnAuditFail
Tipo: REG_DWORD
Valor de dados: 1
Essa chave impede que atividades passíveis de auditoria quando o log de segurança fica cheio.

A segunda alteração é a configuração para os arquivos de log em Visualizar eventos. A configuração de Disposição de arquivo de log é alterada para Não substituir eventos (limpar log manualmente) .

Com essas duas configurações in-loco, o servidor desliga auditáveis todos os processos (fazendo com que chamada de procedimento remoto, ou RPC, para parar de funcionar) quando o log de eventos de segurança ficar cheio.

Resolução

Use um dos seguintes métodos para contornar este problema:

Método 1: Remover o valor CrashOnAuditFail

Aviso : se você usar o Editor do Registro incorretamente, poderá causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Use o Editor do Registro (Regedt32.exe) para excluir o valor CrashOnAuditFail da seguinte chave do Registro:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\
Após fazer essa alteração, feche o Editor do Registro e reinicie o computador para fazer com que a alteração tenha efeito.

Método 2: Alterar as definições de log de eventos

  1. Inicie Visualizar eventos.
  2. No menu log , clique em Configurações de log .
  3. Na caixa de diálogo configurações , você pode aumentar o tamanho do log de segurança ou altere a configuração Disposição de arquivo de log para Substituir eventos conforme necessário .

Mais Informações

Para obter informações adicionais sobre o valor CrashOnAuditFail, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
140058  (http://support.microsoft.com/kb/140058/EN-US/ ) Como impedir que atividades auditáveis ao log de segurança está cheio
178208  (http://support.microsoft.com/kb/178208/EN-US/ ) CrashOnAuditFail com auditoria de logon/logoff causa tela azul

A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 1
  • Microsoft Windows NT 4.0 Service Pack 2
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
Palavras-chave: 
kbmt kbenv kberrmsg kbprb KB242361 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 242361  (http://support.microsoft.com/kb/242361/en-us/ )