XADM: Almacén de información no se inicia después una desfragmentación sin conexión con 4294966277

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Síntomas

Después de ejecutar una desfragmentación sin conexión (el comando eseutil /d ), el almacén de información no se inicia y devuelve un mensaje de error 4294966277.

Se registran los sucesos siguientes en el registro de sucesos de aplicación:
ID. de suceso: 0
Origen: ESE97
Tipo: error
Categoría: Recuperación y registro
Descripción: MSExchangeIS ((451))-1019

ID. de suceso: 1120
Origen: MSExchangeIS
Tipo: error
Categoría: general
Descripción: Error 0xfffffc05 al inicializar la base de datos del almacén de información de Microsoft Exchange Server.
El archivo Tempdfrg.edb (este nombre de archivo puede ser diferente si ha utilizado un modificador /t en el comando de desfragmentación) que se crea durante la desfragmentación es todavía en la unidad; elimina una desfragmentación normal.

Causa

La desfragmentación del almacén de información no finaliza la copia de la base de datos del archivo temporal (desfragmentados) a la ubicación original. La base de datos, por lo tanto, está dañado e inutilizable. El 4294966277 mensaje de error es un error JET_errPageNotInitialized, lo que significa que una página en la base de datos está en blanco o no se ha inicializado correctamente.

Solución

Cuando la desfragmentación sin conexión no finaliza la copia, no se elimina la base de datos temporal. Si la base de datos temporal es la base de datos intacta, desfragmentó correctamente, puede copiarlo manualmente a la ubicación correcta.

Si sólo desfragmentar una base de datos y ya sabe qué base de datos está dañada, continúe en la sección "Copiar la base de temporales datos" de este artículo. Si desfragmentar bases de datos la Priv.edb y Pub.edb y no está seguro de la base de datos que ha causado el problema, realice los pasos siguientes para determinar la base de datos que está causando el problema:
  1. Comprobar la integridad de bases de datos la Priv.edb y Pub.edb:
    • Para comprobar la base de datos Priv.edb, en un símbolo del sistema, ejecute lo siguiente:
      eseutil /g /ispriv
    • Para comprobar la base de datos pub.edb, en un símbolo del sistema, ejecute lo siguiente:
      eseutil /g /ispub
  2. Tenga en cuenta la base de datos que no pasa la comprobación de integridad y devuelve un mensaje de error-1019.
  3. Observe el tamaño del archivo de base de datos que no pasa la comprobación de integridad.
  4. Compare este tamaño al tamaño del archivo temporal.
Comparando el tamaño de los dos archivos, puede determinar si el archivo Tempdfrg.edb es la versión desfragmentada del archivo de base de datos dañada. En la mayoría de los casos, los archivos son exactamente el mismo tamaño. El proceso de copia aparte establece el espacio al principio del proceso y, aunque el proceso no finaliza, el tamaño del archivo de base de datos todavía coincide con el archivo de origen.

Copiar la base de datos temporal

Para asegurarse de que la desfragmentación de base de datos finalizó correctamente y para copiar el archivo desfragmentado volver a la ubicación correcta:

  1. Nota : estos pasos se supone que se encuentran las bases de datos del almacén de información en el servidor en la carpeta D:\Exchsrvr\Mdbdata y el archivo temporal de la desfragmentación se encuentra en la unidad D (D:\Tempdfrg.edb).

  2. Realizar una comprobación de integridad con el archivo temporal. En un símbolo del sistema, ejecute lo siguiente:
    eseutil /g d:\tempdfrg.edb
    Si la comprobación de integridad finaliza correctamente, continúe con el paso siguiente. Si la comprobación de integridad no finaliza correctamente, ambas copias de la base de datos están dañados y debe restaurar la base de datos desde una copia de seguridad.
  3. Cambiar el nombre de la base de datos dañada (base de datos de la Priv.edb o Pub.edb).
  4. Copie el desfragmentación temporal archivo desde la unidad D (D:\Tempdfrg.edb) a la carpeta D:\Exchsrvr\Mdbdata.
  5. En la carpeta D:\Exchsrvr\Mdbdata, cambie el nombre el archivo Tempdfrg.edb al nombre de archivo de base de datos correcta (PRIV.edb o Pub.edb).
  6. Iniciar el almacén de información.
Nota : si se muestra un mensaje de error-1011 cuando inicia el almacén de información, no indica un problema. El almacén de información y el directorio deben deben volverse a sincronizar. Para sincronizar el almacén de información y el directorio, en un símbolo del sistema, ejecute lo siguiente:
\exchsrvr\bin\isinteg - revisión

Más información

Una desfragmentación sin conexión copia los datos de la base de datos actual a un nuevo archivo de base de datos. Cuando el proceso de desfragmentación llegue al 100 % en el archivo temporal es una base de datos desfragmentada y completa. En este momento, la utilidad copia el archivo temporal a la ubicación original, que sobrescribe la base de datos original.

Propiedades

Id. de artículo: 242364 - Última revisión: martes, 11 de febrero de 2014 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Exchange Server 5.5 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbprb KB242364 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 242364

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