XADM: Archivio informazioni non viene avviato dopo una deframmentazione non in linea con 4294966277

Traduzione articoli Traduzione articoli
Identificativo articolo: 242364 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato archiviato. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.
Espandi tutto | Chiudi tutto

Sintomi

Dopo l'esecuzione di una deframmentazione non in linea (il comando eseutil /d ), l'archivio informazioni non si avvia e restituisce un messaggio di errore 4294966277.

Nel registro eventi dell'applicazione vengono registrati i seguenti eventi:
ID evento: 0
Origine: ESE97
Tipo: errore
Categoria: Registrazione/ripristino
Descrizione: MSExchangeIS ((451))-1019

ID evento: 1120
Origine: MSExchangeIS
Tipo: errore
Categoria: generale
Descrizione: Errore 0xfffffc05 l'inizializzazione del database archivio informazioni di Microsoft Exchange Server.
Il file Tempdfrg.edb (il nome del file potrebbe essere diverso se un'opzione /t Ŕ stato utilizzato nel comando deframmentazione) che viene creato durante la deframmentazione Ŕ ancora sul disco; Elimina un normale processo di deframmentazione.

Cause

La deframmentazione dell'archivio informazioni non termina la copia del database dal file temporaneo (deframmentato) alla posizione originale. Il database Ŕ pertanto danneggiato e inutilizzabile. Il messaggio di 4294966277 errore Ŕ un errore di Jet_errPageNotInitialized, significa che una pagina all'interno del database Ŕ vuota o non Ŕ stata inizializzata correttamente.

Risoluzione

Quando la deframmentazione non in linea non viene completata la copia, il database temporaneo non viene eliminato. Se il database temporaneo Ŕ intatto il database deframmentato correttamente, Ŕ possibile copiare manualmente, alla posizione corretta.

Se si deframmentazione solo un database e si conosce giÓ il database Ŕ danneggiato, passare alla sezione "Copia del database temporaneo" di questo articolo. Se entrambi i file Priv.edb e Pub.edb deframmentato e si non Ŕ che il database che ha causato il problema, procedere come segue per determinare quale database Ŕ causato il problema:
  1. Verificare l'integritÓ dei database Priv.edb e Pub.edb:
    • Per controllare il database Priv.edb, al prompt dei comandi, eseguire le seguenti operazioni:
      ESEUTIL /g /ispriv
    • Per controllare il database pub.edb, al prompt dei comandi, eseguire le operazioni seguenti:
      ESEUTIL /g /ispub
  2. Si noti il database non supera il controllo dell'integritÓ e restituisce un messaggio di errore -1019.
  3. Si noti la dimensione del file di database non ha superato il controllo dell'integritÓ.
  4. Consente di confrontare questa dimensione alla dimensione del file temporaneo.
Confrontando le dimensioni dei due file, Ŕ possibile determinare se il file Tempdfrg.edb Ŕ la versione deframmentata del file di database danneggiato. Nella maggior parte dei casi, i file sono le stesse dimensioni. Il processo di copia riservare imposta lo spazio all'inizio del processo e anche se non si termina il processo, la dimensione del file database ancora corrisponde al file di origine.

Copia il database temporaneo

Per assicurarsi che la deframmentazione del database Ŕ stata completata e per copiare il file deframmentato nella posizione corretta:

  1. Nota : questa procedura presuppone che i database dell'archivio informazioni si trovino nel server la cartella D:\Exchsrvr\Mdbdata e che il file di deframmentazione temporanea si trova sull'unitÓ D (D:\Tempdfrg.edb).

  2. Eseguire una verifica integritÓ il file temporaneo. Al prompt dei comandi, eseguire le operazioni seguenti:
    ESEUTIL /g d:\tempdfrg.edb
    Se il controllo dell'integritÓ al termine, proseguire con il passaggio successivo. Se il controllo dell'integritÓ non viene completata correttamente, entrambi copie del database sono danneggiate ed Ŕ necessario ripristinare il database da un backup.
  3. Rinominare il database danneggiato (database il Priv.edb o Pub.edb).
  4. Copiare il temporaneo deframmentazione file dall'unitÓ D (D:\Tempdfrg.edb) nella cartella D:\Exchsrvr\Mdbdata.
  5. Nella cartella D:\Exchsrvr\Mdbdata, rinominare il file Tempdfrg.edb al nome del file corretti del database (priv.edb o Pub.edb).
  6. Avviare l'archivio informazioni.
Nota : se un messaggio di errore-1011 Ŕ visualizzato quando si avvia l'archivio informazioni, non indica un problema. L'archivio informazioni e la directory devono essere sincronizzati. Per sincronizzare l'archivio informazioni e la directory, al prompt dei comandi di eseguire il seguente comando:
\exchsrvr\bin\isinteg - patch

Informazioni

Una deframmentazione non in linea Copia i dati dal database corrente un nuovo file di database. Quando il processo di deframmentazione raggiunge il 100 % il file temporaneo Ŕ un database completo e deframmentato. A questo punto, l'utilitÓ Copia il file temporaneo alla posizione originale, che sovrascrive il database originale.

ProprietÓ

Identificativo articolo: 242364 - Ultima modifica: sabato 1 febbraio 2014 - Revisione: 3.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 5.5 Standard Edition
Chiavi:á
kbnosurvey kbarchive kbmt kbprb KB242364 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 242364
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com