インプレース アップグレードを実行すると、"Windows でパスの無人応答ファイルを解析または処理できませんでした [specialize]" というエラー メッセージが表示される

この記事では、インプレース アップグレードを実行するときに発生するエラー (Windows でパス [specialize] の無人応答ファイルを解析または処理できませんでした) を修正するためのヘルプを提供します。

適用対象: Windows 7、Windows Server 1、Windows Server 2012 R2
元の KB 番号: 2425962

現象

次のような状況で問題が発生します。

  • Unattend.xml ファイルを使用してインストールされた Windows 7 または Windows Server 2008 R2 のバージョンを実行しています。
  • このイメージからコンピューターを起動し、[イン プレース アップグレードの修復 (インストールの上書き)] オプションを選択します。
  • インプレース アップグレードを開始します。

このシナリオでは、次のエラー メッセージが表示されます。Windows では、無人応答ファイルを解析または処理してパス [specialize] を実行できませんでした。

一般に、Unattend.xml ファイルは OEM または企業環境の展開に使用されます。 したがって、イメージに Unattend.xml ファイルが含まれている可能性があり、このファイルが含まれていることに注意していない可能性があります。

原因

この問題は、Unattend.xml ファイルがインプレース アップグレード中に適用されるために発生します。 このシナリオはサポートされていません。

詳細

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、次の記事番号をクリックして、「Microsoft サポート技術情報: Windows でレジストリをバックアップおよび復元する方法 」322756 の記事を参照してください

この動作が発生すると、システムを復旧できません。 そのため、クリーンインストールを実行する必要があります。

この動作を回避するには、OEM インストール イメージを使用してインプレース アップグレードを実行する前に、レジストリ サブキーを削除できます。 これを行うには、次の手順を実行します。

  1. 管理アクセス許可を持つユーザー アカウントを使用して、コンピューターにログオンします。
  2. [スタート] をクリックし、[スタート] 検索ボックスに「regedit」と入力し、[プログラム] の一覧で [regedit.exe] をクリックします。
  3. 次のレジストリ サブキーを見つけて右クリックします: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ActiveSetup\FavoritesList\Favorite<XX>

    注:

    このサブキーでは、 <XX> は 1 で始まる数値のプレースホルダーです。

  4. [削除] をクリックし、[はい] をクリックし、レジストリ エディターを終了します。

状態

この動作は仕様です。

データ収集

Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。