"Uživatel s tímto jménem již existuje. Použijte jiný název." chyba na portálu Microsoft 365

Problém

V Microsoft 365 se na portálu Microsoft 365 zobrazí chybová zpráva podobná následující:

Uživatel s tímto jménem již existuje. Použijte jiný název.

Příčina

K tomuto problému může dojít, pokud se uživatelské jméno už používá nebo pokud už existuje existující e-mailová adresa založená na uživatelském jménu.

Pokus o licencování selže, pokud proces zřizování zjistí, že jiný objekt už má uživatelské jméno nebo e-mailovou adresu, která odpovídá vytvořenému uživatelskému jménu.

Ve výchozím nastavení se uživatelům při přidání nebo přiřazení licence Exchange Online poskytne primární adresa SMTP, která je založená na jejich uživatelském jménu. Uživatelům se navíc poskytuje e-mailová adresa založená na doméně MODRD (Microsoft Online Direct Routing Domain), jako je například contoso.onmicrosoft.com. Kromě toho se při změně uživatelského jména může změnit i primární adresa SMTP. Alternativní adresy se ale neaktualizují ani neodeberou.

Tady je několik ukázkových scénářů.

Scénář 1

Přidá se uživatel s uživatelským jménem john@contoso.com, modrd organizace se contoso.onmicrosoft.com a uživateli je přiřazena licence Exchange Online. V tomto scénáři jsou k dispozici následující e-mailové adresy:

  • Uživatel má k dispozici primární adresu SMTP, která je john@contoso.com.
  • Uživateli je k dispozici alternativní e-mailová adresa, která je john@contoso.onmicrosoft.com.

Scénář 2

Přidá se uživatel s uživatelským jménem john@contoso.onmicrosoft.com, modrd organizace se contoso.onmicrosoft.com a uživateli je přiřazena licence Exchange Online. V tomto scénáři je k dispozici následující e-mailová adresa:

  • Uživatel má k dispozici primární adresu SMTP, která je john@contoso.onmicrosoft.com.

Scénář 3

Uživatelské jméno se změní z john@contoso.com na johnsmith@contoso.com. V tomto scénáři dochází k následujícím událostem:

  • Primární adresa SMTP může john@contoso.combýt změněna na johnsmith@contoso.com.
  • Alternativní e-mailová adresa se john@contoso.comnezmění. Proto při pokusu o přidání john@contoso.com později dojde k problémům.
  • Nevytvořila se žádná alternativní e-mailová adresa pro johnsmith@contoso.onmicrosoft.com .

Řešení

Pokud chcete tento problém vyřešit, proveďte jednu nebo více z následujících akcí:

  • Když přidáte uživatele, použijte jiné uživatelské jméno.
  • Když přidáte uživatele, vyhledejte a změňte stávající uživatelské jméno, abyste mohli použít uživatelské jméno, se kterým dochází k problému.
  • Když přidáte nebo přiřadíte uživatele k Exchange Online licenci, vyhledejte a změňte existující e-mailové adresy založené na uživatelském jménu, které se pokoušíte použít.

Pokud chcete zkontrolovat, jestli už e-mailová adresa existuje, postupujte takto:

  1. Připojte se k Exchangi Online pomocí vzdáleného PowerShellu. Další informace o tom, jak to provést, přejděte na následující web společnosti Microsoft:

    Připojení k Exchange Online pomocí vzdáleného PowerShellu

  2. Spusťte následující rutinu:

    get-mailbox| where {$_.EmailAddresses -match "user name"} | ft Name, RecipientType, EmailAddresses
    

    Poznámka

    "uživatelské jméno" je uživatelské jméno, se kterým dochází k problému.

  3. Na základě výsledků, které obdržíte po spuštění rutiny, aktualizujte nebo odstraňte stávající e-mailovou adresu.

Stále potřebujete pomoc? Přejděte na web Microsoft Community.