"Ein Benutzer mit diesem Namen ist bereits vorhanden. Verwenden Sie einen anderen Namen." fehler im Microsoft 365-Portal

Problem

In Microsoft 365 erhalten Sie im Microsoft 365-Portal eine Fehlermeldung wie die folgende:

Ein Benutzer mit diesem Namen ist bereits vorhanden. Verwenden Sie einen anderen Namen.

Ursache

Dieses Problem kann auftreten, wenn der Benutzername bereits verwendet wird oder wenn bereits eine E-Mail-Adresse vorhanden ist, die auf dem Benutzernamen basiert.

Der Lizenzierungsversuch schlägt fehl, wenn der Bereitstellungsprozess feststellt, dass ein anderes Objekt bereits über einen Benutzernamen oder eine E-Mail-Adresse verfügt, die mit dem erstellten Benutzernamen übereinstimmt.

Wenn Benutzern eine Exchange Online Lizenz hinzugefügt oder zugewiesen wird, erhalten die Benutzer standardmäßig eine primäre SMTP-Adresse, die auf ihrem Benutzernamen basiert. Außerdem erhalten Benutzer eine E-Mail-Adresse, die auf der Microsoft Online Direct Routing Domain (MODRD) basiert, z. B. contoso.onmicrosoft.com. Wenn ein Benutzername geändert wird, kann auch die primäre SMTP-Adresse geändert werden. Alternative Adressen werden jedoch nicht aktualisiert oder entfernt.

Im Folgenden finden Sie einige Beispielszenarien.

Szenario 1

Es wird ein Benutzer hinzugefügt, der john@contoso.comüber den Benutzernamen verfügt, der MODRD für die organization contoso.onmicrosoft.com ist, und dem Benutzer wird eine Exchange Online License zugewiesen. In diesem Szenario werden die folgenden E-Mail-Adressen bereitgestellt:

  • Dem Benutzer wird eine primäre SMTP-Adresse bereitgestellt, die ist john@contoso.com.
  • Dem Benutzer wird eine alternative E-Mail-Adresse bereitgestellt, die lautet john@contoso.onmicrosoft.com.

Szenario 2

Es wird ein Benutzer hinzugefügt, der john@contoso.onmicrosoft.comüber den Benutzernamen verfügt, der MODRD für die organization contoso.onmicrosoft.com ist, und dem Benutzer wird eine Exchange Online License zugewiesen. In diesem Szenario wird die folgende E-Mail-Adresse angegeben:

  • Dem Benutzer wird eine primäre SMTP-Adresse bereitgestellt, die ist john@contoso.onmicrosoft.com.

Szenario 3

Ein Benutzername wird von in john@contoso.comjohnsmith@contoso.comgeändert. In diesem Szenario treten die folgenden Ereignisse auf:

  • Die primäre SMTP-Adresse kann john@contoso.comin johnsmith@contoso.comgeändert werden.
  • Die alternative E-Mail-Adresse ( john@contoso.com) wird nicht geändert. Daher treten Probleme auf, wenn Sie versuchen, später hinzuzufügen john@contoso.com .
  • Es wird keine alternative E-Mail-Adresse für johnsmith@contoso.onmicrosoft.com erstellt.

Lösung

Führen Sie eine oder mehrere der folgenden Schritte aus, um dieses Problem zu beheben:

  • Wenn Sie einen Benutzer hinzufügen, verwenden Sie einen anderen Benutzernamen.
  • Wenn Sie einen Benutzer hinzufügen, suchen und ändern Sie den vorhandenen Benutzernamen, damit Sie den Benutzernamen verwenden können, mit dem das Problem auftritt.
  • Wenn Sie einen Benutzer einer Exchange Online Lizenz hinzufügen oder zuweisen, suchen und ändern Sie die vorhandenen E-Mail-Adressen, die auf dem Benutzernamen basieren, den Sie verwenden möchten.

Führen Sie die folgenden Schritte aus, um zu überprüfen, ob eine E-Mail-Adresse bereits vorhanden ist:

  1. Stellen Sie eine Verbindung mit Exchange Online mithilfe der Remote-PowerShell her. Weitere Informationen dazu finden Sie auf der folgenden Microsoft-Website:

    Herstellen einer Verbindung mit Exchange Online mithilfe der Remote-PowerShell

  2. Führen Sie das folgende Cmdlet aus:

    get-mailbox| where {$_.EmailAddresses -match "user name"} | ft Name, RecipientType, EmailAddresses
    

    Hinweis

    "Benutzername" ist der Benutzername, mit dem das Problem auftritt.

  3. Aktualisieren oder löschen Sie basierend auf den Ergebnissen, die Sie nach dem Ausführen des Cmdlets erhalten, die vorhandene E-Mail-Adresse.

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