«Det finnes allerede en bruker med dette navnet. Bruk et annet navn.» Feil i Microsoft 365-portalen
Problem
I Microsoft 365 får du en feilmelding som er som følger i Microsoft 365-portalen:
Det finnes allerede en bruker med dette navnet. Bruk et annet navn.
Årsak
Dette problemet kan oppstå hvis brukernavnet allerede er i bruk, eller hvis det allerede finnes en eksisterende e-postadresse som er basert på brukernavnet.
Lisensieringsforsøket mislykkes hvis klargjøringsprosessen fastslår at et annet objekt allerede har et brukernavn eller en e-postadresse som samsvarer med brukernavnet som opprettes.
Når brukere legges til eller tilordnes en Exchange Online-lisens, får brukerne som standard en primær SMTP-adresse som er basert på brukernavnet. Brukerne får også en e-postadresse som er basert på Microsoft Online Direct Routing Domain (MODRD), for eksempel contoso.onmicrosoft.com. I tillegg, når et brukernavn endres, kan den primære SMTP-adressen også endres. Alternative adresser oppdateres eller fjernes imidlertid ikke.
Her er noen eksempler på scenarioer.
Scenario 1
En bruker legges til som har et brukernavn på john@contoso.com, MODRD for organisasjonen er contoso.onmicrosoft.com, og brukeren er tilordnet en Exchange Online-lisens. I dette scenarioet er følgende e-postadresser angitt:
- Brukeren leveres med en primær SMTP-adresse som er john@contoso.com.
- Brukeren leveres med en alternativ e-postadresse som er john@contoso.onmicrosoft.com.
Scenario 2
En bruker legges til som har et brukernavn på john@contoso.onmicrosoft.com, MODRD for organisasjonen er contoso.onmicrosoft.com, og brukeren er tilordnet en Exchange Online-lisens. I dette scenarioet er følgende e-postadresse angitt:
- Brukeren leveres med en primær SMTP-adresse som er john@contoso.onmicrosoft.com.
Scenario 3
Et brukernavn endres fra john@contoso.com til johnsmith@contoso.com. I dette scenarioet forekommer følgende hendelser:
- Den primære SMTP-adressen, john@contoso.comkan endres til johnsmith@contoso.com.
- Den alternative e-postadressen er john@contoso.comikke endret. Det oppstår derfor problemer hvis du prøver å legge til john@contoso.com senere.
- Ingen alternativ e-postadresse for johnsmith@contoso.onmicrosoft.com opprettes.
Løsning
Gjør ett eller flere av følgende for å løse dette problemet:
- Når du legger til en bruker, bruker du et annet brukernavn.
- Når du legger til en bruker, kan du finne og endre det eksisterende brukernavnet slik at du kan bruke brukernavnet som du opplever problemet med.
- Når du legger til eller tilordner en bruker til en Exchange Online-lisens, finner og endrer du de eksisterende e-postadressene som er basert på brukernavnet du prøver å bruke.
Følg disse trinnene for å kontrollere om det allerede finnes en e-postadresse:
Koble til Exchange Online ved hjelp av ekstern PowerShell. Hvis du vil ha mer informasjon om hvordan du gjør dette, kan du gå til følgende Microsoft-nettsted:
Kjør følgende cmdlet:
get-mailbox| where {$_.EmailAddresses -match "user name"} | ft Name, RecipientType, EmailAddresses
Obs!
Brukernavnet er brukernavnet du opplever problemet med.
Basert på resultatene du mottar etter at du har kjørt cmdleten, kan du oppdatere eller slette den eksisterende e-postadressen.
Trenger du fremdeles hjelp? Gå til Microsoft Community.
Tilbakemeldinger
https://aka.ms/ContentUserFeedback.
Kommer snart: Gjennom 2024 faser vi ut GitHub Issues som tilbakemeldingsmekanisme for innhold, og erstatter det med et nytt system for tilbakemeldinger. Hvis du vil ha mer informasjon, kan du se:Send inn og vis tilbakemelding for