Při spuštění aplikace Sady Office se zobrazí chyba "Aplikaci Microsoft nelze otevřít kvůli problému"

Příznaky

Při pokusu o spuštění libovolné Office pro Mac aplikace (Microsoft Word, Microsoft Excel, Microsoft PowerPoint, Microsoft Entourage nebo Microsoft Outlook pro Mac) v systému Mac OS X 10.6.x (Snow Leopard), zobrazí se následující chybová zpráva:

Microsoft <application_name> cannot be opened because of a problem.Check with the developer to make sure Microsoft <application_name> works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X.

Příčina

K této chybě dochází, pokud byla aplikace Office přesunuta nebo duplikována.

Řešení

Krok 1: Kontrola cesty k programu

Po zobrazení chybové zprávy si prohlédněte komentáře v části Podrobnosti o problému a konfigurace systému. Poznamenejte si "Cestu", která je uvedena v chybové zprávě, a pak zavřete okno chybové zprávy. Cesta musí být následující:

  • Macintosh HD\Applications\Microsoft Office 2008

  • Macintosh HD\Applications\Microsoft Office 2011

Pokud se cesta v chybové zprávě liší, musíte přesunout složku aplikace do jejího umístění pro opravu. Postupujte takto:

  1. Vyhledejte složku Office 2008.
  2. Kliknutím vyberte složku.
  3. V nabídce Finder klikněte na Upravit a pak vyberte Kopírovat Microsoft Office 2008 nebo Kopírovat Microsoft Office 2011.
  4. V nabídce Finder klikněte na Přejít a pak vyberte Aplikace.
  5. V nabídce Finder klikněte na Upravit a pak vyberte Vložit položku.
  6. Spusťte aplikaci Office a zjistěte, jestli se problém vyřešil.

Pokud k problému dochází i nadále, můžou být duplicitní položky.

Krok 2: Odstranění duplicitních položek

Chcete-li odstranit duplicitní položky, postupujte takto:

  1. V nabídce Finder klikněte na Soubor a potom klikněte na Najít.

  2. Do vyhledávacího pole zadejte název programu a stiskněte klávesu Enter. Zadejte například Excel.

    Snímek obrazovky s výsledkem zadáním excelu do vyhledávacího pole

    Snímek obrazovky s výsledkem zadáním outlooku do vyhledávacího pole

  3. Ve výsledcích vyhledejte duplicitní instance ikony Excelu. Pokud je k dispozici pouze jedna ikona, přejděte ke kroku 3. Pokud existuje několik ikon Excelu, vyberte duplicitní ikonu. V nabídce Finder klikněte na Soubor a pak vyberte Přesunout do koše.

  4. Vysypte koš.

  5. Spusťte aplikaci Office. Pokud potíže přetrvávají, odeberte a znovu nainstalujte aplikaci Office.

Krok 3: Odebrání a následná opětovná instalace Office

Office 2011

Pokud chcete odebrat Office 2011, postupujte takto:

  1. Ukončete všechny aplikace.
  2. Ve Finderu klikněte na Přejít a vyberte Počítač.
  3. Otevřete pevný disk (Macintosh HD) a pak otevřete složku Aplikace.
  4. Kliknutím vyberte Microsoft Office 2011 přetažením do koše.
  5. Přeinstalujte Office pro Mac 2011.

Office 2008

Chcete-li odebrat Office 2008, postupujte takto:

  1. Ukončí všechny aplikace.
  2. Ve Finderu klikněte na Přejít a pak vyberte Počítač.
  3. Otevřete Macintosh HD a pak otevřete složku Aplikace.
  4. Otevřete složku Microsoft Office 2008.
  5. Otevřete složku Další nástroje.
  6. Poklikejte na odebrat soubor Office. Otevře se okno Odebrat Office.
  7. Klikněte na Continue (Pokračovat).
  8. Postupujte podle pokynů, které jsou k dispozici.
  9. Přeinstalujte office 2008 na počítači.