ข้อผิดพลาด "ไม่สามารถเเปิดโปรแกรม Microsoft <ได้เนื่องจากมีปัญหา>” เมื่อคุณเริ่มโปรแกรม Office

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2431353 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณลองเริ่มการทำงานของโปรแกรมประยุกต์ Office for Mac ใดๆ (Microsoft Word, Microsoft Excel, Microsoft PowerPoint, Microsoft Entourage หรือ Microsoft Outlook for Mac) ใน Mac OS X 10.6.x (Snow Leopard) คุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:

ไม่สามารถเปิด Microsoft <application_name> ได้เนื่องจากมีปัญหา
ตรวจสอบกับนักพัฒนาเพื่อให้แน่ใจว่า Microsoft <application_name> ทำงานร่วมกับ Mac OS X รุ่นนี้ คุณอาจจำเป็นต้องติดตั้งโปรแกรมประยุกต์ใหม่ ต้องแน่ใจว่าได้ติดตั้งโปรแกรมปรับปรุงใดๆ ที่มีอยู่สำหรับโปรแกรมประยุกต์และ Mac OS X

สาเหตุ

ข้อผิดพลาดนี้เกิดขึ้นหากโปรแกรม Office ถูกย้ายหรือทำซ้ำ

การแก้ไข

ขั้นตอนที่ 1: ตรวจสอบเส้นทางของโปรแกรม

เมื่อปรากฏข้อความแสดงข้อผิดพลาด ให้ดูข้อคิดเห็นใน "รายละเอียดของปัญหาและการกำหนดค่าระบบ" หมายเหตุ "เส้นทาง" ที่แสดงรายการอยู่ในข้อความแสดงข้อผิดพลาด และจากนั้น ปิดกล่องข้อความแสดงข้อผิดพลาด เส้นทางต้องเป็นดังนี้:

Macintosh HD\Applications\Microsoft Office 2008

Macintosh HD\Applications\Microsoft Office 2011


หากเส้นทางในข้อความแสดงข้อผิดพลาดไม่ตรงกัน คุณต้องย้ายโฟลเดอร์โปรแกรมประยุกต์ไปไว้ในตำแหน่งที่ถูกต้อง โดยให้ทำตามขั้นตอนต่อไปนี้

  1. ค้นหาตำแหน่งของโฟลเดอร์ Office 2008
  2. คลิกเพื่อเลือกโฟลเดอร์
  3. ในเมนู ตัวค้นหา คลิก แก้ไข แล้วเลือก คัดลอก Microsoft Office 2008 หรือ คัดลอก Microsoft Office 2011
  4. ในเมนู ตัวค้นหา คลิก ไป แล้วเลือก โปรแกรมประยุกต์
  5. ในเมนู ตัวค้นหา คลิก แก้ไข แล้วเลือก วางรายการ
  6. เริ่มการทำงานของโปรแกรม Office เพื่อดูว่าปัญหาได้รับการแก้ไขหรือไม่

ถ้าปัญหายังคงเกิดขึ้น อาจมีรายการที่ซ้ำกัน

ขั้นตอนที่ 2: ลบรายการที่ซ้ำกัน


เมื่อต้องการลบรายการที่ซ้ำกัน ให้ทำตามขั้นตอนเหล่านี้:

  1. ในเมนู ตัวค้นหา คลิก แฟ้ม แล้วคลิก ค้นหา
  2. ในกล่องค้นหา พิมพ์ชื่อโปรแกรม จากนั้น กด Enter ตัวอย่างเช่น พิมพ์ Excel

  3. ยุบรูปภาพนี้ขยายรูปภาพนี้
    2431364


    ยุบรูปภาพนี้ขยายรูปภาพนี้
    2505447

  4. ในผลลัพธ์ ค้นหาอินสแตนซ์ที่ซ้ำกันของไอคอน Excel ถ้ามีเพียงไอคอนเดียว ให้ไปที่ "ขั้นตอนที่ 3" ถ้ามีไอคอน Excel หลายไอคอน เลือกไอคอนที่ซ้ำกัน ในเมนู ตัวค้นหา คลิก iแฟ้ม แล้วเลือก ย้ายไปที่ถังขยะ
  5. ลบข้อมูลในถังขยะ
  6. เริ่มโปรแกรม Office ถ้าปัญหายังคงเกิดขึ้น เอาโปรแกรมออก และติดตั้งโปรแกรม Office ใหม่

ขั้นตอนที่ 3: เอา Office ออกและติดตั้งใหม่



Office 2011

เมื่อต้องเอา Office 2011 ออก ให้ทำตามขั้นตอนเหล่านี้:
  1. จบการทำงานของโปรแกรมประยุกต์ทั้งหมด
  2. ใน ตัวค้นหา คลิก ไป เลือก คอมพิวเตอร์
  3. เปิดฮาร์ดไดรฟ์ของคุณ (Macintosh HD) แล้วเปิดโฟลเดอร์โปรแกรมประยุกต์
  4. คลิกเพื่อเลือก Microsoft Office 2011 ลาก และปล่อยไว้ในถังขยะ
  5. ติดตั้ง Office for Mac 2011 ใหม่

Office 2008

เมื่อต้องเอา Office 2008 ออก ให้ทำตามขั้นตอนเหล่านี้:
  1. จบการทำงานของโปรแกรมประยุกต์ทั้งหมด
  2. ใน ตัวค้นหา คลิก ไป แล้วเลือก คอมพิวเตอร์
  3. เปิด Macintosh HD แล้วเปิดโฟลเดอร์ โปรแกรมประยุกต์
  4. เปิดโฟลเดอร์ Microsoft Office 2008
  5. เปิดโฟลเดอร์ เครื่องมือเพิ่มเติม
  6. คลิกสองครั้งที่ เอาแฟ้ม Office ออก หน้าต่าง "เอา Office ออก" จะเปิด
  7. คลิก ดำเนินการต่อ
  8. ทำตามคำแนะนำที่กำหนดไว้
  9. ติดตั้ง Office 2008 บนคอมพิวเตอร์ของคุณใหม่
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

คุณสมบัติ

หมายเลขบทความ (Article ID): 2431353 - รีวิวครั้งสุดท้าย: 2 ธันวาคม 2554 - Revision: 1.0
ใช้กับ
  • Microsoft Office Word 2008 for Mac
  • Microsoft Office Excel 2008 for Mac
  • Microsoft Office PowerPoint 2008 for Mac
  • Microsoft Entourage 2008 for Mac
  • Microsoft Excel 2011 for Mac
  • Microsoft Outlook 2011 for Mac
  • Microsoft PowerPoint 2011 for Mac
  • Microsoft Word 2011 for Mac
Keywords: 
KB2431353

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com