A time-out occurs or you experience slow performance when you save an Appointment activity after you run the Internet Information Services reset in Microsoft Dynamics CRM 4.0

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Article ID: 2431852 - View products that this article applies to.
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SYMPTOMS

When you save an Appointment activity every twenty minutes or immediately after you run the Internet Information Services (IIS) reset in Microsoft Dynamics CRM 4.0, a time-out occurs or you experience slow performance. Additionally, the following error is logged in the Microsoft Dynamics CRM Application trace logs:

>select systemuser0.FullName as 'fullname', systemuser0.CalendarId as 'calendarid', systemuser0.Skills as 'skills', systemuser0.SystemUserId as 'systemuserid' from SystemUser as systemuser0 where ((systemuser0.DeletionStateCode in (0)) and (systemuser0.SystemUserId = 'GUID'))

Note The GUID placeholder represents the actual GUID for the SystemUserId value. For example, the GUID may be "d118caa2-f40c-db11-8871-000f2097a3f8."

CAUSE

This problem occurs because the Microsoft Dynamics CRM scheduling engine is used when the Appointment activity is saved. The scheduling engine checks appointment conflicts between Microsoft Dynamics CRM resources. The scheduling engine uses a cache file that contains information about all Microsoft Dynamics CRM resources. However, the information is invalidated or expires periodically. When an organization has lots of resources, it takes a long time to rebuild the cache file because only a user record is added to the cache file every time.

RESOLUTION

This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes


Note This problem was originally fixed in Update Rollup 14 for Microsoft Dynamics CRM 4.0.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2389019 Update Rollup 14 for Microsoft Dynamics CRM 4.0 is available

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about Microsoft Business Solutions CRM software hotfix and update package terminology, click the following article number to view the article in the Microsoft Knowledge Base:
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

Properties

Article ID: 2431852 - Last Review: November 18, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Dynamics CRM 4.0
Keywords: 
kbmbsmigrate kbsurveynew kbfix kbexpertiseinter kbqfe kberrmsg KB2431852

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