Oppdateringer for installasjon av .NET Framework 2.0 SP2 og .NET Framework 3.0 SP2 kan kjedeinstallere andre oppdateringer

Artikkeloversettelser Artikkeloversettelser
Artikkel-ID: 2436257 - Vis produkter som denne artikkelen gjelder for.
Vis alt | Skjul alt

Symptom

Når du installerer enkelte oppdateringer for Microsoft .NET Framework 2.0 Service Pack 2 (SP2) eller for Microsoft .NET Framework 3.0 SP2, vil disse oppdateringene kjedeinstallere flere oppdateringer. Disse ekstra oppdateringene må installeres for å oppfylle nye avhengigheter i bestemte .NET Framework-komponenter. 

Mer informasjon

Når du installerer bestemte oppdateringer for .NET Framework 2.0 SP2 eller .NET Framework 3.0 SP2, fører disse oppdateringene til at det installeres flere oppdateringer. Dette skjer fordi Extended Protection Security Advisory introduserte den nye utvidede beskyttelsesfunksjonen som inkluderer nye avhengigheter på nylig introduserte typer. Denne nye funksjonen består av ny funksjonalitet i .NET Framework 2.0 SP2 og i funksjonslagene i .NET Framework 3.0 SP2. Den nye WCF-funksjonen Windows Communication Foundation) i funksjonslaget for .NET Framework 3.0 SP2 har en avhengighet i den tilsvarende nye funksjonen i funksjonslaget for .NET Framework 2.0 SP2 og den nye typen. Den nye ASP.NET-funksjonen i funksjonslaget i .NET Framework 2.0 SP2 har også en ny avhengighet i den nye funksjonen i System.Net (nettverksstakk).

Oppdateringer for .NET Framework-komponenter er kumulative. Derfor ble det utgitt en oppdatering for ASP.NET-komponenten, og etter dette vil Extended Protection Security Advisory alltid inneholde den nye ASP.NET-funksjonen for den utvidede beskyttelsen. Denne nye funksjonen krever at den tidligere nevnte funksjonsavhengigheten (på den nye typen) oppfylles. Oppdateringer for WCF- og ASP.NET-komponenter vil kjedeinstallere flere oppdateringer etter behov for å oppfylle denne avhengigheten. Hvis denne avhengigheten ikke oppfylles, kan du oppleve problemet som beskrives i følgende artikkel i Microsoft Knowledge Base: 
2262911 Unntaksfeilen "Kan ikke laste typen 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'" når du har installert oppdatering 982167 eller oppdatering 982168
  • I Windows XP og på Windows Server 2003 vil oppdateringer for ASP.NET-komponenten i .NET Framework 2.0 SP2 også installere følgende oppdatering:
    980773 Beskrivelse av NCL-oppdateringen for .NET Framework 3.5 Service Pack 1 og .NET Framework 2.0 Service Pack 2 i Windows XP og på Windows Server 2003: 08.06.10
  • I Windows Vista SP1 og på Windows Server 2008 vil oppdateringer for ASP.NET-komponenten i .NET Framework 2.0 SP2 også installere følgende oppdatering:
    980843 Beskrivelse av NCL-oppdateringen for Microsoft .NET Framework 3.5 Service Pack 1 for Windows Vista Service Pack 1 og Windows Server 2008 Service Pack 1: 08.06.10
  • I Windows Vista SP2 og på Windows Server 2008 vil oppdateringer for ASP.NET-komponenten i .NET Framework 2.0 SP2 også installere følgende oppdatering:
    980842 Beskrivelse av NCL-oppdateringen for Microsoft .NET Framework 3.5 Service Pack 1 for Windows Vista Service Pack 2 og Windows Server 2008 Service Pack 2: 08.06.10
  • I Windows XP og på Windows Server 2003 vil oppdateringer for WCF-komponenten i .NET Framework 3.0 SP2 også installere følgende oppdateringer:  
    980773 Beskrivelse av NCL-oppdateringen for .NET Framework 3.5 Service Pack 1 og .NET Framework 2.0 Service Pack 2 i Windows XP og på Windows Server 2003: 08.06.10
    976765 Beskrivelse av ASP.NET-oppdateringen for .NET Framework 3.5 Service Pack 1 og .NET Framework 2.0 Service Pack 2 i Windows XP og på Windows Server 2003: 08.06.10
  • I Windows Vista SP1 og på Windows Server 2008 vil oppdateringer for WCF-komponenten i .NET Framework 3.0 SP2 også installere følgende oppdateringer:
    980843 Beskrivelse av NCL-oppdateringen for Microsoft .NET Framework 3.5 Service Pack 1 for Windows Vista Service Pack 1 og Windows Server 2008 Service Pack 1: 08.06.10
    976767 Beskrivelse av ASP.NET-oppdateringen for Microsoft .NET Framework 3.5 Service Pack 1 for Windows Vista Service Pack 1 og Windows Server 2008 Service Pack 1: 08.06.10
  • I Windows Vista SP2 og på Windows Server 2008 vil oppdateringer for WCF-komponenten i .NET Framework 3.0 SP2 også installere følgende oppdateringer:
    980842 Beskrivelse av NCL-oppdateringen for Microsoft .NET Framework 3.5 Service Pack 1 for Windows Vista Service Pack 2 og Windows Server 2008 Service Pack 2: 08.06.10
    976768 Beskrivelse av ASP.NET-oppdateringen for Microsoft .NET Framework 3.5 Service Pack 1 for Windows Vista Service Pack 2 og Windows Server 2008 Service Pack 2: 08.06.10
Obs! Dette er en "FAST PUBLISH"-artikkel som er opprettet direkte innenfor Microsofts kundestøtteorganisasjon. Informasjonen her leveres "som den er" som svar på problemer som kan oppstå. Som et resultat av den korte tiden det tar å gjøre materialet tilgjengelig, kan det inneholde skrivefeil, og det kan når som helst og uten forvarsel bli revidert. Se Vilkår for bruk for mer informasjon.

Egenskaper

Artikkel-ID: 2436257 - Forrige gjennomgang: 26. oktober 2010 - Gjennomgang: 1.0
Informasjonen i denne artikkelen gjelder:
  • Microsoft .NET Framework 3.0 Service Pack 2
  • Microsoft .NET Framework 2.0 Service Pack 2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 Service Pack 2 på følgende plattformer
    • Windows Server 2008 for Itanium-Based Systems
    • Windows Server 2008 Datacenter
    • Windows Server 2008 Enterprise
    • Windows Server 2008 Standard
    • Windows Web Server 2008
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
  • Windows Vista Service Pack 2 på følgende plattformer
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Starter
    • Windows Vista Ultimate
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Home Basic 64-bit edition
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Business 64-bit edition
  • Windows Vista Service Pack 1 på følgende plattformer
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Starter
    • Windows Vista Ultimate
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Home Basic 64-bit edition
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Business 64-bit edition
  • Microsoft Windows Server 2003 Service Pack 2 på følgende plattformer
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Service Pack 3 på følgende plattformer
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Nøkkelord: 
kbbug kbexpertiseinter kbsecbulletin kbsecurity kbsecvulnerability KB2436257

Gi tilbakemelding

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com